Skip Menu |
 

This queue is for tickets about the DBIx-Class-Schema-PopulateMore CPAN distribution.

Report information
The Basics
Id: 99400
Status: new
Priority: 0/
Queue: DBIx-Class-Schema-PopulateMore

People
Owner: Nobody in particular
Requestors: mst [...] shadowcat.co.uk
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: test_requires on SQLT needs increasing or you need to ship a ddl_dir
Date: Thu, 9 Oct 2014 17:31:03 +0000
To: bugs-DBIx-Class-Schema-PopulateMore [...] rt.cpan.org
From: Matt S Trout <mst [...] shadowcat.co.uk>
Download (untitled) / with headers
text/plain 924b
18:18 < ashimema> DBIx::Class::Storage::DBI::deployment_statements(): Can't deploy without a ddl_dir or SQL::Translator >= 0.11018 18:19 <@mst> note: I installed everything into a local::lib against my 5.14.2 debian perl 18:20 <@mst> I think you already have SQL::Translator, but at an older version 18:20 < ashimema> yup.. 18:20 <@mst> test_requires 'SQL::Translator' => '0.11007'; 18:21 <@mst> there's the problem So, either the test_requires needs upping to 0.11018, or you need to create a ddl_dir at release time so SQL::Translator isn't a dependency for user testing. -- Matt S Trout - Shadowcat Systems - Perl consulting with a commit bit and a clue http://shadowcat.co.uk/blog/matt-s-trout/ http://twitter.com/shadowcat_mst/ Email me now on mst (at) shadowcat.co.uk and let's chat about how our CPAN commercial support, training and consultancy packages could help your team.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.