Skip Menu |
 

This queue is for tickets about the App-perlbrew CPAN distribution.

Report information
The Basics
Id: 98907
Status: open
Priority: 0/
Queue: App-perlbrew

People
Owner: Nobody in particular
Requestors: matteo [...] corti.li
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.71
Fixed in: (no value)



Subject: Perlbrew list and wrong version number
Download (untitled) / with headers
text/plain 951b
I installed two version of Perl using --as (naming the version with the major number only) - 5.20.0 installed as 5.20 and - 5.20.0 with threading installed as 5.20t This is the output of perlbrew list * 5.20 (5.20.0) 5.20t (5.20.0) I then upgraded Perl to 5.20.1 using $ perlbrew upgrade-perl Upgrading 5.20 to 5.20.1 Installing /Users/corti/perl5/perlbrew/build/perl-5.20.1 into ~/perl5/perlbrew/perls/5.20 This could take a while. You can run the following command on another shell to track the status: tail -f ~/perl5/perlbrew/build.perl-5.20.1.log 5.20 is successfully installed. Perl seems to be correctly upgraded (v5.20.1): $ perl -version This is perl 5, version 20, subversion 1 (v5.20.1) built for darwin-2level But perlbrew list does not recognise the new version and calling perlbrew upgrade-perl does the upgrade again $ perlbrew list * 5.20 (5.20.0) 5.20t (5.20.0)
Download (untitled) / with headers
text/plain 187b
Thanks for the report. The reason for this is that perl versions are cached since this pull request: https://github.com/gugod/App-perlbrew/pull/381 but without proper invalidation.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.