Skip Menu |
 

This queue is for tickets about the Dist-Zilla-Plugin-ReportVersions-Tiny CPAN distribution.

Maintainer(s)' notes

This module is deprecated!

This distribution has reached end-of-life now that better alternatives exist.

The recommended alternative is Dist::Zilla::Plugin::Test::ReportPrereqs.

Report information
The Basics
Id: 98903
Status: new
Priority: 0/
Queue: Dist-Zilla-Plugin-ReportVersions-Tiny

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: test failures
Download (untitled) / with headers
text/plain 3.1k
It looks like you aren't parsing versions properly: PERL_DL_NONLAZY=1 /Users/ether/perl5/perlbrew/perls/8.9/bin/perl "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/00-compile.t ................. ok # # # Generated by Dist::Zilla::Plugin::ReportVersions::Tiny v # perl: 5.008009 (wanted any version) on darwin from /Users/ether/perl5/perlbrew/perls/8.9/bin/perl # # Dist::Zilla => 5.020 (want 3.101390) # Dist::Zilla::File::FromCode => 5.020 (want any version) # Dist::Zilla::Role::FileGatherer => 5.020 (want any version) # Dist::Zilla::Role::PrereqSource => 5.020 (want any version) # Dist::Zilla::Role::TextTemplate => 5.020 (want any version) # ExtUtils::MakeMaker => 6.98 (want 6.30) # IO::Handle => 1.27 (want any version) # IPC::Open3 => 1.03 (want any version) # Moose => 2.1300 (want any version) # Test::Deep => 0.113 (want any version) # Test::Fatal => 0.013 (want any version) # Test::MockObject => 1.20140408 (want any version) # Test::More => 1.001006 (want 0.88) # Test::Warn => 0.30 (want any version) # lib => 0.61 (want any version) # strict => 1.03 (want any version) # version => 0.9908 (want 0.9901) # warnings => 1.05_01 (want any version) # # Thanks for using my code. I hope it works for you. # If not, please try and include this output in the bug report. # That will help me reproduce the issue and solve your problem. # t/000-report-versions-tiny.t ... ok # Failed test 'can collect modules' # at t/3part_prereq.t line 58. # got: 'Invalid version format (non-numeric data) at /Users/ether/.cpanm/work/1410803633.9169/Dist-Zilla-Plugin-ReportVersions-Tiny-1.10/blib/lib/Dist/Zilla/Plugin/ReportVersions/Tiny.pm line 103. # ' # expected: undef Invalid version format (non-numeric data) at /Users/ether/.cpanm/work/1410803633.9169/Dist-Zilla-Plugin-ReportVersions-Tiny-1.10/blib/lib/Dist/Zilla/Plugin/ReportVersions/Tiny.pm line 103. # Tests were run but no plan was declared and done_testing() was not seen. # Looks like your test exited with 255 just after 2. t/3part_prereq.t ............... Dubious, test returned 255 (wstat 65280, 0xff00) Failed 1/2 subtests t/exclude.t .................... ok t/include.t .................... ok t/version-compare-as-number.t .. ok Test Summary Report ------------------- t/3part_prereq.t (Wstat: 65280 Tests: 2 Failed: 1) Failed test: 2 Non-zero exit status: 255 Parse errors: No plan found in TAP output Files=6, Tests=25, 3 wallclock secs ( 0.03 usr 0.02 sys + 2.71 cusr 0.13 csys = 2.89 CPU) Result: FAIL


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.