Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 98150
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.4207
Fixed in: 0.4208



Subject: Fails with bleadperl
Download (untitled) / with headers
text/plain 1.3k
With a fresh bleadperl, e.g. v5.21.2-166-gb756670, I cannot run a smoker anymore. Configuring L/LE/LEONT/Module-Build-0.4207.tar.gz with Makefile.PL CPAN::Reporter not installed. No reports will be sent. Can't locate Module/Build/Version.pm in @INC (you may need to install the Module::Build::Version module) (@INC contains: lib /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/lib/site_perl/5.21.3/x86_64-linux-ld /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/lib/site_perl/5.21.3 /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/lib/5.21.3/x86_64-linux-ld /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/lib/5.21.3 .) at lib/Module/Build/Compat.pm line 12. BEGIN failed--compilation aborted at lib/Module/Build/Compat.pm line 12. Compilation failed in require at Makefile.PL line 13. BEGIN failed--compilation aborted at Makefile.PL line 13. Warning: No success on command[/home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/bin/perl Makefile.PL] LEONT/Module-Build-0.4207.tar.gz /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/bin/perl Makefile.PL -- NOT OK Advice? Thanks,
Subject: Re: [rt.cpan.org #98150] Fails with bleadperl
Date: Mon, 18 Aug 2014 22:09:11 +0200
To: bug-Module-Build [...] rt.cpan.org
From: Leon Timmermans <leont [...] cpan.org>
Download (untitled) / with headers
text/plain 1.8k
On Mon, Aug 18, 2014 at 9:38 PM, Andreas Koenig via RT < bug-Module-Build@rt.cpan.org> wrote: Show quoted text
> Mon Aug 18 15:38:37 2014: Request 98150 was acted upon. > Transaction: Ticket created by ANDK > Queue: Module-Build > Subject: Fails with bleadperl > Broken in: 0.4207 > Severity: Critical > Owner: Nobody > Requestors: ANDK@cpan.org > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=98150 > > > > With a fresh bleadperl, e.g. v5.21.2-166-gb756670, I cannot run a smoker > anymore. > > Configuring L/LE/LEONT/Module-Build-0.4207.tar.gz with Makefile.PL > CPAN::Reporter not installed. No reports will be sent. > Can't locate Module/Build/Version.pm in @INC (you may need to install the > Module::Build::Version module) (@INC contains: lib > /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/lib/site_perl/5.21.3/x86_64-linux-ld > /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/lib/site_perl/5.21.3 > /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/lib/5.21.3/x86_64-linux-ld > /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/lib/5.21.3 > .) at lib/Module/Build/Compat.pm line 12. > BEGIN failed--compilation aborted at lib/Module/Build/Compat.pm line 12. > Compilation failed in require at Makefile.PL line 13. > BEGIN failed--compilation aborted at Makefile.PL line 13. > Warning: No success on > command[/home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/bin/perl > Makefile.PL] > LEONT/Module-Build-0.4207.tar.gz > > /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.2-166-gb756670/127e/bin/perl > Makefile.PL -- NOT OK >
Thanks for your bug-report. I just shipped 0.4208 containing a fix. This totally slipped past my guard because it does work on all perls from 5.10 - 5.20. Leon
CC: ANDK [...] cpan.org
Subject: Re: [rt.cpan.org #98150] Fails with bleadperl
Date: Tue, 19 Aug 2014 04:10:49 +0200
To: bug-Module-Build [...] rt.cpan.org
From: Andreas Koenig <andreas.koenig.7os6VVqR [...] franz.ak.mind.de>
Download (untitled) / with headers
text/plain 328b
Show quoted text
>>>>> On Mon, 18 Aug 2014 16:09:42 -0400, "Leon Timmermans via RT" <bug-Module-Build@rt.cpan.org> said:
Show quoted text
> Thanks for your bug-report. I just shipped 0.4208 containing a fix. This > totally slipped past my guard because it does work on all perls from 5.10 - > 5.20.
Cool, thanks for the ultraquick release! -- andreas


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.