Skip Menu |
 

This queue is for tickets about the libwww-perl CPAN distribution.

Report information
The Basics
Id: 98
Status: resolved
Priority: 0/
Queue: libwww-perl

People
Owner: Nobody in particular
Requestors: wlkngowl [...] i-2000.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 5.51
Fixed in: (no value)



Subject: LWP::UserAgent does not give a proper error with https:// URLs if Crypt::SSLeay is not installed
Download (untitled) / with headers
text/plain 497b
When using LWP::UserAgent and LWP::Simple (and probably other modules), if a request for a secured page (https protocol) is given when Crypt::SSLeay is not installed on the machine, the error returned is that the page cannot be loaded, but no warnings are given that it is unable to laod the page because the required Perl module is missing. A workaround is in the module to use: require Crypt::SSLeay; use LWP::UserAgent; but this shouldn't be necessary. At least a warning would be nice.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.