Skip Menu |
 

This queue is for tickets about the GD CPAN distribution.

Report information
The Basics
Id: 97760
Status: open
Priority: 0/
Queue: GD

People
Owner: Nobody in particular
Requestors: KABANOID [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: gif animation support in Ubuntu Linux
Date: Tue, 5 Aug 2014 16:08:40 +0400
To: bug-GD [...] rt.cpan.org
From: Mike Katasonov <kabanoid [...] cpan.org>
Download (untitled) / with headers
text/plain 494b
Hello. I am using GD $VERSION = '2.53'; and gdlib version 2.1.0 However when I try to call $im->gifanimbegin, perl script dies with the string: "libgd 2.0.33 or higher required for animated GIF support" Additional info: perl -v This is perl 5, version 18, subversion 2 (v5.18.2) built for x86_64-linux-gnu-thread-multi (with 41 registered patches, see perl -V for more detail) uname -a Linux xxx 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
Download (untitled) / with headers
text/plain 334b
On Tue Aug 05 09:08:49 2014, KABANOID wrote: Show quoted text
> Hello. > I am using GD $VERSION = '2.53'; and gdlib version 2.1.0 > > However when I try to call $im->gifanimbegin, perl script dies with the > string: > > "libgd 2.0.33 or higher required for animated GIF support"
Just adding my voice to say I'm also suffering from this bug. -Brian
Download (untitled) / with headers
text/plain 466b
I now have a patch that makes gif animations work again. Basically the issue lies with the fact that Makefile.PL checks if the minor version (well, really the "patch" version if you go by semver.org) is >= 33. That's fine for the 2.0.x series of libgd, however, with 2.1.x that fails. I've modified it to pull out the middle version number and check if that is > 0 or if the last number is >= 33. Works for local setup (Ubuntu 14.04, libgd version '2.1.1-dev@').
Subject: animgif-2-1-x.patch
Download animgif-2-1-x.patch
text/x-diff 693b
--- Makefile.PL 2014-04-01 11:23:20.000000000 -0300 +++ Makefile.PL.new 2014-09-10 23:41:44.732099869 -0300 @@ -296,8 +296,10 @@ ($$lib_gd_path = $libdir) =~ s!/[^/]+$!!; $$options = $features; - my ($minor) = $version =~ /^2\.\d+\.(\d+)$/; - $$options .= " GD_UNCLOSEDPOLY GD_ANIMGIF GD_FTCIRCLE VERSION_33" if defined($minor) && $minor >= 33; + my ($mid,$minor) = $version =~ /^2\.(\d+)\.(\d+)/; + if( defined $mid && defined $minor ) { + $$options .= " GD_UNCLOSEDPOLY GD_ANIMGIF GD_FTCIRCLE VERSION_33" if $mid > 0 || $minor >= 33; + } my @correct_inc = map {s/^-I// && $_} split /\s+/,$cflags; check_for_stray_headers($includedir,@correct_inc);
FYI: This is basically a duplicate of RT #89592 (also https://github.com/lstein/Perl-GD/pull/9)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.