Skip Menu |
 

This queue is for tickets about the Unicode-Normalize CPAN distribution.

Report information
The Basics
Id: 97281
Status: rejected
Priority: 0/
Queue: Unicode-Normalize

People
Owner: Nobody in particular
Requestors: blue [...] thisisnotmyrealemail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.18
Fixed in: (no value)



Subject: 1.18 doesn't install under perl 5.18
Download (untitled) / with headers
text/plain 3.5k
1.18 installs fine under perl 5.16 and 5.20, but whenever I try to install under perl 5.18 manually or using cpanm, it says it installs ok, but in reality, it doesn't install version 1.18, and 1.17 is still the only installed version. $ perl -E 'say "$^V $^O"' v5.18.2 darwin $ cpanm Unicode::Normalize Successfully installed Unicode-Normalize-1.18 (upgraded from 1.17) 1 distribution installed $ cpanm -v Unicode::Normalize cpanm (App::cpanminus) 1.6911 on perl 5.018002 built for darwin-2level Work directory is /Users/blue/.cpanm/work/1405517609.34811 You have make /usr/bin/make You have LWP 6.07 You have /usr/bin/tar: bsdtar 2.8.3 - libarchive 2.8.3 You have /usr/bin/unzip Searching Unicode::Normalize on cpanmetadb ... --> Working on Unicode::Normalize Fetching http://www.cpan.org/authors/id/S/SA/SADAHIRO/Unicode-Normalize-1.18.tar.gz ... OK Unpacking Unicode-Normalize-1.18.tar.gz x Unicode-Normalize-1.18/ x Unicode-Normalize-1.18/Changes x Unicode-Normalize-1.18/Makefile.PL x Unicode-Normalize-1.18/MANIFEST x Unicode-Normalize-1.18/META.json x Unicode-Normalize-1.18/META.yml x Unicode-Normalize-1.18/Normalize.pm x Unicode-Normalize-1.18/README x Unicode-Normalize-1.18/t/ x Unicode-Normalize-1.18/t/fcdc.t x Unicode-Normalize-1.18/t/form.t x Unicode-Normalize-1.18/t/func.t x Unicode-Normalize-1.18/t/illegal.t x Unicode-Normalize-1.18/t/norm.t x Unicode-Normalize-1.18/t/null.t x Unicode-Normalize-1.18/t/partial1.t x Unicode-Normalize-1.18/t/partial2.t x Unicode-Normalize-1.18/t/proto.t x Unicode-Normalize-1.18/t/split.t x Unicode-Normalize-1.18/t/test.t x Unicode-Normalize-1.18/t/tie.t Entering Unicode-Normalize-1.18 Checking configure dependencies from META.json Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.98) Configuring Unicode-Normalize-1.18 ... Running Makefile.PL Checking if your kit is complete... Looks good Generating a Unix-style Makefile Writing Makefile for Unicode::Normalize Writing MYMETA.yml and MYMETA.json OK Checking dependencies from MYMETA.json ... Checking if you have File::Copy 0 ... Yes (2.26) Checking if you have Exporter 0 ... Yes (5.70) Checking if you have File::Spec 0 ... Yes (3.47) Checking if you have warnings 0 ... Yes (1.18) Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.98) Checking if you have constant 0 ... Yes (1.27) Checking if you have strict 0 ... Yes (1.07) Checking if you have Carp 0 ... Yes (1.3301) Checking if you have bytes 0 ... Yes (1.04) Building and testing Unicode-Normalize-1.18 ... cp Normalize.pm blib/lib/Unicode/Normalize.pm Manifying blib/man3/Unicode::Normalize.3 PERL_DL_NONLAZY=1 /home/perlbrew/perls/perl-5.18/bin/perl "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/fcdc.t ...... ok t/form.t ...... ok t/func.t ...... ok t/illegal.t ... ok t/norm.t ...... ok t/null.t ...... ok t/partial1.t .. ok t/partial2.t .. ok t/proto.t ..... ok t/split.t ..... ok t/test.t ...... ok t/tie.t ....... ok All tests successful. Files=12, Tests=748, 1 wallclock secs ( 0.07 usr 0.03 sys + 1.04 cusr 0.06 csys = 1.20 CPU) Result: PASS Appending installation info to /home/perlbrew/perls/p518/lib/5.18.2/darwin-2level/perllocal.pod OK Successfully installed Unicode-Normalize-1.18 (upgraded from 1.17) Installing /home/perlbrew/perls/p518/lib/site_perl/5.18.2/darwin-2level/.meta/Unicode-Normalize-1.18/install.json 1 distribution installed $ cpan-outdated S/SA/SADAHIRO/Unicode-Normalize-1.18.tar.gz $ grep VERSION `perldoc -l Unicode::Normalize` our $VERSION = '1.17'; bootstrap Unicode::Normalize $VERSION;
From: blue [...] thisisnotmyrealemail.com
Download (untitled) / with headers
text/plain 1.3k
On Wed Jul 16 09:45:03 2014, blue wrote: Show quoted text
> 1.18 installs fine under perl 5.16 and 5.20, but whenever I try to > install under perl 5.18 manually or using cpanm, it says it installs > ok, but in reality, it doesn't install version 1.18, and 1.17 is still > the only installed version.
The following sheds more light on the issue. Note that after pm-uninstall runs and removes 1.17, cpanm still finds version 1.16. I think this is caused by the change in 1.15 to using the site_perl directory. This would also explain why when I tested on 5.16 and 5.20 there was no issue, because I did a fresh install on those perls and didn't have the older version installed beforehand. $ pm-uninstall -f Unicode::Normalize --> Working on Unicode::Normalize Unicode::Normalize is included in the distribution Unicode-Normalize and contains: /home/perlbrew/perls/p518/lib/site_perl/5.18.2/Unicode/Normalize.pm /home/perlbrew/perls/p518/man/man3/Unicode::Normalize.3 Successfully uninstalled Unicode::Normalize You may want to rebuild man(1) entries. Try `mandb -c` if needed $ perldoc -l Unicode::Normalize /home/perlbrew/perls/p518/lib/5.18.2/darwin-2level/Unicode/Normalize.pm $ cpanm Unicode::Normalize Successfully installed Unicode-Normalize-1.18 (upgraded from 1.16) 1 distribution installed $ perldoc -l Unicode::Normalize /home/perlbrew/perls/p518/lib/site_perl/5.18.2/Unicode/Normalize.pm
Download (untitled) / with headers
text/plain 1.7k
On Wed Jul 16 11:23:52 2014, blue wrote: Show quoted text
> On Wed Jul 16 09:45:03 2014, blue wrote:
> > 1.18 installs fine under perl 5.16 and 5.20, but whenever I try to > > install under perl 5.18 manually or using cpanm, it says it installs > > ok, but in reality, it doesn't install version 1.18, and 1.17 is > > still > > the only installed version.
> > The following sheds more light on the issue. Note that after pm- > uninstall runs and removes 1.17, cpanm still finds version 1.16. I > think this is caused by the change in 1.15 to using the site_perl > directory. This would also explain why when I tested on 5.16 and 5.20 > there was no issue, because I did a fresh install on those perls and > didn't have the older version installed beforehand. > > $ pm-uninstall -f Unicode::Normalize > --> Working on Unicode::Normalize > Unicode::Normalize is included in the distribution Unicode-Normalize > and contains: > > /home/perlbrew/perls/p518/lib/site_perl/5.18.2/Unicode/Normalize.pm > /home/perlbrew/perls/p518/man/man3/Unicode::Normalize.3 > > Successfully uninstalled Unicode::Normalize > > You may want to rebuild man(1) entries. Try `mandb -c` if needed > > $ perldoc -l Unicode::Normalize > /home/perlbrew/perls/p518/lib/5.18.2/darwin- > 2level/Unicode/Normalize.pm > > $ cpanm Unicode::Normalize > Successfully installed Unicode-Normalize-1.18 (upgraded from 1.16) > 1 distribution installed > > $ perldoc -l Unicode::Normalize > /home/perlbrew/perls/p518/lib/site_perl/5.18.2/Unicode/Normalize.pm
U:N 1.23 has just been released. It looks like you got 1.18 to install anyway, so is there anything more to do on this ticket? If I don't hear back from you in a reasonable time (at least 7 days, but when I next think to check), I'll close this ticket.
As I indicated earlier, I'm rejecting this ticket because no one has responded to my earlier query


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.