Skip Menu |
 

This queue is for tickets about the URI CPAN distribution.

Report information
The Basics
Id: 97177
Status: resolved
Priority: 0/
Queue: URI

People
Owner: Nobody in particular
Requestors: PLICEASE [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.62
Fixed in: 1.64



Subject: test fails on Perl 5.10.1
Download (untitled) / with headers
text/plain 5.4k
Seems to work on more recent versions of Perl, but on 5.10 the test fails with this: twin% make test PERL_DL_NONLAZY=1 /home/ollisg/perl5/perlbrew/perls/perl-5.10.1/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/abs.t .......... ok t/clone.t ........ ok t/cwd.t .......... ok t/data.t ......... ok t/escape-char.t .. ok t/escape.t ....... ok t/file.t ......... ok t/ftp.t .......... ok t/generic.t ...... ok t/gopher.t ....... ok t/heuristic.t .... ok t/http.t ......... ok t/idna.t ......... ok t/iri.t .......... 1/26 # Failed test at t/iri.t line 72. # got: 'http://%FC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC' # expected: 'http://%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC%C3%BC' # Failed test at t/iri.t line 73. # got: 'üüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüü' # expected: 'üüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüü' # Failed test at t/iri.t line 78. # got: 'http://%FCüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüü' # expected: 'http://üüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüüü' # Looks like you failed 3 tests of 26. t/iri.t .......... Dubious, test returned 3 (wstat 768, 0x300) Failed 3/26 subtests t/ldap.t ......... ok t/mailto.t ....... ok t/mix.t .......... ok t/mms.t .......... ok t/news.t ......... ok t/num_eq.t ....... ok t/old-absconf.t .. ok t/old-base.t ..... ok t/old-file.t ..... ok t/old-relbase.t .. ok t/pop.t .......... ok t/punycode.t ..... ok t/query-param.t .. ok t/query.t ........ ok t/rel.t .......... ok t/rfc2732.t ...... ok t/roy-test.t ..... ok t/rsync.t ........ ok t/rtsp.t ......... ok t/sip.t .......... ok t/split.t ........ ok t/storable.t ..... ok t/urn-isbn.t ..... skipped: Needs the Business::ISBN module installed t/urn-oid.t ...... ok t/utf8.t ......... 1/? Use of uninitialized value in join or string at /home/ollisg/.cpanm/work/1405200305.10988/URI-1.62/blib/lib/URI/Escape.pm line 213. # Failed test at t/utf8.t line 15. # got: 'mooie=mooi%E2%82%ACe' # expected: 'mooi%E2%82%ACe=mooi%E2%82%ACe' # Looks like you failed 1 test of 5. t/utf8.t ......... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/5 subtests Test Summary Report ------------------- t/iri.t (Wstat: 768 Tests: 26 Failed: 3) Failed tests: 23-24, 26 Non-zero exit status: 3 t/utf8.t (Wstat: 256 Tests: 5 Failed: 1) Failed test: 2 Non-zero exit status: 1 Files=39, Tests=611, 1 wallclock secs ( 0.19 usr 0.06 sys + 0.80 cusr 0.14 csys = 1.19 CPU) Result: FAIL Failed 2/39 test programs. 4/611 subtests failed. make: *** [test_dynamic] Error 1 Looks like some similar failures reported by cpantestsers. If you want me to try something out then I'm happy to do it, though I think all you need is a Perl 5.10 install to reproduce. Thanks!
Subject: Re: [rt.cpan.org #97177] test fails on Perl 5.10.1
Date: Sat, 12 Jul 2014 16:10:51 -0700
To: Graham Ollis via RT <bug-URI [...] rt.cpan.org>
From: Karen Etheridge <ether [...] cpan.org>
Download (untitled) / with headers
text/plain 553b
On Sat, Jul 12, 2014 at 05:32:59PM -0400, Graham Ollis via RT wrote: Show quoted text
> Seems to work on more recent versions of Perl, but on 5.10 the test fails with this:
Confirmed. The dependency matrix shows this is consistent on all perls below 5.12.1. Related to this change, in perl5121delta? "utf8::is_utf8 now respects GMAGIC (e.g. $1)" I'll roll out a new release with these tests marked as TODO. Unfortunately, utf8 handling in general is not perfect and needs some changes that may not be consistent with previous releases, which needs careful thought.
Download (untitled) / with headers
text/plain 706b
On 2014-07-12 16:11:09, ETHER wrote: Show quoted text
> On Sat, Jul 12, 2014 at 05:32:59PM -0400, Graham Ollis via RT wrote:
> > Seems to work on more recent versions of Perl, but on 5.10 the test > > fails with this:
> > Confirmed. The dependency matrix shows this is consistent on all > perls > below 5.12.1. > > Related to this change, in perl5121delta? "utf8::is_utf8 now respects > GMAGIC (e.g. $1)" > > I'll roll out a new release with these tests marked as TODO. > Unfortunately, utf8 handling in general is not perfect and needs some > changes that may not be consistent with previous releases, which needs > careful thought.
1.63 is released, but I'll leave this ticket open as the core problem still exists.
Download (untitled) / with headers
text/plain 830b
On 2014-07-12 21:03:40, ETHER wrote: Show quoted text
> On 2014-07-12 16:11:09, ETHER wrote:
> > On Sat, Jul 12, 2014 at 05:32:59PM -0400, Graham Ollis via RT wrote:
> > > Seems to work on more recent versions of Perl, but on 5.10 the test > > > fails with this:
> > > > Confirmed. The dependency matrix shows this is consistent on all > > perls > > below 5.12.1. > > > > Related to this change, in perl5121delta? "utf8::is_utf8 now respects > > GMAGIC (e.g. $1)" > > > > I'll roll out a new release with these tests marked as TODO. > > Unfortunately, utf8 handling in general is not perfect and needs some > > changes that may not be consistent with previous releases, which > > needs > > careful thought.
> > > 1.63 is released, but I'll leave this ticket open as the core problem > still exists.
This should be properly fixed now, in 1.64.
Download (untitled) / with headers
text/plain 137b
On Mon Jul 14 17:48:37 2014, ETHER wrote: Show quoted text
> This should be properly fixed now, in 1.64.
Verified. Installed no problemo on Perl 5.10.1.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.