Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 97166
Status: resolved
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: g.grigelionis [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: 1.995 breaks CPAN Reporter with IO::Socket::IP 0.31
Date: Sat, 12 Jul 2014 10:15:28 +0200
To: bug-IO-Socket-SSL [...] rt.cpan.org
From: Gintautas Grigelionis <g.grigelionis [...] gmail.com>
Download (untitled) / with headers
text/plain 2.6k
Hi, just as IO::Socket::IP seems to fix problems with CPAN Reporter ( https://rt.cpan.org/Public/Bug/Display.html?id=97050), IO::Socket:SSL 1.995 broke it again: Too late to run INIT block at /Library/Perl/5.16/IO/Socket/SSL.pm line 169. Too late to run INIT block at /Library/Perl/5.16/IO/Socket/SSL.pm line 283. CPAN::Reporter: Test::Reporter: error from 'Test::Reporter::Transport::Metabase:' fact submission failed: Can't connect to metabase.cpantesters.org:443 at /Library/Perl/5.16/Metabase/Client/Simple.pm line 100. Metabase::Client::Simple::submit_fact(Metabase::Client::Simple=HASH(0x7f89d56875a0), CPAN::Testers::Report=HASH(0x7f89d57cf230)) called at /Library/Perl/5.16/Test/Reporter/Transport/Metabase.pm line 132 Test::Reporter::Transport::Metabase::send(Test::Reporter::Transport::Metabase=HASH(0x7f89d562b340), Test::Reporter=HASH(0x7f89d53ec058)) called at /Library/Perl/5.16/Test/Reporter.pm line 271 eval {...} called at /Library/Perl/5.16/Test/Reporter.pm line 271 Test::Reporter::send(Test::Reporter=HASH(0x7f89d53ec058)) called at /Library/Perl/5.16/CPAN/Reporter.pm line 494 CPAN::Reporter::_dispatch_report(HASH(0x7f89df32d820)) called at /Library/Perl/5.16/CPAN/Reporter.pm line 106 CPAN::Reporter::grade_test(CPAN::Distribution=HASH(0x7f89df8ac9d8), "/usr/bin/make test", ARRAY(0x7f89d5677bf8), 0) called at /Library/Perl/5.16/CPAN/Reporter.pm line 201 CPAN::Reporter::test(CPAN::Distribution=HASH(0x7f89df8ac9d8), "/usr/bin/make test") called at /Library/Perl/Updates/5.16.2/CPAN/Distribution.pm line 3544 CPAN::Distribution::test(CPAN::Distribution=HASH(0x7f89df8ac9d8)) called at /Library/Perl/Updates/5.16.2/CPAN/Distribution.pm line 3824 CPAN::Distribution::install(CPAN::Distribution=HASH(0x7f89df8ac9d8)) called at /Library/Perl/Updates/5.16.2/CPAN/Module.pm line 479 eval {...} called at /Library/Perl/Updates/5.16.2/CPAN/Module.pm line 478 CPAN::Module::rematein(CPAN::Module=HASH(0x7f89dddb6578), "install") called at /Library/Perl/Updates/5.16.2/CPAN/Module.pm line 578 CPAN::Module::install(CPAN::Module=HASH(0x7f89dddb6578)) called at /Library/Perl/Updates/5.16.2/CPAN/Shell.pm line 2063 CPAN::Shell::rematein("CPAN::Shell", "install", "Sub::Name") called at /Library/Perl/Updates/5.16.2/CPAN/Shell.pm line 2230 CPAN::Shell::__ANON__("CPAN::Shell", "Sub::Name") called at /Library/Perl/Updates/5.16.2/CPAN.pm line 376 eval {...} called at /Library/Perl/Updates/5.16.2/CPAN.pm line 373 CPAN::shell() called at /Library/Perl/Updates/5.16.2/App/Cpan.pm line 339 App::Cpan::_process_options("App::Cpan") called at /Library/Perl/Updates/5.16.2/App/Cpan.pm line 422 App::Cpan::run("App::Cpan") called at /usr/bin/cpan5.16 line 12
Download (untitled) / with headers
text/plain 369b
Am Sa 12. Jul 2014, 04:15:42, g.grigelionis@gmail.com schrieb: Show quoted text
> Hi, > > just as IO::Socket::IP seems to fix problems with CPAN Reporter ( > https://rt.cpan.org/Public/Bug/Display.html?id=97050), IO::Socket:SSL > 1.995 > broke it again: > > Too late to run INIT block at /Library/Perl/5.16/IO/Socket/SSL.pm line > 169.
Thanks for reporting. This is fixed with 1.996.
Download (untitled) / with headers
text/plain 466b
same for 1.997 CPAN::Reporter: Test result is 'pass', All tests successful. CPAN::Reporter: preparing a CPAN Testers report for IO-Socket-SSL-1.997 CPAN::Reporter: sending test report with 'pass' via Metabase CPAN::Reporter: Test::Reporter: error from 'Test::Reporter::Transport::Metabase:' fact submission failed: Can't connect to metabase.cpantesters.org:443 at /home/kevin/perl5/perlbrew/perls/perl-5.20.0/lib/site_perl/5.20.0/Metabase/Client/Simple.pm line 100.
Download (untitled) / with headers
text/plain 810b
Am Sa 12. Jul 2014, 14:18:37, bowtie schrieb: Show quoted text
> same for 1.997 > > CPAN::Reporter: Test result is 'pass', All tests successful. > CPAN::Reporter: preparing a CPAN Testers report for IO-Socket-SSL- > 1.997 > CPAN::Reporter: sending test report with 'pass' via Metabase > CPAN::Reporter: Test::Reporter: error from > 'Test::Reporter::Transport::Metabase:' > fact submission failed: Can't connect to metabase.cpantesters.org:443 > at /home/kevin/perl5/perlbrew/perls/perl- > 5.20.0/lib/site_perl/5.20.0/Metabase/Client/Simple.pm line 100.
I cannot reproduce this. As far as I understand Metabase::Client::Simple just uses LWP and LWP is working fine for me. Could you please verify, that LWP is working within the same environment, e.g. use LWP::Simple; print get('https://metabase.cpantesters.org');
CC: behroozi [...] www.pls.uni.edu
Subject: Re: [rt.cpan.org #97166] 1.995 breaks CPAN Reporter with IO::Socket::IP 0.31
Date: Sun, 13 Jul 2014 07:13:00 +0200
To: bug-IO-Socket-SSL [...] rt.cpan.org
From: Gintautas Grigelionis <g.grigelionis [...] gmail.com>
It works on 5.16 for me, but maybe 5.20 behaves differently. 2014-07-12 21:44 GMT+02:00 Steffen Ullrich via RT < bug-IO-Socket-SSL@rt.cpan.org>: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=97166 > > > Am Sa 12. Jul 2014, 14:18:37, bowtie schrieb:
> > same for 1.997 > > > > CPAN::Reporter: Test result is 'pass', All tests successful. > > CPAN::Reporter: preparing a CPAN Testers report for IO-Socket-SSL- > > 1.997 > > CPAN::Reporter: sending test report with 'pass' via Metabase > > CPAN::Reporter: Test::Reporter: error from > > 'Test::Reporter::Transport::Metabase:' > > fact submission failed: Can't connect to metabase.cpantesters.org:443 > > at /home/kevin/perl5/perlbrew/perls/perl- > > 5.20.0/lib/site_perl/5.20.0/Metabase/Client/Simple.pm line 100.
> > I cannot reproduce this. > As far as I understand Metabase::Client::Simple just uses LWP and LWP is > working fine for me. > Could you please verify, that LWP is working within the same environment, > e.g. > > use LWP::Simple; > print get('https://metabase.cpantesters.org'); > > >
Download (untitled) / with headers
text/plain 1.2k
Am So 13. Jul 2014, 01:13:11, g.grigelionis@gmail.com schrieb: Show quoted text
> It works on 5.16 for me, but maybe 5.20 behaves differently.
Thanks for reporting the difference. Although perl5.20 works for me too. Could you please run the following program to check the status and a list of essential modules? use strict; use warnings; use LWP::Simple; print get('https://metabase.cpantesters.org') =~ m/CPAN Testers Metabase/ ? "LWP success on $^O,$^V\n":"LWP failed on $^O,$^V\n"; for(qw(IO::Socket::SSL IO::Socket::IP Net::SSLeay LWP::UserAgent LWP::Protocol::https)) { print "* $_ ".$_->VERSION."\n"; } This gives the following output on my system: LWP success on linux,v5.20.0 * IO::Socket::SSL 1.997 * IO::Socket::IP 0.31 * Net::SSLeay 1.64 * LWP::UserAgent 6.06 * LWP::Protocol::https 6.06 All these should be the newest version. With LWP::Protocol::https you have to be careful to get the newest version, because cpan picks up 6.04 as the newest (see http://www.nntp.perl.org/group/perl.libwww/2014/05/msg7718.html). While 6.04 works in most cases (I've tested this version too), you absolutely need 6.06 if you are behind a proxy because only this version includes the necessary https proxy support.
Download (untitled) / with headers
text/plain 450b
Thanks for the test script I had to upgrade LWP::Protocol::https from 6.04 to 6.06 as per your suggestion to get CPAN-Reporter to work with IO::Socket::SSL 1.997 kevin@billy:~/scratch/tmp$ perl rt97166.pl LWP success on linux,v5.20.0 * IO::Socket::SSL 1.997 * IO::Socket::IP 0.31 * Net::SSLeay 1.64 * LWP::UserAgent 6.06 * LWP::Protocol::https 6.06 many thanks ps. now all you need to do is get the PAUSE index for LWP::Protocol::https sorted :)
Download (untitled) / with headers
text/plain 386b
Show quoted text
> ps. now all you need to do is get the PAUSE index for > LWP::Protocol::https sorted :)
Glad to know that it works. As for the PAUSE index: Looks like they did pick up the maintainer change of LWP and LWP::Protocol::https from GAAS to MSCHILI only in part, i.e. it worked for the first but not for the second. I've added an issue to lwp-protocol-https and hope they can resolve this.
Subject: Re: [rt.cpan.org #97166] 1.995 breaks CPAN Reporter with IO::Socket::IP 0.31
Date: Sat, 1 Nov 2014 12:09:42 +0100
To: bug-IO-Socket-SSL [...] rt.cpan.org
From: Gintautas Grigelionis <g.grigelionis [...] gmail.com>
Download (untitled) / with headers
text/plain 822b
Just noticed that IO::Socket::SSL 2.002 fails t/io-socket-ip.t with an old IO::Socket::IP (0.30). Upgrading IO::Socket::IP makes the error disappear. What I expect is that IO::Socket::IP is upgraded automatically. I guess the dependency list points to a too old version? 2014-07-13 14:29 GMT+02:00 Steffen Ullrich via RT < bug-IO-Socket-SSL@rt.cpan.org>: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=97166 > > >
> > ps. now all you need to do is get the PAUSE index for > > LWP::Protocol::https sorted :)
> > Glad to know that it works. As for the PAUSE index: Looks like they did > pick up the maintainer change of LWP and LWP::Protocol::https from GAAS to > MSCHILI only in part, i.e. it worked for the first but not for the second. > I've added an issue to lwp-protocol-https and hope they can resolve this. >
Download (untitled) / with headers
text/plain 564b
Am Sa 01. Nov 2014, 07:09:51, g.grigelionis@gmail.com schrieb: Show quoted text
> Just noticed that IO::Socket::SSL 2.002 fails t/io-socket-ip.t with an old > IO::Socket::IP (0.30). > Upgrading IO::Socket::IP makes the error disappear. > What I expect is that IO::Socket::IP is upgraded automatically. > I guess the dependency list points to a too old version?
Unfortunately it is not that easy. IO::Socket::SSL supports IO::Socket::IP since version 0.20. But version 0.30 had a problem so this version is not supported. But, the test be skipped and not fail - fixed in 3b96ed54.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.