Skip Menu |
 

This queue is for tickets about the Module-CPANTS-Analyse CPAN distribution.

Report information
The Basics
Id: 97119
Status: new
Priority: 0/
Queue: Module-CPANTS-Analyse

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: missing_build_prereqs, missing_prereqs omits mentioning core and dual-lifed modules
Download (untitled) / with headers
text/plain 578b
It looks like these metrics do not look for missing declarations of modules that are in core. Note that not everything in core is *always* in core; e.g. Scalar::Util wasn't core in perl 5.6, so every distribution using it that claims to work on perl 5.6 should list it in prereqs. Also, modules can be removed from core, such as Module::Build no longer being in 5.21.0 and up. I would recommend at least requiring dual-lifed modules to be listed. (I am working on an interface in Module::CoreList to make this query easier, as it's not an easy question to answer right now.)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.