Skip Menu |
 

This queue is for tickets about the Pod-WSDL CPAN distribution.

Report information
The Basics
Id: 96652
Status: stalled
Priority: 0/
Queue: Pod-WSDL

People
Owner: JCOP [...] cpan.org
Requestors: goehle [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Pod::WSDL testing fails on Fedora/CentOs
Date: Mon, 23 Jun 2014 10:56:44 -0400
To: bug-Pod-WSDL [...] rt.cpan.org
From: "goehle [...] gmail.com" <goehle [...] gmail.com>
Download (untitled) / with headers
text/plain 9.7k
Hi, I got this email from CPAN. If I got the wrong address, feel free to direct me to wherever it needs to go. When I try to install Pod::WSDL via cpan (cpan Pod::WSDL) on a fresh copy of either Fedora 20 or CentOs 6 I get an installation failure. I've pasted the output below. CPAN: Storable loaded ok (v2.20) Going to read '/root/.cpan/Metadata' Database was generated on Mon, 23 Jun 2014 14:41:02 GMT Running install for module 'Pod::WSDL' CPAN: Data::Dumper loaded ok (v2.124) 'YAML' not installed, falling back to Data::Dumper and Storable to read prefs '/root/.cpan/prefs' Running make for B/BM/BMAVT/Pod-WSDL-0.062.tar.gz CPAN: Digest::SHA loaded ok (v5.47) CPAN: Compress::Zlib loaded ok (v2.021) Checksum for /root/.cpan/sources/authors/id/B/BM/BMAVT/Pod-WSDL-0.062.tar.gz ok CPAN: Archive::Tar loaded ok (v1.58) Pod-WSDL-0.062 Pod-WSDL-0.062/README Pod-WSDL-0.062/Changes Pod-WSDL-0.062/dist.ini Pod-WSDL-0.062/META.yml Pod-WSDL-0.062/MANIFEST Pod-WSDL-0.062/t/My Pod-WSDL-0.062/t/My/Bar.pm Pod-WSDL-0.062/t/My/Foo.pm Pod-WSDL-0.062/Makefile.PL Pod-WSDL-0.062/t Pod-WSDL-0.062/t/axistest.pl Pod-WSDL-0.062/t/My/Server.pm Pod-WSDL-0.062/lib/Pod Pod-WSDL-0.062/lib/Pod/WSDL.pm Pod-WSDL-0.062/t/05Doc01basic.t Pod-WSDL-0.062/t/My/AxisTest.pm Pod-WSDL-0.062/t/My/TypeTest.pm Pod-WSDL-0.062/t/04Attr01basic.t Pod-WSDL-0.062/t/04Type01basic.t Pod-WSDL-0.062/t/09Attr01basic.t Pod-WSDL-0.062/t/11WSDL01basic.t Pod-WSDL-0.062/t/11WSDL02types.t Pod-WSDL-0.062/t/02Utils01basic.t Pod-WSDL-0.062/t/06Fault01basic.t Pod-WSDL-0.062/t/08Param01basic.t Pod-WSDL-0.062/lib/Pod/WSDL Pod-WSDL-0.062/lib/Pod/WSDL/Doc.pm Pod-WSDL-0.062/t/03Writer01basic.t Pod-WSDL-0.062/t/07Return01basic.t Pod-WSDL-0.062/t/10Method01basic.t Pod-WSDL-0.062/t/11WSDL04binding.t Pod-WSDL-0.062/t/11WSDL05service.t Pod-WSDL-0.062/t/11WSDL06parsing.t Pod-WSDL-0.062/t/outputtest001.xml Pod-WSDL-0.062/t/outputtest002.xml Pod-WSDL-0.062/t/My/BindingTest.pm Pod-WSDL-0.062/t/My/ServiceTest.pm Pod-WSDL-0.062/lib/Pod/WSDL/Attr.pm Pod-WSDL-0.062/lib/Pod/WSDL/Type.pm Pod-WSDL-0.062/lib/Pod/WSDL/Fault.pm Pod-WSDL-0.062/lib/Pod/WSDL/Param.pm Pod-WSDL-0.062/lib/Pod/WSDL/Utils.pm Pod-WSDL-0.062/t/01AUTOLOAD01basic.t Pod-WSDL-0.062/t/My/OperationTest.pm Pod-WSDL-0.062/t/My/WrongTypeTest.pm Pod-WSDL-0.062/lib/Pod/WSDL/Method.pm Pod-WSDL-0.062/lib/Pod/WSDL/Return.pm Pod-WSDL-0.062/lib/Pod/WSDL/Writer.pm Pod-WSDL-0.062/t/11WSDL03operations.t Pod-WSDL-0.062/lib/Pod/WSDL/AUTOLOAD.pm Pod-WSDL-0.062/t/01AUTOLOAD02forbiddenmethods.t CPAN: File::Temp loaded ok (v0.22) CPAN.pm: Going to build B/BM/BMAVT/Pod-WSDL-0.062.tar.gz Checking if your kit is complete... Looks good Writing Makefile for Pod::WSDL Could not read '/root/.cpan/build/Pod-WSDL-0.062-GCOcjO/META.yml'. Falling back to other methods to determine prerequisites Show quoted text
---- Unsatisfied dependencies detected during ---- ---- BMAVT/Pod-WSDL-0.062.tar.gz ---- XML::Writer [requires] Shall I follow them and prepend them to the queue of modules we are processing right now? [yes] Running make test Delayed until after prerequisites Running make install Delayed until after prerequisites Running install for module 'XML::Writer' 'YAML' not installed, falling back to Data::Dumper and Storable to read prefs '/root/.cpan/prefs' Running make for J/JO/JOSEPHW/XML-Writer-0.625.tar.gz Checksum for /root/.cpan/sources/authors/id/J/JO/JOSEPHW/XML-Writer-0.625.tar.gz ok XML-Writer-0.625/ XML-Writer-0.625/TODO XML-Writer-0.625/Makefile.PL XML-Writer-0.625/Writer.pm XML-Writer-0.625/t/ XML-Writer-0.625/t/selfcontained_output.t XML-Writer-0.625/t/pod-coverage.t XML-Writer-0.625/t/01_main.t XML-Writer-0.625/t/pod.t XML-Writer-0.625/examples/ XML-Writer-0.625/examples/directory-as-atom.pl XML-Writer-0.625/examples/xml-writer-string.pl XML-Writer-0.625/examples/double-escaping-example.pl XML-Writer-0.625/examples/namespace-prefixes.pl XML-Writer-0.625/examples/simple-xml.pl XML-Writer-0.625/examples/writing-unicode.pl XML-Writer-0.625/examples/data-mode-sample.pl XML-Writer-0.625/MANIFEST XML-Writer-0.625/Changes XML-Writer-0.625/README XML-Writer-0.625/LICENSE XML-Writer-0.625/META.yml CPAN.pm: Going to build J/JO/JOSEPHW/XML-Writer-0.625.tar.gz Checking if your kit is complete... Looks good Writing Makefile for XML::Writer Could not read '/root/.cpan/build/XML-Writer-0.625-i4WIfH/META.yml'. Falling back to other methods to determine prerequisites Makefile out-of-date with respect to Makefile.PL Cleaning current config before rebuilding Makefile... make -f Makefile.old clean > /dev/null 2>&1 /usr/bin/perl Makefile.PL "INSTALLDIRS=site" Checking if your kit is complete... Looks good Writing Makefile for XML::Writer ==> Your Makefile has been rebuilt. <== ==> Please rerun the make command. <== false JOSEPHW/XML-Writer-0.625.tar.gz /usr/bin/make -- NOT OK Warning (usually harmless): 'YAML' not installed, will not store persistent state Running make test Can't test without successful make Running make install Make had returned bad status, install seems impossible Running make for B/BM/BMAVT/Pod-WSDL-0.062.tar.gz Has already been unwrapped into directory /root/.cpan/build/Pod-WSDL-0.062-GCOcjO CPAN.pm: Going to build B/BM/BMAVT/Pod-WSDL-0.062.tar.gz Warning: Prerequisite 'XML::Writer => 0.531' for 'BMAVT/Pod-WSDL-0.062.tar.gz' failed when processing 'JOSEPHW/XML-Writer-0.625.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited. CPAN: Time::HiRes loaded ok (v1.9721) cp lib/Pod/WSDL/AUTOLOAD.pm blib/lib/Pod/WSDL/AUTOLOAD.pm cp lib/Pod/WSDL/Writer.pm blib/lib/Pod/WSDL/Writer.pm cp lib/Pod/WSDL/Return.pm blib/lib/Pod/WSDL/Return.pm cp lib/Pod/WSDL/Utils.pm blib/lib/Pod/WSDL/Utils.pm cp lib/Pod/WSDL/Type.pm blib/lib/Pod/WSDL/Type.pm cp lib/Pod/WSDL/Attr.pm blib/lib/Pod/WSDL/Attr.pm cp lib/Pod/WSDL.pm blib/lib/Pod/WSDL.pm cp lib/Pod/WSDL/Doc.pm blib/lib/Pod/WSDL/Doc.pm cp lib/Pod/WSDL/Fault.pm blib/lib/Pod/WSDL/Fault.pm cp lib/Pod/WSDL/Param.pm blib/lib/Pod/WSDL/Param.pm cp lib/Pod/WSDL/Method.pm blib/lib/Pod/WSDL/Method.pm Manifying blib/man3/Pod::WSDL::AUTOLOAD.3pm Manifying blib/man3/Pod::WSDL::Writer.3pm Manifying blib/man3/Pod::WSDL::Return.3pm Manifying blib/man3/Pod::WSDL::Utils.3pm Manifying blib/man3/Pod::WSDL::Type.3pm Manifying blib/man3/Pod::WSDL::Attr.3pm Manifying blib/man3/Pod::WSDL.3pm Manifying blib/man3/Pod::WSDL::Doc.3pm Manifying blib/man3/Pod::WSDL::Param.3pm Manifying blib/man3/Pod::WSDL::Fault.3pm Manifying blib/man3/Pod::WSDL::Method.3pm BMAVT/Pod-WSDL-0.062.tar.gz /usr/bin/make -- OK Warning (usually harmless): 'YAML' not installed, will not store persistent state Running make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/01AUTOLOAD01basic.t ............. ok t/01AUTOLOAD02forbiddenmethods.t .. ok t/02Utils01basic.t ................ ok t/03Writer01basic.t ............... Dubious, test returned 255 (wstat 65280, 0xff00) Failed 16/16 subtests t/04Attr01basic.t ................. ok t/04Type01basic.t ................. Dubious, test returned 2 (wstat 512, 0x200) Failed 10/11 subtests t/05Doc01basic.t .................. ok t/06Fault01basic.t ................ ok t/07Return01basic.t ............... ok t/08Param01basic.t ................ ok t/09Attr01basic.t ................. ok t/10Method01basic.t ............... Dubious, test returned 255 (wstat 65280, 0xff00) Failed 21/21 subtests t/11WSDL01basic.t ................. Dubious, test returned 255 (wstat 65280, 0xff00) Failed 33/33 subtests t/11WSDL02types.t ................. Dubious, test returned 255 (wstat 65280, 0xff00) Failed 54/54 subtests t/11WSDL03operations.t ............ Dubious, test returned 255 (wstat 65280, 0xff00) Failed 23/23 subtests t/11WSDL04binding.t ............... Dubious, test returned 255 (wstat 65280, 0xff00) Failed 15/15 subtests t/11WSDL05service.t ............... Dubious, test returned 255 (wstat 65280, 0xff00) Failed 4/4 subtests t/11WSDL06parsing.t ............... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/1 subtests Test Summary Report ------------------- t/03Writer01basic.t (Wstat: 65280 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 255 Parse errors: Bad plan. You planned 16 tests but ran 1. t/04Type01basic.t (Wstat: 512 Tests: 1 Failed: 0) Non-zero exit status: 2 Parse errors: Bad plan. You planned 11 tests but ran 1. t/10Method01basic.t (Wstat: 65280 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 255 Parse errors: Bad plan. You planned 21 tests but ran 1. t/11WSDL01basic.t (Wstat: 65280 Tests: 3 Failed: 3) Failed tests: 1-3 Non-zero exit status: 255 Parse errors: Bad plan. You planned 33 tests but ran 3. t/11WSDL02types.t (Wstat: 65280 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 255 Parse errors: Bad plan. You planned 54 tests but ran 1. t/11WSDL03operations.t (Wstat: 65280 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 255 Parse errors: Bad plan. You planned 23 tests but ran 1. t/11WSDL04binding.t (Wstat: 65280 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 255 Parse errors: Bad plan. You planned 15 tests but ran 1. t/11WSDL05service.t (Wstat: 65280 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 255 Parse errors: Bad plan. You planned 4 tests but ran 1. t/11WSDL06parsing.t (Wstat: 256 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 1 Files=18, Tests=98, 0 wallclock secs ( 0.06 usr 0.03 sys + 0.51 cusr 0.12 csys = 0.72 CPU) Result: FAIL BMAVT/Pod-WSDL-0.062.tar.gz /usr/bin/make test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports BMAVT/Pod-WSDL-0.062.tar.gz Warning (usually harmless): 'YAML' not installed, will not store persistent state Running make install make test had returned bad status, won't install without force
Download (untitled) / with headers
text/html 11.3k
Download (untitled) / with headers
text/plain 156b
Hi there Is this still an issue? If so, please confirm if the centOS you used was a 6.5. Also, please indicate how you were building the module. thanks!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.