Skip Menu |
 

This queue is for tickets about the Data-TreeDumper CPAN distribution.

Report information
The Basics
Id: 96493
Status: open
Priority: 0/
Queue: Data-TreeDumper

People
Owner: Nobody in particular
Requestors: MARKLE [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: please make Devel::Size optional, DISPLAY_PERL_SIZE break if not installed
Download (untitled) / with headers
text/plain 340b
Devel::Size is broken in 5.20.0. See https://rt.cpan.org/Ticket/Display.html?id=95493 Perhaps it would be good to make Devel::Size an optional dependency, skip size tests if not installed, and cause DISPLAY_PERL_SIZE to throw an error if Devel::Size is not installed. Otherwise, this module cannot be installed in 5.20.0. Thanks. -Mark
Download (untitled) / with headers
text/plain 484b
On 2014-06-17 00:34:42, MARKLE wrote: Show quoted text
> Devel::Size is broken in 5.20.0. See > https://rt.cpan.org/Ticket/Display.html?id=95493 > > Perhaps it would be good to make Devel::Size an optional dependency, > skip size tests if not installed, and cause DISPLAY_PERL_SIZE to throw > an error if Devel::Size is not installed. > > Otherwise, this module cannot be installed in 5.20.0.
Devel::Size is again broken in perl 5.27.x. So it would still be good to make this dependency optional.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.