Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 96451
Status: resolved
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: CARNIL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)

Attachments
workaround-pod-error-expected-text-after-item-not-number.patch



From: CARNIL [...] cpan.org
Subject: [PATCH] Woraround Pod::Simple change which causes Perl 5.18's to fail
Download (untitled) / with headers
text/plain 581b
Hi, In Debian we are currently applying the following patch to IO-Socket-SSL. We thought you might be interested in it too. Description: Woraround Pod::Simple change which causes Perl 5.18's to fail Origin: vendor Author: Salvatore Bonaccorso <carnil@debian.org> Last-Update: 2014-06-14 The patch is tracked in our Git repository at http://anonscm.debian.org/gitweb/?p=pkg-perl/packages/libio-socket-ssl-perl.git;a=blob;f=debian/patches/workaround-pod-error-expected-text-after-item-not-number.patch;hb=HEAD Thanks for considering, Salvatore Bonaccorso, Debian Perl Group
Here's the patch.

Message body is not shown because sender requested not to inline it.

Download (untitled) / with headers
text/plain 290b
Show quoted text
> Description: Woraround Pod::Simple change which causes Perl 5.18's to > fail
Pod tests should not be running at installation time. Either move them to xt/, or guard them with: plan skip_all => 'these tests are for authors only' unless $ENV{AUTHOR_TESTING} or $ENV{RELEASE_TESTING};
Download (untitled) / with headers
text/plain 594b
Am Sa 14. Jun 2014, 10:22:29, CARNIL schrieb: Show quoted text
> Hi, > > In Debian we are currently applying the following patch to > IO-Socket-SSL. > We thought you might be interested in it too. > > Description: Woraround Pod::Simple change which causes Perl 5.18's to > fail
Thanks for the report. I've made changes to this part of code (no no release, but on github), although slightly different. The strange thing is that I could reproduce the problem, e.g. podchecker with 5.18.1 does not give me any errors and perldoc and pod2html work also too. What kind of code did you run which cause the error?
Download (untitled) / with headers
text/plain 521b
Am Sa 14. Jun 2014, 11:51:07, ETHER schrieb: Show quoted text
>
> > Description: Woraround Pod::Simple change which causes Perl 5.18's to > > fail
> > Pod tests should not be running at installation time. Either move them > to xt/, or guard them with: >
I'm not aware of any test in IO::Socket::SSL which does pod checking. So this must be a test the Debian maintainers do for their own (which is probably a good idea). But thanks to making me aware of the convention to have author only tests in xt. I did not know that rule yet.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.