Skip Menu |
 

This queue is for tickets about the B-Hooks-EndOfScope CPAN distribution.

Report information
The Basics
Id: 95427
Status: rejected
Priority: 0/
Queue: B-Hooks-EndOfScope

People
Owner: ether [...] cpan.org
Requestors: GETTY [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.13
Fixed in: (no value)



Subject: Missing Devel::Hide blocks install
Download (untitled) / with headers
text/plain 1.1k
t/00-basic.t .................... ok # # Versions for all modules listed in META.json (including optional ones): # Version Module # -------- -------------------------- # 2.120351 CPAN::Meta # 2.120351 CPAN::Meta::Requirements # 0.280202 ExtUtils::CBuilder # 6.88 ExtUtils::MakeMaker # 0.07 Module::Implementation # 0.014 Module::Runtime # 0.001011 Sub::Exporter::Progressive # 1.001003 Test::More # 0.53 Variable::Magic t/00-report-prereqs.t ........... ok t/01-eval.t ..................... ok t/02-localise.t ................. ok t/05-exception_xs.t ............. ok t/06-exception_pp.t ............. skipped: Skipping PP fallback test in XS mode # Failed test 'smokers require Devel::Hide for testing the PP path!' # at t/10-test_without_vm_pure_pp.t line 23. # Looks like you failed 1 test of 6. t/10-test_without_vm_pure_pp.t .. Dubious, test returned 1 (wstat 256, 0x100) Failed 1/6 subtests t/11-direct_xs.t ................ ok t/12-direct_pp.t ................ ok I hope thats enough, Devel::Hide install solved the problem for me, probably adding it as Requirement or is that here with purpose?
Download (untitled) / with headers
text/plain 754b
On 2014-05-06 18:00:51, GETTY wrote: Show quoted text
> # Failed test 'smokers require Devel::Hide for testing the PP path!' > # at t/10-test_without_vm_pure_pp.t line 23.
Show quoted text
> I hope thats enough, Devel::Hide install solved the problem for me, > probably adding it as Requirement or is that here with purpose?
The tests are skipped if you don't have Devel::Hide installed, *and* you have none of these variables set in the environment: AUTHOR_TESTING, RELEASE_TESTING, AUTOMATED_TESTING. That error specifically is caused by you having AUTOMATED_TESTING when you ran the tests. Makefile.PL adds Devel::Hide to the prereq list if AUTOMATED_TESTING is set, so you must have had it unset when you ran Makefile.PL, but set when you ran the tests. so don't do that. :)
Download (untitled) / with headers
text/plain 885b
On 2014-05-09 12:22:18, ETHER wrote: Show quoted text
> On 2014-05-06 18:00:51, GETTY wrote: >
> > # Failed test 'smokers require Devel::Hide for testing the PP > > path!' > > # at t/10-test_without_vm_pure_pp.t line 23.
>
> > I hope thats enough, Devel::Hide install solved the problem for me, > > probably adding it as Requirement or is that here with purpose?
> > The tests are skipped if you don't have Devel::Hide installed, *and* > you have none of these variables set in the environment: > AUTHOR_TESTING, RELEASE_TESTING, AUTOMATED_TESTING. That error > specifically is caused by you having AUTOMATED_TESTING when you ran > the tests. Makefile.PL adds Devel::Hide to the prereq list if > AUTOMATED_TESTING is set, so you must have had it unset when you ran > Makefile.PL, but set when you ran the tests. so don't do that. :)
s/tests are skipped/tests are run without Devel::Hide/ ;)
Download (untitled) / with headers
text/plain 221b
Show quoted text
> AUTOMATED_TESTING is set, so you must have had it unset when you ran > Makefile.PL, but set when you ran the tests. so don't do that. :)
Regular cpanm install, i do nothing special on that host, not that I know of ;).
Download (untitled) / with headers
text/plain 330b
On 2014-05-09 12:53:30, GETTY wrote: Show quoted text
> > AUTOMATED_TESTING is set, so you must have had it unset when you ran > > Makefile.PL, but set when you ran the tests. so don't do that. :)
> > Regular cpanm install, i do nothing special on that host, not that I > know of ;).
Are you really sure that $ENV{AUTOMATED_TESTING} is not set?
Download (untitled) / with headers
text/plain 239b
Show quoted text
> Are you really sure that $ENV{AUTOMATED_TESTING} is not set?
For sure not by me, just checked it again its not in the ENV, isnt that what cpanm is setting? But even tho then it would be still on in both cases, or? (or off in both cases)
CC: ;
Subject: Re: [rt.cpan.org #95427] Missing Devel::Hide blocks install
Date: Fri, 9 May 2014 17:14:18 -0400
To: Torsten Raudssus via RT <bug-B-Hooks-EndOfScope [...] rt.cpan.org>
From: Jesse Luehrs <doy [...] tozt.net>
You probably just need to upgrade cpanm.
Download (untitled) / with headers
text/plain 288b
Am Fr 09. Mai 2014, 17:14:33, doy@tozt.net schrieb: Show quoted text
> You probably just need to upgrade cpanm.
Ah yeah, that is a good hint, yeah the machine is an old one, let me check the cpanm version.. 1.4004, is that then explaining it? If not then I wouldn't upgrade and we can investigate further
Subject: Re: [rt.cpan.org #95427] Missing Devel::Hide blocks install
Date: Sat, 10 May 2014 10:57:30 -0700
To: Torsten Raudssus via RT <bug-B-Hooks-EndOfScope [...] rt.cpan.org>
From: Karen Etheridge <ether [...] cpan.org>
Download (untitled) / with headers
text/plain 476b
On Fri, May 09, 2014 at 06:24:22PM -0400, Torsten Raudssus via RT wrote: Show quoted text
> Am Fr 09. Mai 2014, 17:14:33, doy@tozt.net schrieb:
> > You probably just need to upgrade cpanm.
> > Ah yeah, that is a good hint, yeah the machine is an old one, let me check the cpanm version.. 1.4004, is that then explaining it? If not then I wouldn't upgrade and we can investigate further
Potentially: https://metacpan.org/changes/distribution/App-cpanminus#L571 Why not update cpanm anyway?
Download (untitled) / with headers
text/plain 140b
Show quoted text
> Potentially: https://metacpan.org/changes/distribution/App- > cpanminus#L571 > > Why not update cpanm anyway?
Why write bug reports? ;-)
Subject: Re: [rt.cpan.org #95427] Missing Devel::Hide blocks install
Date: Sat, 10 May 2014 14:36:42 -0700
To: Torsten Raudssus via RT <bug-B-Hooks-EndOfScope [...] rt.cpan.org>
From: Karen Etheridge <ether [...] cpan.org>
Download (untitled) / with headers
text/plain 414b
On Sat, May 10, 2014 at 04:27:52PM -0400, Torsten Raudssus via RT wrote: Show quoted text
> Queue: B-Hooks-EndOfScope > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=95427 > >
> > Potentially: https://metacpan.org/changes/distribution/App- > > cpanminus#L571 > > > > Why not update cpanm anyway?
> > Why write bug reports? ;-)
My point is that I'd like to see if the problem goes away for you if you update.
Download (untitled) / with headers
text/plain 196b
Show quoted text
> My point is that I'd like to see if the problem goes away for you if > you update.
Ah! Now we are talking ;) Yes just tested it, and approved, pure cpanminus bug. Thanks for all cooperation! :D


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.