Skip Menu |
 

This queue is for tickets about the PerlIO-subfile CPAN distribution.

Report information
The Basics
Id: 95340
Status: resolved
Priority: 0/
Queue: PerlIO-subfile

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.08
Fixed in: 0.09



Subject: Does not build with perl 5.19.x
Download (untitled) / with headers
text/plain 671b
Running Makefile.PL with perl 5.19.11 shows the following message: You need perl 5.7.1 or later, configured to use perlio (and not to use sfio) Yes, this module is currently only suitable for the development branch of perl Note 1: The features required for layers have only recently been added to development perl, so if your doesn't have the header perliol.h it's too old 2: The perlio layers API has changed (at least once) between the initial version and 5.7.1, and may well change again. If so, it is quite possible that this module will fail to compile. (/usr/perl5.19.11/bin/perl5.19.11 Makefile.PL exited with 65280) Regards, Slaven
Download (untitled) / with headers
text/plain 132b
Git bisect on bleadperl leads us to v5.19.7-51-g0b39d4d which was discussed in https://rt.perl.org/Public/Bug/Display.html?id=120892
Download (untitled) / with headers
text/plain 832b
On 2014-05-04 09:26:52, SREZIC wrote: Show quoted text
> Running Makefile.PL with perl 5.19.11 shows the following message: > > You need perl 5.7.1 or later, configured to use perlio (and not to use sfio) > Yes, this module is currently only suitable for the development branch of > perl > > Note > 1: The features required for layers have only recently been added to > development perl, so if your doesn't have the header perliol.h it's > too old > 2: The perlio layers API has changed (at least once) between the initial > version and 5.7.1, and may well change again. If so, it is quite > possible that this module will fail to compile. > (/usr/perl5.19.11/bin/perl5.19.11 Makefile.PL exited with 65280) >
The patch from https://rt.cpan.org/Ticket/Display.html?id=92412 can also be applied here. Regards, Slaven
On Sat May 24 04:33:54 2014, SREZIC wrote:
Show quoted text
> The patch from https://rt.cpan.org/Ticket/Display.html?id=92412 can
> also be applied here.
>
> Regards,
> Slaven

Any chance this can reach CPAN?  Plack::App::File::Range / Plack::Middleware::Static::Range have this as dependency
Download (untitled) / with headers
text/plain 517b
On 2017-03-26 02:31:08, JWRIGHT wrote: Show quoted text
> On Sat May 24 04:33:54 2014, SREZIC wrote:
> > The patch from https://rt.cpan.org/Ticket/Display.html?id=92412 can > > also be applied here. > > > > Regards, > > Slaven
> > Any chance this can reach CPAN? Plack::App::File::Range / > Plack::Middleware::Static::Range have this as dependency
Until the patch is applied, CPAN.pm users may use the distroprefs systems and <https://github.com/eserte/srezic-cpan-distroprefs/blob/master/PerlIO-subfile.yml> for automatic patching.
Download (untitled) / with headers
text/plain 671b
On Sun Mar 26 05:04:42 2017, SREZIC wrote: Show quoted text
> On 2017-03-26 02:31:08, JWRIGHT wrote:
Show quoted text
> > Any chance this can reach CPAN? Plack::App::File::Range / > > Plack::Middleware::Static::Range have this as dependency
Oh gosh, I didn't realise that it had downstream users other than my own code. Show quoted text
> Until the patch is applied, CPAN.pm users may use the distroprefs > systems and <https://github.com/eserte/srezic-cpan- > distroprefs/blob/master/PerlIO-subfile.yml> for automatic patching.
Sorry about the delay. Patch applied and new version 0.09 uploaded to CPAN. This should fix it, but I'll believe this once CPAN Testers goes green. Been a while since the last release...
Download (untitled) / with headers
text/plain 303b
On Wed Jun 21 15:17:55 2017, NWCLARK wrote: Show quoted text
> Patch applied and new version 0.09 uploaded to CPAN. > This should fix it, but I'll believe this once CPAN Testers goes > green.
CPAN Testers showing that it builds on 5.26.0 and 5.27.1 (and everything back from there), so marking resolved. Nicholas Clark


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.