Skip Menu |
 

This queue is for tickets about the DBD-SQLite CPAN distribution.

Report information
The Basics
Id: 9480
Status: resolved
Priority: 0/
Queue: DBD-SQLite

People
Owner: Nobody in particular
Requestors: gabor [...] perl.org.il
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Date: Thu, 6 Jan 2005 22:35:58 +0200 (IST)
From: Gabor Szabo <gabor [...] perl.org.il>
To: bug-dbd-sqlite [...] rt.cpan.org
CC: matt [...] sergeant.org
Subject: DBD::SQLite installation fails without DBI
Hi Matt, If I am trying to install DBD::SQLite without a DBI using CPAN.pm it fails because before it can require it as a prerequisite it tries to load it. I think it is in both versions of DBD::SQLite I think you can remove this part of the Makefile.PL: eval { require DBI; require DBI::DBD; die "Your DBI Version is too old - require at least 1.03" unless $DBI::VERSION >= 1.03; }; and then this code might also need to go, but I don't understand what is it about: my $nlid = $DBI::VERSION > 1.42 ? '' : '-Dno_last_insert_id'; The error btw looks like this. DBD-SQLite-1.07/vdbeInt.h DBD-SQLite-1.07/vdbemem.c DBD-SQLite-1.07/where.c Removing previously used /root/.cpan/build/DBD-SQLite-1.07 CPAN.pm: Going to build M/MS/MSERGEANT/DBD-SQLite-1.07.tar.gz Checking if your kit is complete... Looks good Warning: prerequisite DBI 1.21 not found. Undefined subroutine &DBI::DBD::dbd_postamble called at Makefile.PL line 58. Running make test Make had some problems, maybe interrupted? Won't test Running make install Make had some problems, maybe interrupted? Won't install


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.