Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 94745
Status: resolved
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: MSCHILLI [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.981
Fixed in: (no value)



Subject: IO::Socket::SSL breaks LWP::Protocol::https test suite - ideas?
Hi Steffen, I've noticed that with later versions of IO::Socket::SSL, the proxy tests in LWP::Protocol::https are failing, and I thought that because you coincidentally authored those as well, you might know what's going on there: https://github.com/libwww-perl/lwp-protocol-https/blob/master/t/https_proxy.t fails with # ID: 3.7.auth@nossl # --------- # GET https://foo/foo HTTP/1.1 # TE: deflate,gzip;q=0.3 # Connection: TE # Host: foo # Proxy-Authorization: Basic Zm9vOmJhcg== # User-Agent: libwww-perl/6.05 not ok 38 - URL in request -> /foo # Failed test 'URL in request -> /foo' # at t/https_proxy.t line 190. # got: 'https://foo/foo' # expected: '/foo' not ok 39 - proxy https://foo/bar -> C.9.Tauth@foo # Failed test 'proxy https://foo/bar -> C.9.Tauth@foo' # at t/https_proxy.t line 182. # got: 'C.8.auth@nossl' # expected: 'C.9.Tauth@foo' # ... Would be great if you could shed some light on this. I'd be happy to apply the fix to LWP::Protocol, only hoping to get some background on what's missing. Any help would be greatly appreciated! -- Mike
Download (untitled) / with headers
text/plain 1.8k
Hi Mike, these are changes to LWP::Protocol::https which depend on changes in libwww. With version <=6.05 support for https proxies in LWP is broken and my changes from 11/2013 for libwww and lwp-protocol-https fix this - but they have to be used together. So actually this version of lwp-protocol-https must depend on a not yet released libwww version 6.06 and if you try it with the latest libwww from github the tests pass (at least for me). I don't know when 6.06 will be released - me and others already wait for ages and debian incorporated the changes because they could not wait any longer for a release. Maybe you could help to speed up a new release :) Regards, Steffen Am Di 15. Apr 2014, 03:12:00, MSCHILLI schrieb: Show quoted text
> Hi Steffen, > > I've noticed that with later versions of IO::Socket::SSL, the proxy > tests in LWP::Protocol::https are failing, and I thought that because > you coincidentally authored those as well, you might know what's going > on there: > > https://github.com/libwww-perl/lwp-protocol- > https/blob/master/t/https_proxy.t > > fails with > > # ID: 3.7.auth@nossl > # --------- > # GET https://foo/foo HTTP/1.1 > # TE: deflate,gzip;q=0.3 > # Connection: TE > # Host: foo > # Proxy-Authorization: Basic Zm9vOmJhcg== > # User-Agent: libwww-perl/6.05 > not ok 38 - URL in request -> /foo > # Failed test 'URL in request -> /foo' > # at t/https_proxy.t line 190. > # got: 'https://foo/foo' > # expected: '/foo' > not ok 39 - proxy https://foo/bar -> C.9.Tauth@foo > # Failed test 'proxy https://foo/bar -> C.9.Tauth@foo' > # at t/https_proxy.t line 182. > # got: 'C.8.auth@nossl' > # expected: 'C.9.Tauth@foo' > # ... > > Would be great if you could shed some light on this. I'd be happy to > apply the fix to LWP::Protocol, only hoping to get some background on > what's missing. Any help would be greatly appreciated! > > -- Mike
Download (untitled) / with headers
text/plain 221b
On Tue Apr 15 03:26:43 2014, SULLR wrote: Show quoted text
> I don't know when 6.06 will be released - me and others already wait > for ages
Ah, good to know, thanks! I'm in the process of rolling out a new libwww release, stay tuned.
Interestingly, I get the same errors with libwww 6.05 installed from github (HEAD): t/apache.t ......... ok t/https_proxy.t .... 1/56 # creating cert for direct.ssl.access # creating cert for direct.ssl.access t/https_proxy.t .... 29/56 # Failed test 'proxy https://foo/foo -> C.8.Tauth@foo' # at t/https_proxy.t line 182. # got: 'C.7.auth@nossl' # expected: 'C.8.Tauth@foo' # HTTP/1.1 200 ok # Connection: keep-alive # Content-Length: 181 # Content-Type: text/plain # Client-Date: Wed, 16 Apr 2014 06:29:21 GMT # Client-Peer: 127.0.0.1:35294 # Client-Response-Num: 7 # # ID: 3.7.auth@nossl # --------- # GET https://foo/foo HTTP/1.1 # TE: deflate,gzip;q=0.3 # Connection: TE # Host: foo # Proxy-Authorization: Basic Zm9vOmJhcg== # User-Agent: libwww-perl/6.05 # Failed test 'URL in request -> /foo' # at t/https_proxy.t line 190. # got: 'https://foo/foo' # expected: '/foo' # Failed test 'proxy https://foo/bar -> C.9.Tauth@foo' # at t/https_proxy.t line 182. # got: 'C.8.auth@nossl' # expected: 'C.9.Tauth@foo' Any pointers how to fix them?
Download (untitled) / with headers
text/plain 1014b
Am Mi 16. Apr 2014, 02:30:52, MSCHILLI schrieb: Show quoted text
> Interestingly, I get the same errors with libwww 6.05 installed from > github (HEAD):
I cannot reproduce this with HEAD from github. Can you please add the following to the top of the test to make sure that we are talking about the same versions: use Digest::MD5; for( grep { m{LWP|SSL\.pm} } keys %INC ) { no strict 'refs'; open( my $fh,'<',$INC{$_}); warn "$_ | ". Digest::MD5->new->addfile($fh)->hexdigest."\n"; } In my setup this gives IO/Socket/SSL.pm | 44f43e3cddcef54bc1ad78a9c42d48d8 LWP/Protocol/https.pm | 3afd6affbbcccfbe2003eb4edc94f9de LWP/MemberMixin.pm | eb411881a3941b071d2837c3318d1634 LWP/Protocol/http.pm | 90dd0c89df008bc1647faf5517674a87 LWP/UserAgent.pm | c1e752310f08c82fae2988610539ef76 LWP.pm | f0217092871ca1b25fb47a93b5ebea1c LWP/Protocol.pm | f60f9850710ff71e029032519ec96e8b While the hash for SSL.pm might differ (I use 1.981) the hashes for LWP* should reflect the HEAD on github and thus be the same.
CC: MSCHILLI [...] cpan.org, behroozi [...] www.pls.uni.edu
Subject: Re: [rt.cpan.org #94745] IO::Socket::SSL breaks LWP::Protocol::https test suite - ideas?
Date: Wed, 16 Apr 2014 20:06:23 -0700 (PDT)
To: Steffen Ullrich via RT <bug-IO-Socket-SSL [...] rt.cpan.org>
From: Mike Schilli <m [...] perlmeister.com>
Download (untitled) / with headers
text/plain 438b
On Wed, 16 Apr 2014, Steffen Ullrich via RT wrote: Show quoted text
> In my setup this gives IO/Socket/SSL.pm > | 44f43e3cddcef54bc1ad78a9c42d48d8 LWP/Protocol/https.pm > | 3afd6affbbcccfbe2003eb4edc94f9de
Thanks so much for this, I had indeed a rogue version of LWP::Protocol::http (no s) sitting there which caused the problem, after deleting that everything went through without error. Much appreciated! -- -- Mike Mike Schilli m@perlmeister.com
Download (untitled) / with headers
text/plain 541b
Am Mi 16. Apr 2014, 23:07:01, m@perlmeister.com schrieb: Show quoted text
> On Wed, 16 Apr 2014, Steffen Ullrich via RT wrote: >
> > In my setup this gives IO/Socket/SSL.pm > > | 44f43e3cddcef54bc1ad78a9c42d48d8 LWP/Protocol/https.pm > > | 3afd6affbbcccfbe2003eb4edc94f9de
> > Thanks so much for this, I had indeed a rogue version of > LWP::Protocol::http (no s) sitting there which caused the problem, after > deleting that everything went through without error. > > Much appreciated! >
That's what I thought because this happend to me before too :)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.