Skip Menu |
 

This queue is for tickets about the Crypt-SSLeay CPAN distribution.

Report information
The Basics
Id: 94626
Status: resolved
Priority: 0/
Queue: Crypt-SSLeay

People
Owner: nanis [...] runu.moc.invalid
Requestors: KENTNL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 0.65_06
  • 0.65_07
  • 0.65_08
  • 0.65_09
Fixed in: 0.65_10



Subject: Couldn't find module or a distribution IO::Intereactive::Tiny in dependency resolution

Looks like there's a typo in the deps.

Unless that module is really that badly named;

 

https://metacpan.org/diff/file?target=NANIS/Crypt-SSLeay-0.65_08/&source=NANIS/Crypt-SSLeay-0.64/#META.json

-            "ExtUtils::MakeMaker" : "0"
+            "Devel::CheckLib" : "0.99",
+            "ExtUtils::CBuilder" : "0.280205",
+            "Getopt::Long" : "0",
+            "IO::Intereactive::Tiny" : "0",    <-----------
+            "Path::Class" : "0.26",
+            "Try::Tiny" : "0.19"


Given its correct in Makefile.PL, somebody just transposed wrong:
 

-use Getopt::Long;
+use Getopt::Long qw( GetOptionsFromArray );
+use IO::Interactive::Tiny;
+use Path::Class;
 

 

Interactive  # right
Intereactive # wrong

 


 

Download (untitled) / with headers
text/plain 248b
I find it odd that there is a discrepancy between Makefile.PL and META.json. META.json is normally generated from a tool - either from running Makefile.PL itself, or by some other packaging tool. One should never be constructing this file by hand.

Ah. I see.

Its 'used' correctly in Makefile.PL

 

https://metacpan.org/source/NANIS/Crypt-SSLeay-0.65_08/Makefile.PL#L9

9: use IO::Interactive::Tiny;

 

However, the string in the code is wrong:

 

https://metacpan.org/source/NANIS/Crypt-SSLeay-0.65_08/Makefile.PL#L134

 

130: CONFIGURE_REQUIRES => {

...

134: 'IO::Intereactive::Tiny' => 0,

 

^^^^^ Here is the source of the bug I think.

Download (untitled) / with headers
text/plain 576b
Yup ... Thank you very, very, very much! I had been staring at that for awhile and not seeing it. -- Sinan On Fri Apr 11 13:47:24 2014, KENTNL wrote: Show quoted text
> Ah. I see. > > Its 'used' correctly in Makefile.PL > > https://metacpan.org/source/NANIS/Crypt-SSLeay-0.65_08/Makefile.PL#L9 > > 9: use IO::Interactive::Tiny; > > However, the string in the code is wrong: > > https://metacpan.org/source/NANIS/Crypt-SSLeay-0.65_08/Makefile.PL#L134 > > 130: CONFIGURE_REQUIRES => { > > ... > > 134: 'IO::Intereactive::Tiny' => 0, > > ^^^^^ Here is the source of the bug I think.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.