Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 94591
Status: new
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.32
Fixed in: (no value)



Subject: perlver returns different results than ->minimum_version
Download (untitled) / with headers
text/plain 1.3k
I'm using Dist::Zilla::Plugin::MinimumPerl to determine a minimum version. From this file: https://metacpan.org/source/ETHER/Dist-Zilla-PluginBundle-Author-ETHER-0.056/t/02-minter-github.t this code returns 5.013002: Perl::MinimumVersion->new( \$content )->minimum_version; but different invocations of `perlver` yield different results: $ perlver t/02-minter-github.t --------------------------------------------------- | file | explicit | syntax | external | | --------------------------------------------------- | | t/02-minter-github.t | v5.13.2 | v5.6.0 | n/a | | --------------------------------------------------- | | Minimum explicit version : v5.13.2 | | Minimum syntax version : v5.6.0 | | Minimum version of perl : v5.13.2 | --------------------------------------------------- $ perlver --blame t/02-minter-github.t ------------------------------------------------------------ File : t/02-minter-github.t Line : 2 Char : 1 Rule : _perl_5006_pragmas Version : 5.006 ------------------------------------------------------------ use warnings FATAL => 'all'; ------------------------------------------------------------ Perhaps the root cause is https://rt.cpan.org/Ticket/Display.html?id=94590 ?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.