Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 94590
Status: new
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.32
Fixed in: (no value)



Download (untitled) / with headers
text/plain 374b
When scanning a file with: my $ver = $pmv->minimum_version; my $reason = $pmv->minimum_explicit_reason; Invalid version format (non-numeric data) at /Users/ether/.perlbrew/libs/19.10@std/lib/perl5/Perl/MinimumVersion.pm line 278. This is because a Perl::MinimumVersion::Reason object is being compared to a version object. The reason object needs a <=> overload.
Download (untitled) / with headers
text/plain 117b
Code correction my $pmv = Perl::MinimumVersion->new( \$file_content ); my $reason = $pmv->minimum_explicit_reason;


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.