Skip Menu |
 

This queue is for tickets about the libxml-perl CPAN distribution.

Report information
The Basics
Id: 9451
Status: new
Priority: 0/
Queue: libxml-perl

People
Owner: Nobody in particular
Requestors: dgray [...] internap.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in:
  • 0.06
  • 0.07
  • 0.08
Fixed in: (no value)



Subject: XML::Parser::PerlSAX should not "use UNIVERSAL"
Download (untitled) / with headers
text/plain 704b
Using .07 but it looks as though .08 has same problem: So if you want to reproduce the problem just do: perl -e 'use XML::Parser::PerlSAX; use Crypt::Random;' It will produce nasty messages about Crypt::Random not exporting subs. Notice that the following does the same error: perl -e 'use UNIVERSAL; use Crypt::Random;' I'm using 5.6.1 and can not upgrade as of yet, I think that using UNIVERSAL in later version of perl may work but it is still not suggested. See following about not use'ing UNIVERSAL: http://groups-beta.google.com/groups?hl=en&q=Crypt%3A%3ARandom+%22not+exported%22&qt_s=Search+Groups http://www.xray.mpe.mpg.de/mailing-lists/perl5-porters/2003-10/msg00163.html Thanks!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.