Skip Menu |
 

This queue is for tickets about the Tapper-TAP-Harness CPAN distribution.

Report information
The Basics
Id: 94307
Status: rejected
Priority: 0/
Queue: Tapper-TAP-Harness

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc: ether [...] cpan.org
AdminCc:

Bug Information
Severity: (no value)
Broken in: 4.1.1
Fixed in: (no value)



Subject: Undeclared dependency on Class::MOP
Download (untitled) / with headers
text/plain 3.3k
As per subject. There is no sample fail report at cpantesters yet, but I see it on my smoker. It seems Moose installations without Class::MOP are rare, but current Moose has no dependency on it, so packages that rely on that dependency are now breaking. Here a bit of the output of the cpan shell: Tapper-TAP-Harness-4.1.1/xt/lazyplan_noyaml.t Tapper-TAP-Harness-4.1.1/xt/critic.t Tapper-TAP-Harness-4.1.1/META.json Tapper-TAP-Harness-4.1.1/MANIFEST Tapper-TAP-Harness-4.1.1/META.yml Tapper-TAP-Harness-4.1.1/dist.ini Tapper-TAP-Harness-4.1.1/Changes Tapper-TAP-Harness-4.1.1/LICENSE Tapper-TAP-Harness-4.1.1/README Configuring T/TA/TAPPER/Tapper-TAP-Harness-4.1.1.tar.gz with Makefile.PL Checking if your kit is complete... Looks good Generating a Unix-style Makefile Writing Makefile for Tapper::TAP::Harness Writing MYMETA.yml and MYMETA.json (/home/sand/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da/bin/perl Makefile.PL exited with 0) CPAN::Reporter: Makefile.PL result is 'pass', No errors. TAPPER/Tapper-TAP-Harness-4.1.1.tar.gz /home/sand/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da/bin/perl Makefile.PL -- OK Running make for T/TA/TAPPER/Tapper-TAP-Harness-4.1.1.tar.gz ==========monitoring proc 913 perl /home/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da secs 8.0000======= cp lib/Tapper/TAP/Harness.pm blib/lib/Tapper/TAP/Harness.pm Manifying blib/man3/Tapper::TAP::Harness.3 (/usr/bin/make exited with 0) CPAN::Reporter: make result is 'pass', No errors. TAPPER/Tapper-TAP-Harness-4.1.1.tar.gz /usr/bin/make -- OK Running make test PERL_DL_NONLAZY=1 /home/sand/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da/bin/perl "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/backcompat/*.t ==========monitoring proc 913 perl /home/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da secs 9.0000======= # Failed test 'use Tapper::TAP::Harness;' # at t/00-load.t line 6. # Tried to use 'Tapper::TAP::Harness'. # Error: Can't locate Class/MOP.pm in @INC (you may need to install the Class::MOP module) (@INC contains: /tmp/loop_over_bdir-912-QvaXPL/Tapper-TAP-Harness-4.1.1-PhqbgW/blib/lib /tmp/loop_over_bdir-912-QvaXPL/Tapper-TAP-Harness-4.1.1-PhqbgW/blib/arch /home/sand/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da/lib/site_perl/5.19.11/x86_64-linux-thread-multi-ld /home/sand/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da/lib/site_perl/5.19.11 /home/sand/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da/lib/5.19.11/x86_64-linux-thread-multi-ld /home/sand/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da/lib/5.19.11) at /home/sand/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da/lib/site_perl/5.19.11/x86_64-linux-thread-multi-ld/Moose/Exporter.pm line 10. # BEGIN failed--compilation aborted at /home/sand/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da/lib/site_perl/5.19.11/x86_64-linux-thread-multi-ld/Moose/Exporter.pm line 10. # Compilation failed in require at /home/sand/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da/lib/site_perl/5.19.11/x86_64-linux-thread-multi-ld/Moose.pm line 16. Cheers,
RT-Send-CC: ether [...] cpan.org
Download (untitled) / with headers
text/plain 312b
Now that I look at it again I discover, it looks much more like a bug in Moose since the first diagnostics line is coming from Moose/Exporter.pm line 10. And there it is: use Class::MOP; So Moose seems to need a test that uses the exporter in a similar way as Tapper::TAP::Harness. I'll Cc Karen. Best wishes,
Subject: Re: [rt.cpan.org #94307] Undeclared dependency on Class::MOP
Date: Sun, 30 Mar 2014 09:44:48 -0700
To: Andreas Koenig via RT <bug-Tapper-TAP-Harness [...] rt.cpan.org>
From: Karen Etheridge <ether [...] cpan.org>
Download (untitled) / with headers
text/plain 927b
Andreas, do you have a smoker report showing this issue? I couldn't find any failures at http://matrix.cpantesters.org/?dist=Tapper-TAP-Harness+4.1.1 that looked like they were caused by the same problem. (There are a few unrelated issues with IO::ZLib and unicode character encodings, though.) Moose is listed as a prereq in META.json, so I don't immediately see what the problem could be. Seeing a list of what library versions have been installed might help. On Sun, Mar 30, 2014 at 01:02:07AM -0400, Andreas Koenig via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=94307 > > > Now that I look at it again I discover, it looks much more like a bug in Moose since the first diagnostics line is coming from Moose/Exporter.pm line 10. And there it is: > > use Class::MOP; > > So Moose seems to need a test that uses the exporter in a similar way as Tapper::TAP::Harness. I'll Cc Karen. > > Best wishes,
CC: ANDK [...] cpan.org
Subject: Re: [rt.cpan.org #94307] Undeclared dependency on Class::MOP
Date: Mon, 31 Mar 2014 08:56:53 +0200
To: bug-Tapper-TAP-Harness [...] rt.cpan.org
From: Andreas Koenig <andreas.koenig.7os6VVqR [...] franz.ak.mind.de>
Download (untitled) / with headers
text/plain 1.9k
"Karen Etheridge via RT" <bug-Tapper-TAP-Harness@rt.cpan.org> writes: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=94307 > > > > Andreas, do you have a smoker report showing this issue?
There is an additional bug in CPAN::Reporter that I have not yet understood and that holds this report back. On further reflection I now realize that the bug seems to be that Class::MOP is not installed after installing Moose. And this is something I cannot reproduce at the moment:( Show quoted text
> Moose is listed as a prereq in META.json, so I don't immediately see what > the problem could be. Seeing a list of what library versions have been > installed might help.
I agree, it can't be diagnosed from what we have. I had two bleedperls with Moose installed but without Class::MOP. cpan[1]> m Class::MOP CPAN: Storable loaded ok (v2.48) Reading '/home/sand/.cpan/Metadata' Database was generated on Mon, 31 Mar 2014 04:53:02 GMT CPAN: LWP::UserAgent loaded ok (v6.05) CPAN: YAML::Syck loaded ok (v1.27) CPAN: URI::URL loaded ok (v5.04) Module id = Class::MOP CPAN_USERID ETHER (Karen Etheridge <ether@cpan.org>) CPAN_VERSION 2.1204 CPAN_FILE E/ET/ETHER/Moose-2.1204.tar.gz UPLOAD_DATE 2014-02-07 INST_FILE (not installed) cpan[2]> m Moose Module id = Moose CPAN_USERID ETHER (Karen Etheridge <ether@cpan.org>) CPAN_VERSION 2.1204 CPAN_FILE E/ET/ETHER/Moose-2.1204.tar.gz UPLOAD_DATE 2014-02-07 MANPAGE Moose - A postmodern object system for Perl 5 INST_FILE /home/sand/src/perl/repoperls/installed-perls/perl/v5.19.10-18-gfb5a6c4/a2da/lib/site_perl/5.19.11/x86_64-linux-thread-multi-ld/Moose.pm INST_VERSION 2.1204 I don't know how it came about that Class::MOP was not installed there. If I force an install of Moose there, then Class::MOP actually gets installed and the problem disappears. I'll have to keep an eye on this, but at the moment I have no chance to try out more. -- andreas
RT-Send-CC: andreas.koenig.7os6VVqR [...] franz.ak.mind.de
Download (untitled) / with headers
text/plain 774b
On 2014-03-30 23:57:11, andreas.koenig.7os6VVqR@franz.ak.mind.de wrote: Show quoted text
> I agree, it can't be diagnosed from what we have. I had two bleedperls > with Moose installed but without Class::MOP. > > I don't know how it came about that Class::MOP was not installed > there. > If I force an install of Moose there, then Class::MOP actually gets > installed and the problem disappears. > > I'll have to keep an eye on this, but at the moment I have no chance > to > try out more.
This is very odd indeed. Moose and Class::MOP *used* to be shipped as separate distributions, but if you are installing the latest version (2.1204), you'll definitely get both packages. (Also, the earlier distributions of Moose did correctly declare a dependency on the Class-MOP distribution.)
CC: ANDK [...] cpan.org
Subject: Re: [rt.cpan.org #94307] Undeclared dependency on Class::MOP
Date: Mon, 31 Mar 2014 22:25:56 +0200
To: bug-Tapper-TAP-Harness [...] rt.cpan.org
From: Andreas Koenig <andreas.koenig.7os6VVqR [...] franz.ak.mind.de>
Download (untitled) / with headers
text/plain 555b
"Karen Etheridge via RT" <bug-Tapper-TAP-Harness@rt.cpan.org> writes: Show quoted text
> This is very odd indeed. Moose and Class::MOP *used* to be shipped as > separate distributions, but if you are installing the latest version > (2.1204), you'll definitely get both packages. (Also, the earlier > distributions of Moose did correctly declare a dependency on the > Class-MOP distribution.)
In the meantime I have tried out some more bleadperls and installed Moose early and it did not happen again that Class::MOP was lost during installation. Mysteries. -- andreas
Download (untitled) / with headers
text/plain 280b
Phew, I have never done this before but it seems appropriate to me: I set my own ticket to rejected. I see nothing here that qualifies as a bug because it is not reproducible. And the subject line is wrong. It's a weird bugreport and deserves nothing but rejection. :) && Thanks,


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.