Skip Menu |
 

This queue is for tickets about the XML-Twig CPAN distribution.

Report information
The Basics
Id: 94299
Status: resolved
Priority: 0/
Queue: XML-Twig

People
Owner: Nobody in particular
Requestors: racke [...] linuxia.de
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 3.48
Fixed in: (no value)



Subject: New test fails in XML::Twig 3.47
Download (untitled) / with headers
text/plain 238b
t/test_3_47.t ....................... 1/3 # Looks like you planned 3 tests but ran 5. t/test_3_47.t ....................... Dubious, test returned 255 (wstat 65280, 0xff00) All 3 subtests passed (less 3 skipped subtests: 0 okay)
From: dsteinbrunner [...] pobox.com
On Sat Mar 29 07:06:41 2014, HORNBURG wrote: Show quoted text
> t/test_3_47.t ....................... 1/3 # Looks like you planned 3 > tests but ran 5. > t/test_3_47.t ....................... Dubious, test returned 255 > (wstat 65280, 0xff00) > All 3 subtests passed > (less 3 skipped subtests: 0 okay)
I get the same. If I change the test count to 5 and rerun I get this: t/test_3_47.t ....................... 1/5 # Failed test 'In and out are the same (HTML::TreeBuilder)' # at t/test_3_47.t line 29. # '<html><head></head><body><h1>Herethere v&amp;r;</h1><p>marco&amp;company; and marcocompany ? ? ? ?</p></body></html>' # doesn't match '(?^u:\<h1\>Here\&amp\;there\ v\&amp\;r\;\<\/h1\>\<p\>marco\&amp\;company\;\ and\ marco\&amp\;company\ \?\ \?\ \?\ \?\<\/p\>)' # Failed test 'regexp on attribute, including an = sign' # at t/test_3_47.t line 40. # got: undef # expected: 'e1' # Looks like you failed 2 tests of 5. t/test_3_47.t ....................... Dubious, test returned 2 (wstat 512, 0x200) Failed 2/5 subtests
Subject: Re: [rt.cpan.org #94299] New test fails in XML::Twig 3.47
Date: Sat, 29 Mar 2014 09:33:27 -0400
To: bug-XML-Twig [...] rt.cpan.org
From: Michel Rodriguez <xmltwig [...] gmail.com>
Download (untitled) / with headers
text/plain 1.3k
Drats! Thanks, I'll look at it tonight. On Mar 29, 2014 12:17 PM, "dsteinbrunner@pobox.com via RT" < bug-XML-Twig@rt.cpan.org> wrote: Show quoted text
> Queue: XML-Twig > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=94299 > > > On Sat Mar 29 07:06:41 2014, HORNBURG wrote:
> > t/test_3_47.t ....................... 1/3 # Looks like you planned 3 > > tests but ran 5. > > t/test_3_47.t ....................... Dubious, test returned 255 > > (wstat 65280, 0xff00) > > All 3 subtests passed > > (less 3 skipped subtests: 0 okay)
> > > I get the same. If I change the test count to 5 and rerun I get this: > > t/test_3_47.t ....................... 1/5 > # Failed test 'In and out are the same (HTML::TreeBuilder)' > # at t/test_3_47.t line 29. > # '<html><head></head><body><h1>Herethere > v&amp;r;</h1><p>marco&amp;company; and marcocompany ? ? ? > ?</p></body></html>' > # doesn't match '(?^u:\<h1\>Here\&amp\;there\ > v\&amp\;r\;\<\/h1\>\<p\>marco\&amp\;company\;\ and\ marco\&amp\;company\ > \?\ \?\ \?\ \?\<\/p\>)' > > # Failed test 'regexp on attribute, including an = sign' > # at t/test_3_47.t line 40. > # got: undef > # expected: 'e1' > # Looks like you failed 2 tests of 5. > t/test_3_47.t ....................... Dubious, test returned 2 (wstat 512, > 0x200) > Failed 2/5 subtests >
Download (untitled) / with headers
text/plain 122b
Damn Skippy! I was skipping too much when one of the HTML conversion modules wasn't available. fixed in 3.48 -- mirod
Download (untitled) / with headers
text/plain 1.2k
Are you sure you ran the test with the new version? The failing tests are those on bugs fixed in 3.47. -- mirod On Sat Mar 29 07:17:27 2014, dsteinbrunner@pobox.com wrote: Show quoted text
> On Sat Mar 29 07:06:41 2014, HORNBURG wrote:
> > t/test_3_47.t ....................... 1/3 # Looks like you planned 3 > > tests but ran 5. > > t/test_3_47.t ....................... Dubious, test returned 255 > > (wstat 65280, 0xff00) > > All 3 subtests passed > > (less 3 skipped subtests: 0 okay)
> > > I get the same. If I change the test count to 5 and rerun I get this: > > t/test_3_47.t ....................... 1/5 > # Failed test 'In and out are the same (HTML::TreeBuilder)' > # at t/test_3_47.t line 29. > # '<html><head></head><body><h1>Herethere > v&amp;r;</h1><p>marco&amp;company; and marcocompany ? ? ? > ?</p></body></html>' > # doesn't match '(?^u:\<h1\>Here\&amp\;there\ > v\&amp\;r\;\<\/h1\>\<p\>marco\&amp\;company\;\ and\ > marco\&amp\;company\ \?\ \?\ \?\ \?\<\/p\>)' > > # Failed test 'regexp on attribute, including an = sign' > # at t/test_3_47.t line 40. > # got: undef > # expected: 'e1' > # Looks like you failed 2 tests of 5. > t/test_3_47.t ....................... Dubious, test returned 2 (wstat > 512, 0x200) > Failed 2/5 subtests
Subject: Re: [rt.cpan.org #94299] New test fails in XML::Twig 3.47
Date: Sun, 30 Mar 2014 14:05:39 +0200
To: bug-XML-Twig [...] rt.cpan.org
From: "Stefan Hornburg (Racke)" <racke [...] linuxia.de>
Download (untitled) / with headers
text/plain 463b
On 03/30/2014 11:02 AM, MIROD via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=94299 > > > Damn Skippy! > > I was skipping too much when one of the HTML conversion modules wasn't available. > > fixed in 3.48 >
Thanks a lot for quick fix, the test is working now and the HTML entities are good now as well. Regards Racke -- Perl and Dancer Development Visit our Open Source conference on E-commerce: http://www.ecommerce-innovation.com/


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.