Skip Menu |
 

This queue is for tickets about the RT-Authen-ExternalAuth CPAN distribution.

Report information
The Basics
Id: 94014
Status: new
Priority: 0/
Queue: RT-Authen-ExternalAuth

People
Owner: Nobody in particular
Requestors: raphael.berlamont [...] raphux.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: uninitialized string in LDAP.pm
Date: Wed, 19 Mar 2014 20:26:02 +0100
To: bug-RT-Authen-ExternalAuth [...] rt.cpan.org
From: Raphaël Berlamont <raphael.berlamont [...] raphux.com>
Download (untitled) / with headers
text/plain 1.9k
Hi, Installed RT-Authen-ExternalAuth (0.18) on RT 4.0.19, and got this error when login into RT : =========== An internal RT error has occurred. Your administrator can find more details in RT's log files. =========== If the page is reloaded (F5), user can access the page without any other error. Full log : ============== [2021] [Wed Mar 19 18:38:00 2014] [error]: Can't call method "as_string" on an undefined value at /opt/rt4/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm line 563. Stack: [/opt/rt4/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth/LDAP.pm:563] [/opt/rt4/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:564] [/opt/rt4/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:397] [/opt/rt4/local/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm:349] [/opt/rt4/local/plugins/RT-Authen-ExternalAuth/html/Elements/DoAuth:15] [/opt/rt4/local/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAuth/autohandler/Session:1] [/opt/rt4/sbin/../lib/RT/Interface/Web.pm:276] [/opt/rt4/share/html/autohandler:53] (/opt/rt4/sbin/../lib/RT/Interface/Web/Handler.pm:208) =============== The only way I managed to make it work, is to comment the concerned line : ============ [root@dgilx202 tmp]# diff -Nau LDAP.pm.ori LDAP.pm --- LDAP.pm.ori 2014-03-19 20:21:46.176477611 +0100 +++ LDAP.pm 2014-03-19 20:21:17.901962560 +0100 @@ -564,7 +564,7 @@ "Base:", $base, "== Filter:", - $search_filter->as_string, +# $search_filter->as_string, "== Attrs:", join(',',@attrs)); [root@dgilx202 tmp]# ============= The plugin then work flawlessly. I guess I miss something in the config, but don't really know what (I do have a LDAP filter). Regards, -- Raphaël Berlamont


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.