This queue is for tickets about the TermReadKey CPAN distribution.

Report information
The Basics
Id:
93581
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
chm [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
2.31
Fixed in:
2.32



Subject: Term::ReadKey 2.31 is UNAUTHORIZED release
... because co-maint permissions have not been given to Jonathan Stowe for the
Configure module.
Subject: Re: [rt.cpan.org #93581] Term::ReadKey 2.31 is UNAUTHORIZED release
Date: Sun, 09 Mar 2014 21:44:21 +0000
To: bug-TermReadKey@rt.cpan.org
From: Jonathan Stowe <jonathan.stowe@gmail.com>
Hi, The Configure.pm has always been in the distribution since before I was maintaining it, something changed in the interim about the way things were indexed. The solution is to stop the PAUSE from indexing it, which is simple, just do package Configure; ;-) I'll stick it in the next release. On Thu, 2014-03-06 at 17:18 -0500, Chris Marshall via RT wrote:
Show quoted text
> Thu Mar 06 17:18:02 2014: Request 93581 was acted upon. > Transaction: Ticket created by CHM > Queue: TermReadKey > Subject: Term::ReadKey 2.31 is UNAUTHORIZED release > Broken in: 2.31 > Severity: Important > Owner: Nobody > Requestors: chm@cpan.org > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=93581 > > > > ... because co-maint permissions have not been given to Jonathan Stowe for the > Configure module. >
CC: chm@cpan.org
Subject: Re: [rt.cpan.org #93581] Term::ReadKey 2.31 is UNAUTHORIZED release
Date: Mon, 10 Mar 2014 10:10:38 -0400
To: bug-TermReadKey@rt.cpan.org
From: Chris Marshall <devel.chm.01@gmail.com>
Since the latest official Configure was indexed with Term-ReadKey-2.14 and since the current Configure.pm in the Term-ReadKey-2.31+ release is different, you'll need to make sure that the local, different copy is *always* used even if the older version is present. The more robust solution would be to request Kenneth Albanowski to give you co-maint for the already-indexed Configure module. That would minimize potential install/packaging glitches going forward. --Chris On Sun, Mar 9, 2014 at 5:44 PM, Jonathan Stowe via RT <bug-TermReadKey@rt.cpan.org> wrote:
Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=93581 > > > Hi, > The Configure.pm has always been in the distribution since before I was > maintaining it, something changed in the interim about the way things > were indexed. > > The solution is to stop the PAUSE from indexing it, which is simple, > just do > > package > Configure; > > ;-) > > I'll stick it in the next release. > > On Thu, 2014-03-06 at 17:18 -0500, Chris Marshall via RT wrote:
>> Thu Mar 06 17:18:02 2014: Request 93581 was acted upon. >> Transaction: Ticket created by CHM >> Queue: TermReadKey >> Subject: Term::ReadKey 2.31 is UNAUTHORIZED release >> Broken in: 2.31 >> Severity: Important >> Owner: Nobody >> Requestors: chm@cpan.org >> Status: new >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=93581 > >> >> >> ... because co-maint permissions have not been given to Jonathan Stowe for the >> Configure module. >>
> > >
Subject: Re: [rt.cpan.org #93581] Term::ReadKey 2.31 is UNAUTHORIZED release
Date: Mon, 10 Mar 2014 18:10:02 +0000
To: bug-TermReadKey@rt.cpan.org
From: Jonathan Stowe <jonathan.stowe@gmail.com>
If Kenneth Albanowski could be tracked down I wouldn't be maintaining the module, I think that would be a non-starter :) The module doesn't need to be installed, just used for purposes of writing out some XS parts, not indexing it will be fine. It doesn't need to be installed, On Mon, 2014-03-10 at 10:10 -0400, devel.chm.01@gmail.com via RT wrote:
Show quoted text
> Queue: TermReadKey > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=93581 > > > Since the latest official Configure was indexed with Term-ReadKey-2.14 > and since the current Configure.pm in the Term-ReadKey-2.31+ release > is different, you'll need to make sure that the local, different copy is > *always* used even if the older version is present. > > The more robust solution would be to request Kenneth Albanowski to give > you co-maint for the already-indexed Configure module. That would > minimize potential install/packaging glitches going forward. > > --Chris > > On Sun, Mar 9, 2014 at 5:44 PM, Jonathan Stowe via RT > <bug-TermReadKey@rt.cpan.org> wrote:
> > <URL: https://rt.cpan.org/Ticket/Display.html?id=93581 > > > > > Hi, > > The Configure.pm has always been in the distribution since before I was > > maintaining it, something changed in the interim about the way things > > were indexed. > > > > The solution is to stop the PAUSE from indexing it, which is simple, > > just do > > > > package > > Configure; > > > > ;-) > > > > I'll stick it in the next release. > > > > On Thu, 2014-03-06 at 17:18 -0500, Chris Marshall via RT wrote:
> >> Thu Mar 06 17:18:02 2014: Request 93581 was acted upon. > >> Transaction: Ticket created by CHM > >> Queue: TermReadKey > >> Subject: Term::ReadKey 2.31 is UNAUTHORIZED release > >> Broken in: 2.31 > >> Severity: Important > >> Owner: Nobody > >> Requestors: chm@cpan.org > >> Status: new > >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=93581 > > >> > >> > >> ... because co-maint permissions have not been given to Jonathan Stowe for the > >> Configure module. > >>
> > > > > >
>
CC: chm@cpan.org
Subject: Re: [rt.cpan.org #93581] Term::ReadKey 2.31 is UNAUTHORIZED release
Date: Mon, 10 Mar 2014 16:46:37 -0400
To: bug-TermReadKey@rt.cpan.org
From: Chris Marshall <devel.chm.01@gmail.com>
OK, I didn't realize that he was out of the picture. In that case, I suggest adding the appropriate -I option to the lines in Makefile.PL that have genchars.pl on them so that the included Configure.pm is the one that will be found. Regards, Chris On Mon, Mar 10, 2014 at 2:10 PM, Jonathan Stowe via RT <bug-TermReadKey@rt.cpan.org> wrote:
Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=93581 > > > If Kenneth Albanowski could be tracked down I wouldn't be maintaining > the module, I think that would be a non-starter :) > > The module doesn't need to be installed, just used for purposes of > writing out some XS parts, not indexing it will be fine. It doesn't > need to be installed, > > On Mon, 2014-03-10 at 10:10 -0400, devel.chm.01@gmail.com via RT wrote:
>> Queue: TermReadKey >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=93581 > >> >> Since the latest official Configure was indexed with Term-ReadKey-2.14 >> and since the current Configure.pm in the Term-ReadKey-2.31+ release >> is different, you'll need to make sure that the local, different copy is >> *always* used even if the older version is present. >> >> The more robust solution would be to request Kenneth Albanowski to give >> you co-maint for the already-indexed Configure module. That would >> minimize potential install/packaging glitches going forward. >> >> --Chris >> >> On Sun, Mar 9, 2014 at 5:44 PM, Jonathan Stowe via RT >> <bug-TermReadKey@rt.cpan.org> wrote:
>> > <URL: https://rt.cpan.org/Ticket/Display.html?id=93581 > >> > >> > Hi, >> > The Configure.pm has always been in the distribution since before I was >> > maintaining it, something changed in the interim about the way things >> > were indexed. >> > >> > The solution is to stop the PAUSE from indexing it, which is simple, >> > just do >> > >> > package >> > Configure; >> > >> > ;-) >> > >> > I'll stick it in the next release. >> > >> > On Thu, 2014-03-06 at 17:18 -0500, Chris Marshall via RT wrote:
>> >> Thu Mar 06 17:18:02 2014: Request 93581 was acted upon. >> >> Transaction: Ticket created by CHM >> >> Queue: TermReadKey >> >> Subject: Term::ReadKey 2.31 is UNAUTHORIZED release >> >> Broken in: 2.31 >> >> Severity: Important >> >> Owner: Nobody >> >> Requestors: chm@cpan.org >> >> Status: new >> >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=93581 > >> >> >> >> >> >> ... because co-maint permissions have not been given to Jonathan Stowe for the >> >> Configure module. >> >>
>> > >> > >> >
>>
> > >
RT-Send-CC: devel.chm.01@gmail.com, jonathan.stowe@gmail.com
Le 2014-03-06 23:18:02, CHM a écrit :
Show quoted text
> ... because co-maint permissions have not been given to Jonathan Stowe > for the > Configure module.
It looks like this has been fixed in the repo for feature releases: Configure.pm will not be indexed anymore. Commit: https://github.com/jonathanstowe/TermReadKey/commit/1db0ed9e74a4a0b3162990296a540508a1303d31 -- Olivier Mengué - http://perlresume.org/DOLMEN
Hi, since the 2.32 release the Configure.pm has been hidden from the indexer and this shouldn't happen again.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.