Skip Menu |
 

This queue is for tickets about the SOAP-Lite CPAN distribution.

Report information
The Basics
Id: 93555
Status: open
Priority: 0/
Queue: SOAP-Lite

People
Owner: Nobody in particular
Requestors: raherh [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.06
Fixed in: 0.716



Subject: empty uri with register_ns
Download (untitled) / with headers
text/plain 500b
I set a namespace with a prefix like this: $soap->serializer->register_ns('uri:kow' => 'xmlns:q0'); $soap->envprefix('soapenv'); $soap->on_action(sub{ '' }); $soap->autotype(0); $soap->ns('','q0'); When generating a request, the namespace declared with register_ns in soapenv:Envelope element is empty in about 40% of requests: xmlns:q0="" or correctly xmlns:q0="uri:kow" I tested this behaviour with 1.06, 1.10, 1.11 versions. Requests generation works ok with SOAP::Lite version 0.716. Radek
From: raherh [...] gmail.com
Download (untitled) / with headers
text/plain 176b
I had to fill in uri of the request: $soap->ns('myuri','q0'); then it's ok. Also additionally found out that previous versions have same behaviour as the latest one. Radek
Subject: Re: [rt.cpan.org #93555] empty uri with register_ns
Date: Thu, 27 Mar 2014 11:34:19 -0700
To: bug-SOAP-Lite [...] rt.cpan.org
From: Fred Moyer <fred [...] redhotpenguin.com>
Download (untitled) / with headers
text/plain 421b
Can you provide a patch which resolves this issue? On Thu, Mar 27, 2014 at 11:00 AM, Radek via RT <bug-SOAP-Lite@rt.cpan.org> wrote: Show quoted text
> Queue: SOAP-Lite > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=93555 > > > I had to fill in uri of the request: > $soap->ns('myuri','q0'); > then it's ok. > Also additionally found out that previous versions have same behaviour as the latest one. > > Radek > > > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.