Skip Menu |
 
rt.cpan.org will be shut down on March 1st, 2021.

This queue is for tickets about the Parse-CPAN-Meta CPAN distribution.

Report information
The Basics
Id: 93072
Status: resolved
Priority: 0/
Queue: Parse-CPAN-Meta

People
Owner: Nobody in particular
Requestors: jkeenan [...] cpan.org
Cc: ether [...] cpan.org
rjbs [...] cpan.org
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.4410
Fixed in: 1.4412

Attachments


CC: rjbs [...] cpan.org, ether [...] cpan.org
Subject: failure: utf8 does not map to Unicode
Download (untitled) / with headers
text/plain 893b
The .yml file attached is derived from the test suite for CPAN distribution Module-Install. When Module-Install's v1.06 was recently tested against Perl 5 blead, a failure emerged in that distro's t/20_authors_with_special_characters.t. Reported at: http://www.cpantesters.org/cpan/report/aa51b0e6-9619-11e3-9bb1-f0615d7e0655 That led to https://rt.perl.org/Ticket/Display.html?id=121262 Module-Install makes extensive use of the quasi-deprecated Parse::CPAN::Meta::Loadfile(). The failure can be triggered simply by using that function to try to read the .yml file attached. $ perl -MParse::CPAN::Meta -e '@yaml = Parse::CPAN::Meta::LoadFile( q|module_install_t20_META.yml| );'Error reading from file 'module_install_t20_META.yml': utf8 "\xE9" does not map to Unicode at /usr/local/lib/perl5/site_perl/5.18.0/Parse/CPAN/Meta.pm line 97. at -e line 1. Thank you very much. Jim Keenan
Subject: module_install_t20_META.yml
--- abstract: ~ author: - 'Olivier Mengué' build_requires: ExtUtils::MakeMaker: 6.36 configure_requires: ExtUtils::MakeMaker: 6.36 distribution_type: module dynamic_config: 1 generated_by: 'Module::Install version 1.06' license: perl meta-spec: url: http://module-build.sourceforge.net/META-spec-v1.4.html version: 1.4 name: Foo no_index: directory: - inc requires: perl: 5.005 resources: license: http://dev.perl.org/licenses/ version: 0.01
Download (untitled) / with headers
text/plain 1.9k
On Sun Feb 16 21:24:44 2014, JKEENAN wrote: Show quoted text
> The .yml file attached is derived from the test suite for CPAN > distribution Module-Install. When Module-Install's v1.06 was recently > tested against Perl 5 blead, a failure emerged in that distro's > t/20_authors_with_special_characters.t. Reported at: > > http://www.cpantesters.org/cpan/report/aa51b0e6-9619-11e3-9bb1- > f0615d7e0655 > > That led to https://rt.perl.org/Ticket/Display.html?id=121262 > > Module-Install makes extensive use of the quasi-deprecated > Parse::CPAN::Meta::Loadfile(). The failure can be triggered simply by > using that function to try to read the .yml file attached. > > $ perl -MParse::CPAN::Meta -e '@yaml = Parse::CPAN::Meta::LoadFile( > q|module_install_t20_META.yml| );'Error reading from file > 'module_install_t20_META.yml': utf8 "\xE9" does not map to Unicode > at /usr/local/lib/perl5/site_perl/5.18.0/Parse/CPAN/Meta.pm line 97. > at -e line 1. >
This appears to be fixedc by Parse::CPAN::Meta v1.4412. ##### $ perl -MData::Dumper -MParse::CPAN::Meta -e '@yaml = Parse::CPAN::Meta::LoadFile( q|module_install_t20_META.yml| );$Data::Dumper::Indent=1;print Dumper(\@yaml);' $VAR1 = [ { 'name' => 'Foo', 'dynamic_config' => '1', 'no_index' => { 'directory' => [ 'inc' ] }, 'version' => '0.01', 'license' => 'perl', 'requires' => { 'perl' => '5.005' }, 'distribution_type' => 'module', 'author' => [ 'Olivier Mengu\\xE9' ], 'resources' => { 'license' => 'http://dev.perl.org/licenses/' }, 'build_requires' => { 'ExtUtils::MakeMaker' => '6.36' }, 'configure_requires' => { 'ExtUtils::MakeMaker' => '6.36' }, 'meta-spec' => { 'version' => '1.4', 'url' => 'http://module-build.sourceforge.net/META-spec-v1.4.html' }, 'abstract' => undef, 'generated_by' => 'Module::Install version 1.06' } ]; ##### Closing ticket. Thank you very much. Jim Keenan


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.