Skip Menu |
 

This queue is for tickets about the Math-Int128 CPAN distribution.

Report information
The Basics
Id: 93050
Status: resolved
Priority: 0/
Queue: Math-Int128

People
Owner: Nobody in particular
Requestors: blue [...] thisisnotmyrealemail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: outdated check for clang
Download (untitled) / with headers
text/plain 119b
clang is at version 5, and the install script is only accepting version 3. I removed the check and it passed all tests.
On Sat Feb 15 18:04:47 2014, blue wrote: Show quoted text
> clang is at version 5, and the install script is only accepting > version 3. I removed the check and it passed all tests.
I've been unable to install this module on OS X for the same reason, I believe. I'm using this script in order to get the code to install cleanly: #!/bin/sh export ARCHFLAGS="-arch x86_64" wget http://cpan.metacpan.org/authors/id/S/SA/SALVA/Math-Int128-0.13.tar.gz tar zxf Math-Int128-0.13.tar.gz cd Math-Int128-0.13 PERL=perl cat >/tmp/p$$.patch <<'EOF' diff --git a/Makefile.PL b/Makefile.PL index 97b057b..dc8ea12 100644 --- a/Makefile.PL +++ b/Makefile.PL @@ -41,6 +41,10 @@ elsif ($cc_version =~ /\bclang\s+version\s+(3.(\d+)\S*)/im and $2 >= 2) { print "Clang compiler version $1 found, good!\n"; } +elsif ($cc_version =~ /\(clang-(\d+)/im and + $1 >= 300) { + print "Clang compiler version $1 found, good!\n"; +} else { unlink $mm->{MAKEFILE}; die "This module requires version 4.4 or above of the GCC compiler.\nAborting!\n\n" EOF patch -Ep1 < /tmp/p$$.patch $PERL Makefile.PL make make install
Fixed in 0.15. Thank you for reporting the issue!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.