Skip Menu |
 

This queue is for tickets about the strictures CPAN distribution.

Report information
The Basics
Id: 92965
Status: resolved
Priority: 0/
Queue: strictures

People
Owner: Nobody in particular
Requestors: ribasushi [...] leporine.io
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: 1.005003



Subject: The query-interface side of VERSION is broken
Download (untitled) / with headers
text/plain 352b
perl -Mstrictures\ 999 Major version specified as 999 - this is strictures version 1 at /home/rabbit/perl5/perlbrew/perls/5.16.2/lib/site_perl/5.16.2/strictures.pm line 15. perl -Mstrictures -e 'warn strictures->VERSION' Invalid version format (version required) at /home/rabbit/perl5/perlbrew/perls/5.16.2/lib/site_perl/5.16.2/strictures.pm line 23.
Subject: Re: [rt.cpan.org #92965] The query-interface side of VERSION is broken
Date: Wed, 12 Feb 2014 09:51:54 -0800
To: Peter Rabbitson via RT <bug-strictures [...] rt.cpan.org>
From: Karen Etheridge <ether [...] cpan.org>
Download (untitled) / with headers
text/plain 766b
On Wed, Feb 12, 2014 at 10:41:03AM -0500, Peter Rabbitson via RT wrote: Show quoted text
> perl -Mstrictures\ 999 > Major version specified as 999 - this is strictures version 1 at /home/rabbit/perl5/perlbrew/perls/5.16.2/lib/site_perl/5.16.2/strictures.pm line 15. > > perl -Mstrictures -e 'warn strictures->VERSION' > Invalid version format (version required) at /home/rabbit/perl5/perlbrew/perls/5.16.2/lib/site_perl/5.16.2/strictures.pm line 23.
I'm not sure what's going on here - the VERSION sub hasn't been changed in years. However, a quick check with older perl versions as well as older strictures shows the same issue, so it's possible this has been around for years as well. When this is sorted, we should add a unit test to ensure it doesn't reassert itself later.
Download (untitled) / with headers
text/plain 431b
On Wed Feb 12 10:41:02 2014, RIBASUSHI wrote: Show quoted text
> perl -Mstrictures\ 999 > Major version specified as 999 - this is strictures version 1 at > /home/rabbit/perl5/perlbrew/perls/5.16.2/lib/site_perl/5.16.2/strictures.pm > line 15. > > perl -Mstrictures -e 'warn strictures->VERSION' > Invalid version format (version required) at > /home/rabbit/perl5/perlbrew/perls/5.16.2/lib/site_perl/5.16.2/strictures.pm > line 23.
Fixed in repo.
This was fixed in 1.005003


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.