Skip Menu |
 

This queue is for tickets about the DBIx-Class CPAN distribution.

Report information
The Basics
Id: 92959
Status: rejected
Priority: 0/
Queue: DBIx-Class

People
Owner: Nobody in particular
Requestors: gamesh.g [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: DBIx::Class::Core::VERSION
Date: Wed, 12 Feb 2014 10:01:56 +0000
To: bug-DBIx-Class [...] rt.cpan.org
From: Gil Gamesh <gamesh.g [...] gmail.com>
Download (untitled) / with headers
text/plain 1.4k
Hi, My system: GNU/Linux i686 3.11.0-15-generic Kubuntu 13.10 My Perl: v5.16.2 using perlbrew After a recent cpanp update, when I start a Catalyst application I see this error: Couldn't instantiate component "ETSEA::Model::DB", "{UNKNOWN}: DBIx::Class::Core does not define $DBIx::Class::Core::VERSION--version check failed at /opt/perl5/perls/perl-5.16.2/lib/site_perl/5.16.2/Module/Runtime.pm line 386. Compilation failed in require at /opt/perl5/perls/perl-5.16.2/lib/site_perl/5.16.2/Class/C3/Componentised.pm line 150. at /opt/perl5/perls/perl-5.16.2/lib/site_perl/5.16.2/Class/C3/Componentised.pm line 155 Compilation failed in require at /opt/perl5/perls/perl-5.16.2/lib/site_perl/5.16.2/Catalyst/Restarter/Forking.pm line 20. The error goes away when I copy the following code from DBIx/Class.pm to DBIx/Class/Core.pm our $VERSION; # Always remember to do all digits for the version even if they're 0 # i.e. first release of 0.XX *must* be 0.XX000. This avoids fBSD ports # brain damage and presumably various other packaging systems too # $VERSION declaration must stay up here, ahead of any other package # declarations, as to not confuse various modules attempting to determine # this ones version, whether that be s.c.o. or Module::Metadata, etc $VERSION = '0.08270'; $VERSION = eval $VERSION if $VERSION =~ /_/; # numify for warning-free dev releases But maybe this is a bug in Module::Runtime rather than DBIx? If so I'll open a report there. Thanks.
Subject: Re: [rt.cpan.org #92959] AutoReply: DBIx::Class::Core::VERSION
Date: Wed, 12 Feb 2014 10:14:40 +0000
To: bug-DBIx-Class [...] rt.cpan.org
From: Gil Gamesh <gamesh.g [...] gmail.com>
Download (untitled) / with headers
text/plain 2.5k
Apologies. After running another cpanp update, I can no longer reproduce this bug. I guess it was some transient weirdness. Please reject and close. Thanks. On 12 February 2014 10:02, Bugs in DBIx-Class via RT < bug-DBIx-Class@rt.cpan.org> wrote: Show quoted text
> > Greetings, > > This message has been automatically generated in response to the > creation of a trouble ticket regarding: > "DBIx::Class::Core::VERSION", > a summary of which appears below. > > There is no need to reply to this message right now. Your ticket has been > assigned an ID of [rt.cpan.org #92959]. Your ticket is accessible > on the web at: > > https://rt.cpan.org/Ticket/Display.html?id=92959 > > Please include the string: > > [rt.cpan.org #92959] > > in the subject line of all future correspondence about this issue. To do > so, > you may reply to this message. > > Thank you, > bug-DBIx-Class@rt.cpan.org > > ------------------------------------------------------------------------- > Hi, > > My system: GNU/Linux i686 3.11.0-15-generic Kubuntu 13.10 > > My Perl: v5.16.2 using perlbrew > > > After a recent cpanp update, when I start a Catalyst application I see this > error: > > Couldn't instantiate component "ETSEA::Model::DB", "{UNKNOWN}: > DBIx::Class::Core does not define $DBIx::Class::Core::VERSION--version > check failed at > /opt/perl5/perls/perl-5.16.2/lib/site_perl/5.16.2/Module/Runtime.pm line > 386. > Compilation failed in require at > /opt/perl5/perls/perl-5.16.2/lib/site_perl/5.16.2/Class/C3/Componentised.pm > line 150. at > /opt/perl5/perls/perl-5.16.2/lib/site_perl/5.16.2/Class/C3/Componentised.pm > line 155 > Compilation failed in require at > > /opt/perl5/perls/perl-5.16.2/lib/site_perl/5.16.2/Catalyst/Restarter/Forking.pm > line 20. > > > The error goes away when I copy the following code from DBIx/Class.pm to > DBIx/Class/Core.pm > > our $VERSION; > # Always remember to do all digits for the version even if they're 0 > # i.e. first release of 0.XX *must* be 0.XX000. This avoids fBSD ports > # brain damage and presumably various other packaging systems too > > # $VERSION declaration must stay up here, ahead of any other package > # declarations, as to not confuse various modules attempting to determine > # this ones version, whether that be s.c.o. or Module::Metadata, etc > $VERSION = '0.08270'; > > $VERSION = eval $VERSION if $VERSION =~ /_/; # numify for warning-free dev > releases > > > But maybe this is a bug in Module::Runtime rather than DBIx? If so I'll > open a report there. > > Thanks. >
Download (untitled) / with headers
text/plain 133b
This bug was caused by a bug in MooseX::NonMoose which was exposed by an updated version of Module::Runtime, nothing to do with DBIC.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.