Skip Menu |
 

This queue is for tickets about the Fuse CPAN distribution.

Report information
The Basics
Id: 92865
Status: open
Priority: 0/
Queue: Fuse

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.16.1
Fixed in: (no value)



Subject: Fuse 0.16.1 not indexed
Download (untitled) / with headers
text/plain 212b
For some reason, DPATES/Fuse-0.16.1.tar.gz is not indexed by PAUSE the indexer, and does not appear in 02packages.details.txt. This means that CPAN.pm would peek only the older 0.16 version. Regards, Slaven
Download (untitled) / with headers
text/plain 547b
On Sun Feb 09 14:42:56 2014, SREZIC wrote: Show quoted text
> For some reason, DPATES/Fuse-0.16.1.tar.gz is not indexed by PAUSE the > indexer, and does not appear in 02packages.details.txt. This means > that CPAN.pm would peek only the older 0.16 version. > > Regards, > Slaven
Additionally, with the weirdness of Perl version numbering, 0.16.1 is lower than 0.16, so if indexed wouldn't appear as the most recent: 0.16.1 is 0.016001 0.16 is 0.160000 To keep correct version order, single and double decimal points shouldn't be mixed. thanks, Michael
Download (untitled) / with headers
text/plain 585b
0.16.1 is indexed alright, but as it was correctly pointed, the indexer thinks 0.16 is the latest one because 0.160000 > 0.016001. The fix is to make a new release updating $VERSION to either 0.17 (as the rest of the Fuse releases) or to 0.160.2 (to keep using double-dotted). For the author's convenience, I have provided two pull requests, one bumping $VERSION to 0.17 (https://github.com/dpavlin/perl-fuse/pull/22) and another bumping it to 0.160.2 (https://github.com/dpavlin/perl-fuse/pull/23). The author may pick whichever is preferred and discard the other. Hope this helps!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.