Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 92498
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: RSAVAGE [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Option to force install optional deps
Download (untitled) / with headers
text/plain 174b
The installdeps docs say "You will be prompted whether to install optional dependencies." I'd like a way to override the prompt, so I can run installdeps from a batch file.
Download (untitled) / with headers
text/plain 283b
On 2014-01-27 01:11:32, RSAVAGE wrote: Show quoted text
> The installdeps docs say "You will be prompted whether to install > optional dependencies." > > I'd like a way to override the prompt, so I can run installdeps from a > batch file.
I suspect you can achieve this with PERL_MB_USE_DEFAULT=1.
Subject: Re: [rt.cpan.org #92498] Option to force install optional deps
Date: Tue, 28 Jan 2014 01:50:07 +0100
To: bug-Module-Build [...] rt.cpan.org
From: Leon Timmermans <leont [...] cpan.org>
Download (untitled) / with headers
text/plain 622b
On Tue, Jan 28, 2014 at 1:25 AM, Karen Etheridge via RT < bug-Module-Build@rt.cpan.org> wrote: Show quoted text
> Queue: Module-Build > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=92498 > > > On 2014-01-27 01:11:32, RSAVAGE wrote:
> > The installdeps docs say "You will be prompted whether to install > > optional dependencies." > > > > I'd like a way to override the prompt, so I can run installdeps from a > > batch file.
> > > I suspect you can achieve this with PERL_MB_USE_DEFAULT=1. >
Actually, it reuses PERL_MM_USE_DEFAULT instead of reinventing a new environmental variable, but yeah that should work. Leon
Subject: Re: [rt.cpan.org #92498] Option to force install optional deps
Date: Tue, 28 Jan 2014 13:30:12 +1100
To: bug-Module-Build [...] rt.cpan.org
From: Ron Savage <ron [...] savage.net.au>
Download (untitled) / with headers
text/plain 824b
Hi All Interesting. Thanx. On 28/01/14 11:50, Leon Timmermans via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=92498 > > > On Tue, Jan 28, 2014 at 1:25 AM, Karen Etheridge via RT < > bug-Module-Build@rt.cpan.org> wrote: >
>> Queue: Module-Build >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=92498 > >> >> On 2014-01-27 01:11:32, RSAVAGE wrote:
>>> The installdeps docs say "You will be prompted whether to install >>> optional dependencies." >>> >>> I'd like a way to override the prompt, so I can run installdeps from a >>> batch file.
>> >> >> I suspect you can achieve this with PERL_MB_USE_DEFAULT=1. >>
> > Actually, it reuses PERL_MM_USE_DEFAULT instead of reinventing a new > environmental variable, but yeah that should work. > > Leon >
-- Ron Savage http://savage.net.au/


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.