Skip Menu |
 

This queue is for tickets about the Devel-SizeMe CPAN distribution.

Report information
The Basics
Id: 92348
Status: open
Priority: 0/
Queue: Devel-SizeMe

People
Owner: Nobody in particular
Requestors: jkeenan [...] cpan.org
Cc: jquelin [...] cpan.org
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.19
Fixed in: (no value)



Download (untitled) / with headers
text/plain 5.1k
For nearly a month I have been looking at RT #119295[1] in the Perl 5 bug queue. This ticket reports that a commit in the Perl 5 core's blead has caused failures in Devel-SizeMe. More recent CPAN testers reports[2] indicate that Devel-SizeMe is again building and testing successfully *on Linux*, but it has not been tested on other OSes. I requested smoke tests on other platforms in the hope of closing #119295. Tonight I had an opportunity, using 'perlbrew', to build Perl 5's blead on Darwin/x86_64 and to use 'cpan' to test Devel-SizeMe against blead. Unfortunately, I encountered failures in the 'make' portion of the build. ##### TIMB/Devel-SizeMe-0.19.tar.gz Has already been unwrapped into directory /Users/jkeenan/.cpan/build/Devel-SizeMe-0.19-W3XHgC TIMB/Devel-SizeMe-0.19.tar.gz Has already been prepared Running make for T/TI/TIMB/Devel-SizeMe-0.19.tar.gz Warning: Prerequisite 'Devel::Dwarn => 0' for 'T/TI/TIMB/Devel-SizeMe-0.19.tar.gz' seems not available according to the indices cp lib/Devel/SizeMe/Graph/static/jit.js blib/lib/Devel/SizeMe/Graph/static/jit.js cp lib/Devel/SizeMe/Graph/static/excanvas.js blib/lib/Devel/SizeMe/Graph/static/excanvas.js cp lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/README.md blib/lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/README.md cp lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap.min.css blib/lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap.min.css cp lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap.css blib/lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap.css cp lib/Devel/SizeMe/Graph/static/css/base.css blib/lib/Devel/SizeMe/Graph/static/css/base.css cp lib/Devel/SizeMe/Graph/static/bootstrap/img/glyphicons-halflings-white.png blib/lib/Devel/SizeMe/Graph/static/bootstrap/img/glyphicons-halflings-white.png cp lib/Devel/SizeMe.pm blib/lib/Devel/SizeMe.pm cp lib/Devel/SizeMe/Graph/static/css/Treemap.css blib/lib/Devel/SizeMe/Graph/static/css/Treemap.css cp lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/jquery.jsonview.js blib/lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/jquery.jsonview.js cp lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/index.html blib/lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/index.html cp lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/jsonview.jquery.json blib/lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/jsonview.jquery.json cp lib/Devel/SizeMe/Core.pm blib/lib/Devel/SizeMe/Core.pm cp lib/Devel/SizeMe/Graph/static/sprintf.js blib/lib/Devel/SizeMe/Graph/static/sprintf.js cp lib/Devel/SizeMe/Graph/static/jquery-1.8.1-min.js blib/lib/Devel/SizeMe/Graph/static/jquery-1.8.1-min.js cp lib/Devel/SizeMe/Graph.pm blib/lib/Devel/SizeMe/Graph.pm cp lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap-responsive.css blib/lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap-responsive.css cp lib/Devel/SizeMe/Graph/static/bootstrap/js/bootstrap.js blib/lib/Devel/SizeMe/Graph/static/bootstrap/js/bootstrap.js cp lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap-responsive.min.css blib/lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap-responsive.min.css cp lib/Devel/SizeMe/Graph/static/jit-yc.js blib/lib/Devel/SizeMe/Graph/static/jit-yc.js cp lib/Devel/SizeMe/Graph/static/bootstrap/js/bootstrap.min.js blib/lib/Devel/SizeMe/Graph/static/bootstrap/js/bootstrap.min.js cp lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/jquery.jsonview.css blib/lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/jquery.jsonview.css cp lib/Devel/SizeMe/Graph/static/bootstrap/img/glyphicons-halflings.png blib/lib/Devel/SizeMe/Graph/static/bootstrap/img/glyphicons-halflings.png cp lib/Devel/SizeMe/Graph/static/treemap.js blib/lib/Devel/SizeMe/Graph/static/treemap.js Running Mkbootstrap for Devel::SizeMe () chmod 644 SizeMe.bs /Users/jkeenan/perl5/perlbrew/perls/perl-blead/bin/perl5.19.9 /Users/jkeenan/perl5/perlbrew/perls/perl-blead/lib/5.19.9/ExtUtils/xsubpp -typemap /Users/jkeenan/perl5/perlbrew/perls/perl-blead/lib/5.19.9/ExtUtils/typemap -typemap typemap SizeMe.xs > SizeMe.xsc && mv SizeMe.xsc SizeMe.c cc -c -fno-common -DPERL_DARWIN -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -O3 -DVERSION=\"0.19\" -DXS_VERSION=\"0.19\" "-I/Users/jkeenan/perl5/perlbrew/perls/perl-blead/lib/5.19.9/darwin-2level/CORE" -DALIGN_BITS=3 SizeMe.c SizeMe.xs: In function ‘perl_size’: SizeMe.xs:2226: error: ‘PL_L1Posix_ptrs’ undeclared (first use in this function) SizeMe.xs:2226: error: (Each undeclared identifier is reported only once SizeMe.xs:2226: error: for each function it appears in.) make: *** [SizeMe.o] Error 1 TIMB/Devel-SizeMe-0.19.tar.gz /usr/bin/make -- NOT OK Failed during this command: TIMB/Devel-SizeMe-0.19.tar.gz : make NO ##### With the exception of the warning about Devel::Dwarn cited above, all of Devel-SizeMe's prerequisites were located, built and tested successfully. Since this was the first time I used the combination of 'perlbrew' on blead and 'cpan', I may have made a technical error. But assuming I did not, then this build failure is puzzling. Thank you very much. Jim Keenan [1] https://rt.perl.org/Ticket/Display.html?id=119295 [2] http://matrix.cpantesters.org/?dist=Devel-SizeMe
Subject: perl_V_blead.txt
Summary of my perl5 (revision 5 version 19 subversion 9) configuration: Snapshot of: 568d025de1c93424654d2796e7e1a59b8f4aeb58 Platform: osname=darwin, osvers=11.4.2, archname=darwin-2level uname='darwin macbook-pro.local 11.4.2 darwin kernel version 11.4.2: thu aug 23 16:25:48 pdt 2012; root:xnu-1699.32.7~1release_x86_64 x86_64 ' config_args='-de -Dprefix=/Users/jkeenan/perl5/perlbrew/perls/perl-blead -Dusedevel -Aeval:scriptdir=/Users/jkeenan/perl5/perlbrew/perls/perl-blead/bin' hint=recommended, useposix=true, d_sigaction=define useithreads=undef, usemultiplicity=undef use64bitint=define, use64bitall=define, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='cc', ccflags ='-fno-common -DPERL_DARWIN -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include', optimize='-O3', cppflags='-fno-common -DPERL_DARWIN -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include' ccversion='', gccversion='4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.1.00)', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='env MACOSX_DEPLOYMENT_TARGET=10.3 cc', ldflags =' -fstack-protector -L/usr/local/lib' libpth=/usr/local/lib /usr/lib libs=-ldbm -ldl -lm -lutil -lc perllibs=-ldl -lm -lutil -lc libc=, so=dylib, useshrplib=false, libperl=libperl.a gnulibc_version='' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=bundle, d_dlsymun=undef, ccdlflags=' ' cccdlflags=' ', lddlflags=' -bundle -undefined dynamic_lookup -L/usr/local/lib -fstack-protector' Characteristics of this binary (from libperl): Compile-time options: HAS_TIMES PERLIO_LAYERS PERL_DONT_CREATE_GVSV PERL_HASH_FUNC_ONE_AT_A_TIME_HARD PERL_MALLOC_WRAP PERL_NEW_COPY_ON_WRITE PERL_PRESERVE_IVUV PERL_USE_DEVEL USE_64_BIT_ALL USE_64_BIT_INT USE_LARGE_FILES USE_LOCALE USE_LOCALE_COLLATE USE_LOCALE_CTYPE USE_LOCALE_NUMERIC USE_PERLIO USE_PERL_ATOF Built under darwin Compiled at Jan 21 2014 12:55:45 %ENV: PERL5DIR="/Users/jkeenan/gitwork/perl" PERLBREW_BASHRC_VERSION="0.46" PERLBREW_HOME="/Users/jkeenan/.perlbrew" PERLBREW_MANPATH="/Users/jkeenan/perl5/perlbrew/perls/perl-blead/man" PERLBREW_PATH="/Users/jkeenan/perl5/perlbrew/bin:/Users/jkeenan/perl5/perlbrew/perls/perl-blead/bin" PERLBREW_PERL="perl-blead" PERLBREW_ROOT="/Users/jkeenan/perl5/perlbrew" PERLBREW_VERSION="0.46" @INC: /Users/jkeenan/perl5/perlbrew/perls/perl-blead/lib/site_perl/5.19.9/darwin-2level /Users/jkeenan/perl5/perlbrew/perls/perl-blead/lib/site_perl/5.19.9 /Users/jkeenan/perl5/perlbrew/perls/perl-blead/lib/5.19.9/darwin-2level /Users/jkeenan/perl5/perlbrew/perls/perl-blead/lib/5.19.9 .
Download (untitled) / with headers
text/plain 241b
Devel::SizeMe is so intimate with the perl core that I would expect it to break on bleadperl changes fairly often. Devel::SizeMe breaking shouldn't be a blocker for a perl release. It may be a few weeks before I get to working on this again.
Download (untitled) / with headers
text/plain 5.9k
On Tue Jan 21 22:01:03 2014, JKEENAN wrote: Show quoted text
> For nearly a month I have been looking at RT #119295[1] in the Perl 5 > bug queue. This ticket reports that a commit in the Perl 5 core's > blead has caused failures in Devel-SizeMe. More recent CPAN testers > reports[2] indicate that Devel-SizeMe is again building and testing > successfully *on Linux*, but it has not been tested on other OSes. I > requested smoke tests on other platforms in the hope of closing > #119295. > > Tonight I had an opportunity, using 'perlbrew', to build Perl 5's > blead on Darwin/x86_64 and to use 'cpan' to test Devel-SizeMe against > blead. Unfortunately, I encountered failures in the 'make' portion of > the build. > > ##### > TIMB/Devel-SizeMe-0.19.tar.gz > Has already been unwrapped into directory > /Users/jkeenan/.cpan/build/Devel-SizeMe-0.19-W3XHgC > TIMB/Devel-SizeMe-0.19.tar.gz > Has already been prepared > Running make for T/TI/TIMB/Devel-SizeMe-0.19.tar.gz > Warning: Prerequisite 'Devel::Dwarn => 0' for 'T/TI/TIMB/Devel-SizeMe- > 0.19.tar.gz' seems not available according to the indices > cp lib/Devel/SizeMe/Graph/static/jit.js > blib/lib/Devel/SizeMe/Graph/static/jit.js > cp lib/Devel/SizeMe/Graph/static/excanvas.js > blib/lib/Devel/SizeMe/Graph/static/excanvas.js > cp lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/README.md > blib/lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/README.md > cp lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap.min.css > blib/lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap.min.css > cp lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap.css > blib/lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap.css > cp lib/Devel/SizeMe/Graph/static/css/base.css > blib/lib/Devel/SizeMe/Graph/static/css/base.css > cp lib/Devel/SizeMe/Graph/static/bootstrap/img/glyphicons-halflings- > white.png blib/lib/Devel/SizeMe/Graph/static/bootstrap/img/glyphicons- > halflings-white.png > cp lib/Devel/SizeMe.pm blib/lib/Devel/SizeMe.pm > cp lib/Devel/SizeMe/Graph/static/css/Treemap.css > blib/lib/Devel/SizeMe/Graph/static/css/Treemap.css > cp lib/Devel/SizeMe/Graph/static/yesmeck-jquery- > jsonview/jquery.jsonview.js > blib/lib/Devel/SizeMe/Graph/static/yesmeck-jquery- > jsonview/jquery.jsonview.js > cp lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/index.html > blib/lib/Devel/SizeMe/Graph/static/yesmeck-jquery-jsonview/index.html > cp lib/Devel/SizeMe/Graph/static/yesmeck-jquery- > jsonview/jsonview.jquery.json > blib/lib/Devel/SizeMe/Graph/static/yesmeck-jquery- > jsonview/jsonview.jquery.json > cp lib/Devel/SizeMe/Core.pm blib/lib/Devel/SizeMe/Core.pm > cp lib/Devel/SizeMe/Graph/static/sprintf.js > blib/lib/Devel/SizeMe/Graph/static/sprintf.js > cp lib/Devel/SizeMe/Graph/static/jquery-1.8.1-min.js > blib/lib/Devel/SizeMe/Graph/static/jquery-1.8.1-min.js > cp lib/Devel/SizeMe/Graph.pm blib/lib/Devel/SizeMe/Graph.pm > cp lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap- > responsive.css > blib/lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap- > responsive.css > cp lib/Devel/SizeMe/Graph/static/bootstrap/js/bootstrap.js > blib/lib/Devel/SizeMe/Graph/static/bootstrap/js/bootstrap.js > cp lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap- > responsive.min.css > blib/lib/Devel/SizeMe/Graph/static/bootstrap/css/bootstrap- > responsive.min.css > cp lib/Devel/SizeMe/Graph/static/jit-yc.js > blib/lib/Devel/SizeMe/Graph/static/jit-yc.js > cp lib/Devel/SizeMe/Graph/static/bootstrap/js/bootstrap.min.js > blib/lib/Devel/SizeMe/Graph/static/bootstrap/js/bootstrap.min.js > cp lib/Devel/SizeMe/Graph/static/yesmeck-jquery- > jsonview/jquery.jsonview.css > blib/lib/Devel/SizeMe/Graph/static/yesmeck-jquery- > jsonview/jquery.jsonview.css > cp lib/Devel/SizeMe/Graph/static/bootstrap/img/glyphicons- > halflings.png > blib/lib/Devel/SizeMe/Graph/static/bootstrap/img/glyphicons- > halflings.png > cp lib/Devel/SizeMe/Graph/static/treemap.js > blib/lib/Devel/SizeMe/Graph/static/treemap.js > Running Mkbootstrap for Devel::SizeMe () > chmod 644 SizeMe.bs > /Users/jkeenan/perl5/perlbrew/perls/perl-blead/bin/perl5.19.9 > /Users/jkeenan/perl5/perlbrew/perls/perl- > blead/lib/5.19.9/ExtUtils/xsubpp -typemap > /Users/jkeenan/perl5/perlbrew/perls/perl- > blead/lib/5.19.9/ExtUtils/typemap -typemap typemap SizeMe.xs > > SizeMe.xsc && mv SizeMe.xsc SizeMe.c > cc -c -fno-common -DPERL_DARWIN -fno-strict-aliasing -pipe -fstack- > protector -I/usr/local/include -O3 -DVERSION=\"0.19\" > -DXS_VERSION=\"0.19\" "-I/Users/jkeenan/perl5/perlbrew/perls/perl- > blead/lib/5.19.9/darwin-2level/CORE" -DALIGN_BITS=3 SizeMe.c > SizeMe.xs: In function ‘perl_size’: > SizeMe.xs:2226: error: ‘PL_L1Posix_ptrs’ undeclared (first use in this > function) > SizeMe.xs:2226: error: (Each undeclared identifier is reported only > once > SizeMe.xs:2226: error: for each function it appears in.) > make: *** [SizeMe.o] Error 1 > TIMB/Devel-SizeMe-0.19.tar.gz > /usr/bin/make -- NOT OK > Failed during this command: > TIMB/Devel-SizeMe-0.19.tar.gz : make NO > ##### >
Similar error output on Linux x86_64 (dromedary) today at blead: ##### Running Mkbootstrap for Devel::SizeMe () chmod 644 SizeMe.bs /home/jkeenan/testing/blead/bin/perl /home/jkeenan/testing/blead/lib/perl5/5.21.1/ExtUtils/xsubpp -typemap /home/jkeenan/testing/blead/lib/perl5/5.21.1/ExtUtils/typemap -typemap typemap SizeMe.xs > SizeMe.xsc && mv SizeMe.xsc SizeMe.c cc -c -fwrapv -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -DVERSION=\"0.19\" -DXS_VERSION=\"0.19\" -fPIC "-I/home/jkeenan/testing/blead/lib/perl5/5.21.1/x86_64-linux/CORE" -DALIGN_BITS=3 SizeMe.c SizeMe.xs: In function ‘perl_size’: SizeMe.xs:2226: error: ‘PL_L1Posix_ptrs’ undeclared (first use in this function) SizeMe.xs:2226: error: (Each undeclared identifier is reported only once SizeMe.xs:2226: error: for each function it appears in.) make: *** [SizeMe.o] Error 1 ##### $ ./perl -v This is perl 5, version 21, subversion 1 (v5.21.1 (v5.21.0-258-g43e5477)) built for x86_64-linux
Subject: [rt.cpan.org #92348]
Date: Sat, 28 Jun 2014 18:51:05 -0500
To: bug-Devel-SizeMe [...] rt.cpan.org
From: Samuel Smith <leon36 [...] gmail.com>
Download (untitled) / with headers
text/plain 529b
According to this: http://perl5.git.perl.org/perl.git/commit/462590f101305c4cba63e871bebe6253548df840 The 'PL_L1Posix_ptrs' structure has been removed. If you comment out the offending line #2,226 in SizeMe.xs , you will be able to successfully compile and install Devel::SizeMe on the latest perl (5.20) on Linux. I cannot vouch for how this will effect accuracy, but from my tests using Devel::SizeMe on 5.20, the numbers were nearly the same as 5.18 (where is could compile and install without patching). Samuel Smith
Download (untitled) / with headers
text/plain 1.6k
On Sat Jun 28 19:51:23 2014, leon36@gmail.com wrote: Show quoted text
> According to this: > http://perl5.git.perl.org/perl.git/commit/462590f101305c4cba63e871bebe6253548df840 > > The 'PL_L1Posix_ptrs' structure has been removed. If you comment out > the > offending line #2,226 in SizeMe.xs , you will be able to successfully > compile and install Devel::SizeMe on the latest perl (5.20) on Linux. > > I cannot vouch for how this will effect accuracy, but from my tests > using Devel::SizeMe on 5.20, the numbers were nearly the same as 5.18 > (where is could compile and install without patching). > > Samuel Smith
I commented out line 2226 in SizeMe.xs and ran 'make' successfully. However, 3 tests in 'make test' failed with output like this: ##### $ prove -vb t/00-load.t t/00-load.t .. Can't load '/home/jkeenan/.cpanm/work/1404000473.4599/Devel-SizeMe-0.19/blib/arch/auto/Devel/SizeMe/SizeMe.so' for module Devel::SizeMe: /home/jkeenan/.cpanm/work/1404000473.4599/Devel-SizeMe-0.19/blib/arch/auto/Devel/SizeMe/SizeMe.so: undefined symbol: PL_body_roots at /usr/lib/perl/5.18/DynaLoader.pm line 184. at /home/jkeenan/.cpanm/work/1404000473.4599/Devel-SizeMe-0.19/blib/lib/Devel/SizeMe/Core.pm line 12. Compilation failed in require at /home/jkeenan/.cpanm/work/1404000473.4599/Devel-SizeMe-0.19/blib/lib/Devel/SizeMe.pm line 28. Compilation failed in require at t/00-load.t line 6. BEGIN failed--compilation aborted at t/00-load.t line 6. ##### I don't know what 'PL_body_roots' is, other than that 'ack' points here: ##### $ ack PL_body_roots . SizeMe.xs 2297: for (next = &PL_body_roots[sv_type]; *next; next = *next) { ##### Thank you very much. Jim Keenan
Download (untitled) / with headers
text/plain 2.1k
On Sat Jun 28 20:19:14 2014, JKEENAN wrote: Show quoted text
> On Sat Jun 28 19:51:23 2014, leon36@gmail.com wrote:
> > According to this: > > http://perl5.git.perl.org/perl.git/commit/462590f101305c4cba63e871bebe6253548df840 > > > > The 'PL_L1Posix_ptrs' structure has been removed. If you comment out > > the > > offending line #2,226 in SizeMe.xs , you will be able to successfully > > compile and install Devel::SizeMe on the latest perl (5.20) on Linux. > > > > I cannot vouch for how this will effect accuracy, but from my tests > > using Devel::SizeMe on 5.20, the numbers were nearly the same as 5.18 > > (where is could compile and install without patching). > > > > Samuel Smith
> > I commented out line 2226 in SizeMe.xs and ran 'make' successfully. > However, 3 tests in 'make test' failed with output like this: > > ##### > $ prove -vb t/00-load.t > t/00-load.t .. Can't load > '/home/jkeenan/.cpanm/work/1404000473.4599/Devel-SizeMe- > 0.19/blib/arch/auto/Devel/SizeMe/SizeMe.so' for module Devel::SizeMe: > /home/jkeenan/.cpanm/work/1404000473.4599/Devel-SizeMe- > 0.19/blib/arch/auto/Devel/SizeMe/SizeMe.so: undefined symbol: > PL_body_roots at /usr/lib/perl/5.18/DynaLoader.pm line 184. > at /home/jkeenan/.cpanm/work/1404000473.4599/Devel-SizeMe- > 0.19/blib/lib/Devel/SizeMe/Core.pm line 12. > Compilation failed in require at > /home/jkeenan/.cpanm/work/1404000473.4599/Devel-SizeMe- > 0.19/blib/lib/Devel/SizeMe.pm line 28. > Compilation failed in require at t/00-load.t line 6. > BEGIN failed--compilation aborted at t/00-load.t line 6. > > ##### > > I don't know what 'PL_body_roots' is, other than that 'ack' points > here: > > ##### > > $ ack PL_body_roots . > SizeMe.xs > 2297: for (next = &PL_body_roots[sv_type]; *next; next = *next) > { > > ##### > > Thank you very much. > Jim Keenan
Tim Bunce: I see that Devel::SizeMe is still failing its tests against Perl 5 blead: http://matrix.cpantesters.org/?author=TIMB#Devel-SizeMe-0.19 ... which means that https://rt.perl.org/Ticket/Display.html?id=119295 is still open as well. Is there some way someone could contribute to investigating and resolving this problem? Thank you very much.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.