Skip Menu |
 

This queue is for tickets about the AnyEvent-Subprocess CPAN distribution.

Report information
The Basics
Id: 92227
Status: open
Priority: 0/
Queue: AnyEvent-Subprocess

People
Owner: Nobody in particular
Requestors: smakki [...] hedera-technology.com
cpan [...] zoffix.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Moose compatibility
Date: Fri, 17 Jan 2014 12:39:13 +0100 (CET)
To: bug-AnyEvent-Subprocess [...] rt.cpan.org
From: Sami Makki <smakki [...] hedera-technology.com>
Download (untitled) / with headers
text/plain 460b
Hello, I'm using the AnyEvent:::Subprocess with Moose, and since this evolution (https://metacpan.org/pod/release/ETHER/Moose-2.1106-TRIAL/lib/Moose/Manual/Delta.pod#The-non-arrayref-forms-of-enum-and-duck_type-have-been-deprecated),an alert is generated from Types.pm (line 42). "Passing a list of values to enum is deprecated. Enum values should be wrapped in an arrayref." The quickest fix is to add squared brackets,as suggested. Regards, Sami Makki


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.