Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CPAN-Reporter CPAN distribution.

Report information
The Basics
Id: 92223
Status: resolved
Priority: 0/
Queue: CPAN-Reporter

People
Owner: Nobody in particular
Requestors: pause [...] tlinx.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: CR doesn't work with CR::TransMetabase..
Download (untitled) / with headers
text/plain 8.4k
(note this works on my linux machine, BUT, am on cygwin, and there is a 'hole' in the testing. I can install CPAN::Reporter::Transport::Metabase and it tests and installs w/no probs. I can also run a test/install of CR:TM, but... when I run CPAN and CR:TM tries to actually *use* CRTM -- it can't. It fails to load. CR: Show quoted text
> test Test::Reporter
Running test for module 'Test::Reporter' Running make for D/DA/DAGOLDEN/Test-Reporter-1.60.tar.gz CPAN.pm: Building D/DA/DAGOLDEN/Test-Reporter-1.60.tar.gz CPAN::Reporter: error loading Test::Reporter::Transport::Metabase. Please install the missing module or choose a different transport mechanism. Checking if your kit is complete... Looks good Generating a Unix-style Makefile Writing Makefile for Test::Reporter Writing MYMETA.yml and MYMETA.json (/usr/bin/perl Makefile.PL exited with 0) CPAN::Reporter: Makefile.PL result is 'pass', No errors. CPAN::Reporter: error loading Test::Reporter::Transport::Metabase. Please install the missing module or choose a different transport mechanism. ---- and CR:TM: cpan[11]> install Test::Reporter::Transport::Metabase Test::Reporter::Transport::Metabase is up to date (1.999008). cpan[12]> test Test::Reporter::Transport::Metabase Running test for module 'Test::Reporter::Transport::Metabase' Running make for D/DA/DAGOLDEN/Test-Reporter-Transport-Metabase-1.999008.tar.gz Has already been unwrapped into directory /var/cache/CPAN/build/Test-Reporter-Transport-Metabase-1.999008-LNmhRa Has already been made Running make test Has already been tested successfully cpan[13]> look Test::Reporter Running look for module 'Test::Reporter' Trying to open a subshell in the build directory... Working directory is /var/cache/CPAN/build/Test-Reporter-1.60-gmmDl0 User Bliss\law's .bashrc called 2nd time /var/../build/Test-Reporter-1.60-gmmDl0> make clean rm -f \ Reporter.bso Reporter.def \ Reporter.exp Reporter.x \ blib/arch/auto/Test/Reporter/extralibs.all \ blib/arch/auto/Test/Reporter/extralibs.ld Makefile.aperl \ *.a *.o \ *perl.core MYMETA.json \ MYMETA.yml blibdirs.ts \ core core.*perl.*.? \ core.[0-9] core.[0-9][0-9] \ core.[0-9][0-9][0-9] core.[0-9][0-9][0-9][0-9] \ core.[0-9][0-9][0-9][0-9][0-9] libReporter.def \ mon.out perl \ perl.exe perl.exe \ perlmain.c pm_to_blib \ pm_to_blib.ts so_locations \ tmon.out rm -rf \ blib mv Makefile Makefile.old > /dev/null 2>&1 /var/../build/Test-Reporter-1.60-gmmDl0> perl Makefile.PL Checking if your kit is complete... Looks good Generating a Unix-style Makefile Writing Makefile for Test::Reporter Writing MYMETA.yml and MYMETA.json /var/../build/Test-Reporter-1.60-gmmDl0> make cp lib/Test/Reporter/Transport/Null.pm blib/lib/Test/Reporter/Transport/Null.pm cp lib/Test/Reporter.pm blib/lib/Test/Reporter.pm cp lib/Test/Reporter/Transport/File.pm blib/lib/Test/Reporter/Transport/File.pm cp lib/Test/Reporter/Transport.pm blib/lib/Test/Reporter/Transport.pm Manifying blib/man3/Test.Reporter.3pm Manifying blib/man3/Test.Reporter.Transport.3pm Manifying blib/man3/Test.Reporter.Transport.File.3pm Manifying blib/man3/Test.Reporter.Transport.Null.3pm /var/../build/Test-Reporter-1.60-gmmDl0> make test PERL_DL_NONLAZY=1 /usr/bin/perl.exe "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/00-report-prereqs.t .. 1/1 # # Versions for all modules listed in MYMETA.json (including optional ones): # Version Module # -------- ------------------------ # 2.133380 CPAN::Meta # 2.125 CPAN::Meta::Requirements # 1.32 Carp # 3.36 Cwd # 2.130_02 Data::Dumper # 6.86 ExtUtils::MakeMaker # 1.19 File::Find # 3.33 File::Spec::Functions # 0.2304 File::Temp # 2.02 FileHandle # 1.35 List::Util # 2.13 Mail::Send # 0.73 Net::DNS # 2.20 Net::Domain # 2.31 Net::SMTP # 1.16 Sys::Hostname # 1.001002 Test::More # 1.2300 Time::Local # 2.18 base # 1.27 constant # 1.04 strict # 1.02 vars # 1.12 warnings t/00-report-prereqs.t .. ok t/1-reporter.t ......... ok t/3-file-transport.t ... ok t/6-write-read-crlf.t .. ok t/rt-89404.t ........... ok All tests successful. Files=5, Tests=140, 3 wallclock secs ( 0.02 usr 0.06 sys + 0.59 cusr 1.73 csys = 2.40 CPU) Result: PASS ---- When CR was 'installed -- I'd already been through both -- i.e. CR::TM had already been 'TESTED', PASSED, but Test::Reporter can't make use of it. Seems like there is a hole in testing -- as I don't know how I would run a test to see if TR **really** works with the suggested Transport mechanism. FWIW -- I am behind a proxy -- which works for CPAN, but am unclear about CPAN-Reporter -- LWP seems to work reading the env vars -- but realistically, CR should read the vars used by CPAN (from the 'MyConfig.pl file)... Both are set, but still don't know if that works, as I can't get the Transport::Metabase to even "load" (even though it does pass it's tests... ) FWIW, I tried tying in a "use of metabase" in the routine where it normally does a "require"...i.e.: line 186: (blank) line 187 (and following): sub transport { use Test::Reporter::Transport::Metabase; <<<< my $self = shift; warn __PACKAGE__, ": transport\n" if $self->debug(); return $self->{_transport} unless scalar @_; my $transport = shift; my $transport_class = "Test::Reporter::Transport::$transport"; unless ( eval "require $transport_class;" ) { ## no critic croak __PACKAGE__ . ": could not load '$transport_class'\n$@\n"; } ---- Doing the above didn't create a compile time error as would be suggested by the message. Tried to build 'P' -- which passes, but...: (love the message at the end -- after getting the traceback & fatal send error): t/P.env .. ok All tests successful. Files=1, Tests=29, 1 wallclock secs ( 0.03 usr 0.01 sys + 0.29 cusr 0.66 csys = 0.99 CPU) Result: PASS (make.exe test exited with 0) CPAN::Reporter: Test result is 'pass', All tests successful. CPAN::Reporter: preparing a CPAN Testers report for P-1.1.24 CPAN::Reporter: sending test report with 'pass' via Metabase CPAN::Reporter: Test::Reporter: error from 'Test::Reporter::Transport::Metabase:' fact submission failed: Can't connect to web_proxy:8118 (Bad hostname) at /usr/lib/perl5/site_perl/5.14/Metabase/Client/Simple.pm line 100. Metabase::Client::Simple::submit_fact(Metabase::Client::Simple=HASH(0x60b12f6f0), CPAN::Testers::Report=HASH(0x60b1ac6d0)) called at /usr/lib/perl5/site_perl/5.14/Test/Reporter/Transport/Metabase.pm line 132 Test::Reporter::Transport::Metabase::send(Test::Reporter::Transport::Metabase=HASH(0x60adb26a0), Test::Reporter=HASH(0x60afe09e0)) called at /usr/lib/perl5/site_perl/5.14/Test/Reporter.pm line 272 eval {...} called at /usr/lib/perl5/site_perl/5.14/Test/Reporter.pm line 272 Test::Reporter::send(Test::Reporter=HASH(0x60afe09e0)) called at /usr/lib/perl5/site_perl/5.14/CPAN/Reporter.pm line 492 CPAN::Reporter::_dispatch_report(HASH(0x60afe64b8)) called at /usr/lib/perl5/site_perl/5.14/CPAN/Reporter.pm line 104 CPAN::Reporter::grade_test(CPAN::Distribution=HASH(0x60a8dcce8), "make.exe test", ARRAY(0x60ad039e0), 0) called at /usr/lib/perl5/site_perl/5.14/CPAN/Reporter.pm line 199 CPAN::Reporter::test(CPAN::Distribution=HASH(0x60a8dcce8), "make.exe test") called at /usr/lib/perl5/5.14/CPAN/Distribution.pm line 3258 CPAN::Distribution::test(CPAN::Distribution=HASH(0x60a8dcce8)) called at /usr/lib/perl5/5.14/CPAN/Module.pm line 479 eval {...} called at /usr/lib/perl5/5.14/CPAN/Module.pm line 478 CPAN::Module::rematein(CPAN::Module=HASH(0x60859fbf0), "test") called at /usr/lib/perl5/5.14/CPAN/Module.pm line 508 CPAN::Module::test(CPAN::Module=HASH(0x60859fbf0)) called at /usr/lib/perl5/5.14/CPAN/Shell.pm line 1797 CPAN::Shell::rematein("CPAN::Shell", "test", "P") called at /usr/lib/perl5/5.14/CPAN/Shell.pm line 1977 CPAN::Shell::__ANON__("CPAN::Shell", "P") called at /usr/lib/perl5/5.14/CPAN.pm line 376 eval {...} called at /usr/lib/perl5/5.14/CPAN.pm line 373 CPAN::shell() called at /usr/lib/perl5/5.14/App/Cpan.pm line 338 App::Cpan::_process_options("App::Cpan") called at /usr/lib/perl5/5.14/App/Cpan.pm line 421 App::Cpan::run("App::Cpan") called at /bin/cpan line 12 LAWALSH/P-1.1.24.tar.gz make.exe test -- OK So maybe it's not that it can't load transMeta, but that transmeta doesn't work w/CPAN's configured proxies?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.