This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
92161
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
CHORNY [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
2.00
Fixed in:
2.05



Subject: dependency not installed
perl 5.18.1, so version of ExtUtils::MakeMaker is lower than required. MYMETA.json for local::lib has "prereqs" : { "build" : { "requires" : { "ExtUtils::MakeMaker" : "0" } }, "runtime" : { "requires" : { "CPAN" : "1.82", "ExtUtils::Install" : "1.43", "ExtUtils::MakeMaker" : "6.74", "Module::Build" : "0.36" } }, "test" : { "requires" : { "Test::More" : "0" } } }, ExtUtils::MakeMaker is not installed. I tried removing "ExtUtils::MakeMaker" : "0" from build/requires in MYMETA.json, same result. If I add version 6.74 to build/requires, ExtUtils::MakeMaker will be installed. -- Alexandr Ciornii, http://chorny.net
Subject: Re: [rt.cpan.org #92161] dependency not installed
Date: Wed, 15 Jan 2014 08:42:59 -0500
To: bug-CPAN <bug-CPAN@rt.cpan.org>
From: David Golden <dagolden@cpan.org>
That's the known bug where build_requires overrides requires because prereqs aren't properly merged. It should be fixed in the dev release. David
Thanks everybody, resolving, finally...


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.