Skip Menu |
 

This queue is for tickets about the HTTP-Server-Simple CPAN distribution.

Report information
The Basics
Id: 92120
Status: resolved
Priority: 0/
Queue: HTTP-Server-Simple

People
Owner: Nobody in particular
Requestors: warren [...] etr-usa.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Remove dependency on Env.pm in t/04cgi.t
Date: Mon, 13 Jan 2014 18:29:16 -0700
To: bug-HTTP-Server-Simple [...] rt.cpan.org
From: Warren Young <warren [...] etr-usa.com>
Download (untitled) / with headers
text/plain 597b
This test currently uses the non-core module Env.pm, which isn't listed as a dependency of HTTP::Server::Simple. This causes cpanm to fail to install HTTP::Server::Simple on a minimal install of RHEL7 beta. As far as I can tell, the test doesn't actually make use of Env, it just says "use Env". The only environment variable used is referenced as $ENV{$file}, which works on all Perls without the "use Env". HTTP::Server::Simple::PSGI is a subclass of your ::CGI module, and its author claims it doesn't uses any non-core modules. Because of this "use Env", that's currently not true.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.