Skip Menu |
 

This queue is for tickets about the WWW-TMDB-API CPAN distribution.

Report information
The Basics
Id: 91816
Status: new
Priority: 0/
Queue: WWW-TMDB-API

People
Owner: Nobody in particular
Requestors: donald_benton [...] hotmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Movie Search in API v3 has stopped working
Date: Thu, 2 Jan 2014 19:11:11 +0000
To: bug-WWW-TMDB-API [...] rt.cpan.org
From: Donald Benton <donald_benton [...] hotmail.com>
I have been using WWW::TMDB::API successfully to search movies for several months, but it seems to have stopped working in the last week or two. This appears to be a slight change in the API, but I haven't found it mentioned on the TMDB. After setting the API key appropriately, and initializing the API, I use a line like: $tmdb->get_api->movie->search(query=>"The Philadelphia Story"); This returns an error: 404 Not Found returned by http://api.themoviedb.org/3/search/movies?query=The+Philadelphia+Story&api_key=... at /usr/local/share/perl/5.10.1/WWW/TMDB/API/Movie.pm line 17. The URL entered in a browser returns: {"status_code":6,"status_message":"Invalid id - The pre-requisite id is invalid or not found"} Replacing the URL with http://api.themoviedb.org/3/search/movie?query=The+Philadelphia+Story&api_key=... (i.e., replacing "movies" with "movie") returns the expected result. Replacing line 17 of Movie.pm with $self->{api}->send_api( [ 'search', 'movie' ], seems to work. Regards, Donald Benton


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.