Skip Menu |
 

This queue is for tickets about the Net-SSLeay CPAN distribution.

Report information
The Basics
Id: 91737
Status: resolved
Priority: 0/
Queue: Net-SSLeay

People
Owner: MIKEM [...] cpan.org
Requestors: KENTNL [...] cpan.org
rurban [...] x-ray.at
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.56
Fixed in: (no value)



Subject: License 'SSLeay' is invalid (license) [Validation: 1.4]
Download (untitled) / with headers
text/plain 977b
3 trivial kwalitee issues: The 'SSLeay' string is an invalid license according to http://search.cpan.org/dist/CPAN-Meta/lib/CPAN/Meta/Spec.pm#license It fails the t/local/kwalitee.t test It needs to be changed to lowercase 'ssleay' # known; License 'SSLeay' is invalid (license) [Validation: 1.4] # known # License 'SSLeay' is invalid (license) [Validation: 1.4] # Remedy: Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-current.html and change your META.yml accordingly. # Error: This distribution does not have a license defined in the documentation or in a file called LICENSE # Details: # Neither LICENSE file nor LICENSE section in pod was found. # Remedy: Add a section called "LICENSE" to the documentation, or add a file named LICENSE to the distribution. # LICENSE section was not found in the pod. # Remedy: Add =head1 LICENSE and the text of the license to the main module in your code. # Looks like you failed 3 tests of 14.
Subject: Re: [rt.cpan.org #91737] License 'SSLeay' is invalid (license) [Validation: 1.4]
Date: Tue, 31 Dec 2013 05:54:02 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 1.7k
Hello. These issues are already fixed in SVN. Cheers. On Monday, December 30, 2013 12:05:21 PM you wrote: Show quoted text
> Mon Dec 30 12:05:20 2013: Request 91737 was acted upon. > Transaction: Ticket created by rurban@x-ray.at > Queue: Net-SSLeay > Subject: License 'SSLeay' is invalid (license) [Validation: 1.4] > Broken in: (no value) > Severity: Normal > Owner: Nobody > Requestors: rurban@x-ray.at > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=91737 > > > > 3 trivial kwalitee issues: > > The 'SSLeay' string is an invalid license according to > http://search.cpan.org/dist/CPAN-Meta/lib/CPAN/Meta/Spec.pm#license It > fails the t/local/kwalitee.t test > > It needs to be changed to lowercase 'ssleay' > > # known; License 'SSLeay' is invalid (license) [Validation: 1.4] > # known > # License 'SSLeay' is invalid (license) [Validation: 1.4] > # Remedy: Take a look at the META.yml Spec at > http://module-build.sourceforge.net/META-spec-current.html and change your > META.yml accordingly. > > # Error: This distribution does not have a license defined in the > documentation or in a file called LICENSE # Details: > # Neither LICENSE file nor LICENSE section in pod was found. > # Remedy: Add a section called "LICENSE" to the documentation, or add a file > named LICENSE to the distribution. > > # LICENSE section was not found in the pod. > # Remedy: Add =head1 LICENSE and the text of the license to the main module > in your code. # Looks like you failed 3 tests of 14.
-- Mike McCauley VK4AMM mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474 Fax +61 7 5598-7070

This is still unfortunately broken in 1.56

And considering its an author/develop side test, it really aught to be excluded from installtime testing.
 

Because documentation and packaging issues are not something that should block install.

__[ 1.56 output ]__

These tests should not be running unless AUTHOR_TESTING=1 and/or RELEASE_TESTING=1!
t/local/35_ephemeral.t ................. ok

#   Failed test 'metayml_conforms_to_known_spec'
#   at t/local/kwalitee.t line 7.
# Error: META.yml does not conform to any recognised META.yml Spec.
# Details:
# known; License 'openssl' is invalid (license) [Validation: 1.4]
# known
# License 'openssl' is invalid (license) [Validation: 1.4]
# Remedy: Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-current.html and change your META.yml accordingly.
t/local/31_rsa_generate_key.t .......... ok

#   Failed test 'has_license_in_source_file'
#   at t/local/kwalitee.t line 7.
# Error: Does not have license information in any of its source files
# Details:
# LICENSE section was not found in the pod.
# Remedy: Add =head1 LICENSE and the text of the license to the main module in your code.
# Looks like you failed 2 tests of 14.
t/local/kwalitee.t .....................
 



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.