Skip Menu |
 

This queue is for tickets about the Glib CPAN distribution.

Report information
The Basics
Id: 91679
Status: resolved
Priority: 0/
Queue: Glib

People
Owner: XAOC [...] cpan.org
Requestors: jasongross9+glibbugs [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.303
Fixed in: 1.304



Subject: installation of glib from cpan is broken in 1.303
Download (untitled) / with headers
text/plain 2.4k
When I try to install glib 1.303 using cpanm, I get https://travis-ci.org/JasonGross/barnowl/jobs/15991398: Configuring Glib-1.303 Running Makefile.PL Including generated API documentation... *** *** configuring Glib to build without thread safety *** Checking if your kit is complete... Looks good Generating a Unix-style Makefile Writing Makefile for Glib Writing MYMETA.yml and MYMETA.json -> OK Checking dependencies from MYMETA.json ... Checking if you have ExtUtils::Makaker 0 ... Yes (6.82) Checking if you have ExtUtils::Depends 0.300 ... Yes (0.306) Checking if you have ExtUtils::PkgConfig 1.000 ... Yes (1.15) Building and testing Glib-1.303 cp lib/Glib/GenPod.pm blib/lib/Glib/GenPod.pm cp build/IFiles.pm blib/arch/Glib/Install/Files.pm cp lib/Glib.pm blib/lib/Glib.pm cp gperl.h blib/arch/Glib/Install/gperl.h cp lib/Glib/Object/Subclass.pm blib/lib/Glib/Object/Subclass.pm cp devel.pod blib/lib/Glib/devel.pod cp gperl_marshal.h blib/arch/Glib/Install/gperl_marshal.h cp lib/Glib/ParseXSDoc.pm blib/lib/Glib/ParseXSDoc.pm cp lib/Glib/MakeHelper.pm blib/lib/Glib/MakeHelper.pm cp lib/Glib/CodeGen.pm blib/lib/Glib/CodeGen.pm cp doctypes blib/arch/Glib/Install/doctypes cp /home/travis/.cpanm/work/1388067496.3963/Glib-1.303/typemap blib/arch/Glib/Install/typemap [ XS Glib.xs ] [ CC Glib.c ] [ XS GError.xs ] [ CC GError.c ] [ XS GUtils.xs ] [ CC GUtils.c ] [ XS GLog.xs ] [ CC GLog.c ] [ XS GType.xs ] [ CC GType.c ] [ XS GBoxed.xs ] [ CC GBoxed.c ] [ XS GObject.xs ] [ CC GObject.c ] [ XS GValue.xs ] [ CC GValue.c ] [ XS GClosure.xs ] [ CC GClosure.c ] [ XS GSignal.xs ] [ CC GSignal.c ] [ XS GMainLoop.xs ] [ CC GMainLoop.c ] [ XS GIOChannel.xs ] [ CC GIOChannel.c ] [ XS GParamSpec.xs ] [ CC GParamSpec.c ] [ XS GKeyFile.xs ] [ CC GKeyFile.c ] [ XS GOption.xs ] [ CC GOption.c ] [ XS GBookmarkFile.xs ] [ CC GBookmarkFile.c ] [ CC gperl-gtypes.c ] gperl-gtypes.c: In function ‘gperl_spawn_flags_get_type’: gperl-gtypes.c:190:9: error: ‘G_SPAWN_SEARCH_PATH_FROM_ENVP’ undeclared (first use in this function) gperl-gtypes.c:190:9: note: each undeclared identifier is reported only once for each function it appears in make: *** [gperl-gtypes.o] Error 1 -> FAIL Installing Glib failed. See /home/travis/.cpanm/work/1388067496.3963/build.log for details. Retry with --force to force install it. 1.302 works fine. According to http://about.travis-ci.org/docs/user/ci-environment/, I'm running on Ubuntu 12.04 LTS Server Edition 64 bit.
Download (untitled) / with headers
text/plain 231b
I see this is fixed in https://git.gnome.org/browse/perl-Glib/commit/?id=4e85501a3b03c4636dc1d9529bcacdffcbfadf2c. Would it be possible to release a new version of Glib so that automatic cpan installations work again on travis-ci?
Download (untitled) / with headers
text/plain 737b
On Thu Dec 26 19:23:58 2013, https://www.google.com/accounts/o8/id?id=AItOawkOdS9bt7YQwAMMslElJf1cQ2-9s1nKMGY wrote: Show quoted text
> I see this is fixed in https://git.gnome.org/browse/perl- > Glib/commit/?id=4e85501a3b03c4636dc1d9529bcacdffcbfadf2c. Would it be > possible to release a new version of Glib so that automatic cpan > installations work again on travis-ci?
This issue was already reported in RT#91313. The release deadline for this month's Gtk-Perl release is December 29th. The release of an updated Glib would take place within a few days of that date. Is this bugfix an emergency, i.e. you immediately need an updated Glib package, or can the release of an updated Glib wait until after the previously announced release deadline?
Download (untitled) / with headers
text/plain 884b
On Thu Dec 26 19:37:01 2013, XAOC wrote: Show quoted text
> On Thu Dec 26 19:23:58 2013, > https://www.google.com/accounts/o8/id?id=AItOawkOdS9bt7YQwAMMslElJf1cQ2- > 9s1nKMGY wrote:
> > I see this is fixed in https://git.gnome.org/browse/perl- > > Glib/commit/?id=4e85501a3b03c4636dc1d9529bcacdffcbfadf2c. Would it > > be > > possible to release a new version of Glib so that automatic cpan > > installations work again on travis-ci?
> > This issue was already reported in RT#91313. > > The release deadline for this month's Gtk-Perl release is December > 29th. The release of an updated Glib would take place within a few > days of that date. > > Is this bugfix an emergency, i.e. you immediately need an updated Glib > package, or can the release of an updated Glib wait until after the > previously announced release deadline?
It's not an emergency, and can wait for the next 3-4 days or so.
Brian release 1.304, so this should be fixed now.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.