Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CGI CPAN distribution.

Report information
The Basics
Id: 90791
Status: resolved
Priority: 0/
Queue: CGI

People
Owner: Nobody in particular
Requestors: zefram [...] fysh.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: installs in wrong place for 5.19
Date: Mon, 25 Nov 2013 10:54:02 +0000
To: bug-CGI.pm [...] rt.cpan.org
From: Zefram <zefram [...] fysh.org>
Download (untitled) / with headers
text/plain 727b
CGI.pm now contains use if $] >= 5.019, 'deprecate'; which means that on 5.19 it will generate a deprecation warning if it was installed in the core's library directory. The intended rectification is to install it from CPAN, putting it in the site library directory so that it won't generate the warning. But Makefile.PL in CGI's CPAN distro contains 'INSTALLDIRS' => 'perl', meaning that it *always* installs in the core library directory, and so always generates the deprecation warning on 5.19 even if installed from CPAN. The line in Makefile.PL should probably be 'INSTALLDIRS' => $] < 5.011 ? 'perl' : 'site', so that it will install in the site dirs on versions where that's first in @INC. -zefram
Subject: Re: [rt.cpan.org #90791] installs in wrong place for 5.19
Date: Mon, 25 Nov 2013 06:18:16 -0800
To: Zefram via RT <bug-CGI.pm [...] rt.cpan.org>
From: Mark Stosberg <mark [...] stosberg.com>
Download (untitled) / with headers
text/plain 1.3k
Zefram, Does this recently merged pull request address your concerns? https://github.com/markstos/CGI.pm/pull/30 Otherwise, could you submit further refinements via Github? Mark On Mon, Nov 25, 2013, at 02:54 AM, Zefram via RT wrote: Show quoted text
> Mon Nov 25 05:54:22 2013: Request 90791 was acted upon. > Transaction: Ticket created by zefram@fysh.org > Queue: CGI.pm > Subject: installs in wrong place for 5.19 > Broken in: (no value) > Severity: (no value) > Owner: Nobody > Requestors: zefram@fysh.org > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=90791 > > > > CGI.pm now contains > > use if $] >= 5.019, 'deprecate'; > > which means that on 5.19 it will generate a deprecation warning if it was > installed in the core's library directory. The intended rectification > is to install it from CPAN, putting it in the site library directory > so that it won't generate the warning. But Makefile.PL in CGI's CPAN > distro contains > > 'INSTALLDIRS' => 'perl', > > meaning that it *always* installs in the core library directory, and > so always generates the deprecation warning on 5.19 even if installed > from CPAN. The line in Makefile.PL should probably be > > 'INSTALLDIRS' => $] < 5.011 ? 'perl' : 'site', > > so that it will install in the site dirs on versions where that's first > in @INC. > > -zefram >
Subject: Re: [rt.cpan.org #90791] installs in wrong place for 5.19
Date: Mon, 25 Nov 2013 14:21:39 +0000
To: Mark Stosberg via RT <bug-CGI.pm [...] rt.cpan.org>
From: Zefram <zefram [...] fysh.org>
Download (untitled) / with headers
text/plain 364b
Mark Stosberg via RT wrote: Show quoted text
>Does this recently merged pull request address your concerns?
That's almost equivalent to what I proposed, differing only in behaviour on 5.11, which is not important. It fixes the problem. Show quoted text
>Otherwise, could you submit further refinements via Github?
(Not practically relevant, but) no, I don't drink the Github kool-aid. -zefram
Download (untitled) / with headers
text/plain 241b
This issue has been copied to: https://github.com/leejo/CGI.pm/issues/128 please take all future correspondence there. This ticket will remain open but please do not reply here. This ticket will be closed when the github issue is dealt with.
Subject: Re: [rt.cpan.org #90791] installs in wrong place for 5.19
Date: Thu, 22 May 2014 15:02:16 +0100
To: Lee Johnson via RT <bug-CGI.pm [...] rt.cpan.org>
From: Zefram <zefram [...] fysh.org>
Download (untitled) / with headers
text/plain 247b
Lee Johnson via RT wrote: Show quoted text
>This issue has been copied to: https://github.com/leejo/CGI.pm/issues/128 >please take all future correspondence there.
Can't. Github requires one to have an account with them in order to add a comment there. -zefram


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.