Skip Menu |
 

This queue is for tickets about the JavaScript CPAN distribution.

Report information
The Basics
Id: 90245
Status: open
Priority: 0/
Queue: JavaScript

People
Owner: Nobody in particular
Requestors: draxil [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: JavaScript doesn't build with the version of mozjs in stable debian
Date: Mon, 11 Nov 2013 13:04:54 +0000
To: bug-JavaScript [...] rt.cpan.org
From: joe higton <draxil [...] gmail.com>
Download (untitled) / with headers
text/plain 991b
Building trying to install JavaScript in Debian 7.0 gets me: JavaScript_Env.h:11:28: fatal error: mozjs/jsinterp.h: No such file or directory compilation terminated. Failed compiling test_js.c. ABORTING If I look in the directory I get: ls /usr/include/mozjs/ ds jsatom.h jscpucfg.h jslock.h jsproto.tbl jsutil.h vm gc jsatom.tbl jsdbgapi.h js.msg jsproxy.h jsval.h js jsclass.h jsdhash.h json.h jsprvtd.h jsversion.h jsalloc.h jsclist.h jsfriendapi.h jsperf.h jspubtd.h jswrapper.h jsapi.h js-config.h jsgc.h jsprf.h jstypes.h mozilla The version of libmozjs now in Debian is 1.8.5, so I am guessing they changed the API underneath you. And of course Debian has dropped the package for this module, which is a real shame. I'm trying the manual build route to get an older version of the library working in current debian. Obviously if there's anything I can do to help please ask. Thanks, Joe
Subject: Re: [rt.cpan.org #90245] AutoReply: JavaScript doesn't build with the version of mozjs in stable debian
Date: Mon, 11 Nov 2013 13:15:32 +0000
To: bug-javascript <bug-JavaScript [...] rt.cpan.org>
From: joe higton <draxil [...] gmail.com>
Incidentally I have found what looks to be header file, which is in: /usr/include/js/jsinterp.h
Subject: Re: [rt.cpan.org #90245] AutoReply: JavaScript doesn't build with the version of mozjs in stable debian
Date: Mon, 11 Nov 2013 14:59:52 +0000
To: bug-javascript <bug-JavaScript [...] rt.cpan.org>
From: joe higton <draxil [...] gmail.com>
Download (untitled) / with headers
text/plain 1.9k
If its helpful I tried patching the Makefile.PM to use those files instead, and that allowed some progress but the compile failed with errors: In file included from /usr/include/js/jsobj.h:64:0, from /usr/include/js/jsfun.h:47, from JavaScript_Env.h:11, from test_js.c:2: /usr/include/js/jsvalue.h:113:1: error: unknown type name ‘bool’ /usr/include/js/jsvalue.h: In function ‘JSDOUBLE_IS_INT32’: /usr/include/js/jsvalue.h:116:16: error: ‘false’ undeclared (first use in this function) /usr/include/js/jsvalue.h:116:16: note: each undeclared identifier is reported only once for each function it appears in /usr/include/js/jsvalue.h:117:24: error: expected expression before ‘int32_t’ /usr/include/js/jsvalue.h: At top level: /usr/include/js/jsvalue.h:148:1: error: conflicting types for ‘MAGIC_TO_JSVAL_IMPL’ /usr/include/js/jsvalue.h:139:1: note: previous definition of ‘MAGIC_TO_JSVAL_IMPL’ was here /usr/include/js/jsvalue.h:329:1: error: unknown type name ‘namespace’ /usr/include/js/jsvalue.h:329:14: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token In file included from /usr/include/js/jstl.h:43:0, from /usr/include/js/jsvector.h:44, from /usr/include/js/jsobj.h:65, from /usr/include/js/jsfun.h:47, from JavaScript_Env.h:11, from test_js.c:2: /usr/include/js/jsbit.h:255:1: error: unknown type name ‘namespace’ /usr/include/js/jsbit.h:255:14: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token In file included from /usr/include/js/jsvector.h:44:0, from /usr/include/js/jsobj.h:65, from /usr/include/js/jsfun.h:47, from JavaScript_Env.h:11, from test_js.c:2: /usr/include/js/jstl.h:46:15: fatal error: new: No such file or directory compilation terminated. Failed compiling test_js.c. ABORTING
Download (untitled) / with headers
text/plain 147b
For those reading this who just want to be able to build with older spidermonkey: https://gist.github.com/draxil/b1738684f3f8bac9c230515c3d92c3b6


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.