Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CPAN-Reporter CPAN distribution.

Report information
The Basics
Id: 90237
Status: resolved
Priority: 0/
Queue: CPAN-Reporter

People
Owner: Nobody in particular
Requestors: CHORNY [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.2010
Fixed in: (no value)



Subject: incorrect "Perl version too low"
Download (untitled) / with headers
text/plain 1.9k
Version of main module was defined from another module, but this module is from current distribution, so it can't be loaded and Build.PL fails. In which case /Error evaling version line 'BEGIN/ims appears when perl version is too low? Checking prerequisites... requires: ! AnyEvent is not installed ! AnyEvent::WebSocket::Server is not installed test_requires: ! AnyEvent is not installed ! AnyEvent::WebSocket::Client is not installed ERRORS/WARNINGS FOUND IN PREREQUISITES. You may wish to install the versions of the modules indicated above before proceeding with this installation Run 'Build installdeps' to install missing prerequisites. Error evaling version line 'BEGIN { my $dummy = q# Hide from _packages_inside() #; package Module::Metadata::_version::p6; use version; no strict; no warnings; $vsub = sub { local $VERSION; $VERSION=undef; use Plack::App::WebSocket::Connection; our $VERSION = $Plack::App::WebSocket::Connection::VERSION;; $VERSION }; }' in C:\strawberry5161\cpan\build\Plack-App-WebSocket-0.01-LoJSiC\lib\Plack\App\WebSocket.pm: Can't locate AnyEvent.pm in @INC (@INC contains: lib C:\strawberry5161\cpan\build\Plack-App-WebSocket-0.01-LoJSiC\_build\lib C:/strawberry5161/perl/site/lib C:/strawberry5161/perl/vendor/lib C:/strawberry5161/perl/lib .) at lib/Plack/App/WebSocket/Connection.pm line 7, <GEN8> line 10. BEGIN failed--compilation aborted at lib/Plack/App/WebSocket/Connection.pm line 7, <GEN8> line 10. Compilation failed in require at (eval 42) line 10, <GEN8> line 10. BEGIN failed--compilation aborted at (eval 42) line 10, <GEN8> line 10. failed to build version sub for C:\strawberry5161\cpan\build\Plack-App-WebSocket-0.01-LoJSiC\lib\Plack\App\WebSocket.pm at C:/strawberry5161/perl/site/lib/Module/Build/Base.pm line 1196. CPAN::Reporter: Build.PL result is 'na', Perl version too low. -- Alexandr Ciornii, http://chorny.net


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.