This queue is for tickets about the XML-LibXSLT CPAN distribution.

Report information
The Basics
Id:
90085
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
DAVEWOOD [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
(no value)
Fixed in:
(no value)



Subject: Makefile buggy. doesnt report libxslt version mismatch correctly
Makefile.PL checks for libxslt version incorrectly. The regex: "if ($@ =~ /^VERSION/)" https://metacpan.org/source/SHLOMIF/XML-LibXSLT-1.81/Makefile.PL#L75 doesnt match the previous die: "libxslt versions before 1.1.28 are buggy. Please install libxslt-1.1.28." https://metacpan.org/source/SHLOMIF/XML-LibXSLT-1.81/Makefile.PL#L65 and on line https://metacpan.org/source/SHLOMIF/XML-LibXSLT-1.81/Makefile.PL#L76 you recommend installing 1.1.18 which should probably say 1.1.28 thanks to joel and brother @ channel #perl-help for helping with this issue.
On Wed Nov 06 05:33:06 2013, DAVEWOOD wrote:
Show quoted text
> Makefile.PL checks for libxslt version incorrectly. > > The regex: "if ($@ =~ /^VERSION/)" > https://metacpan.org/source/SHLOMIF/XML-LibXSLT-1.81/Makefile.PL#L75 > > doesnt match the previous die: "libxslt versions before 1.1.28 are > buggy. Please install libxslt-1.1.28." > https://metacpan.org/source/SHLOMIF/XML-LibXSLT-1.81/Makefile.PL#L65 > > and on line https://metacpan.org/source/SHLOMIF/XML-LibXSLT- > 1.81/Makefile.PL#L76 you recommend installing 1.1.18 which should > probably say 1.1.28 > > thanks to joel and brother @ channel #perl-help for helping with this > issue.
Thanks for the report. This was hopefully fixed in XML-LibXSLT-1.82. Resolving. Regards, -- Shlomi Fish


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.