Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CGI CPAN distribution.

Report information
The Basics
Id: 89992
Status: resolved
Priority: 0/
Queue: CGI

People
Owner: Nobody in particular
Requestors: BULKDD [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: url.t fails if env var SCRIPT_NAME is set, url.t fails with Intel C on Win32
Download (untitled) / with headers
text/plain 5.4k
Win32 Intel C Compiler's build environment sets an env var called SCRIPT_NAME. url.t fails if SCRIPT_NAME is set to something when url.t runs. Don't assume SCRIPT_NAME is unset when the tests run. Using CGI 3.63, but https://rt.cpan.org/Dist/Display.html?Name=CGI says to file it here, where the max ver is 3.48. I've never used this module so I don't know anything particular about it. --------------------------------------------------------- C:\p519\src\t>..\perl.exe -I../lib harness ../cpan/CGI/t/url.t ../cpan/CGI/t/url.t .. 1/? # Failed test 'url()' # at t/url.t line 17. # got: 'http://proxy:8484compilervars_arch.bat' # expected: 'http://proxy:8484' # Failed test 'url() with default port' # at t/url.t line 23. # got: 'http://proxycompilervars_arch.bat' # expected: 'http://proxy' # Looks like you failed 2 tests of 5. ../cpan/CGI/t/url.t .. Dubious, test returned 2 (wstat 512, 0x200) Failed 2/5 subtests Test Summary Report ------------------- ../cpan/CGI/t/url.t (Wstat: 512 Tests: 5 Failed: 2) Failed tests: 3-4 Non-zero exit status: 2 Files=1, Tests=5, 0 wallclock secs ( 0.03 usr + 0.02 sys = 0.05 CPU) Result: FAIL C:\p519\src\t>..\perl.exe -I../lib -V Summary of my perl5 (revision 5 version 19 subversion 6) configuration: Derived from: Platform: osname=MSWin32, osvers=5.2, archname=MSWin32-x86-multi-thread uname='' config_args='undef' hint=recommended, useposix=true, d_sigaction=undef useithreads=define, usemultiplicity=define useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef use64bitint=undef, use64bitall=undef, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='icl', ccflags ='-nologo -GF -W3 -O1 -MD -Zi -DNDEBUG -GS- -GL -GL -DWIN3 2 -D_CONSOLE -DNO_STRICT -D_CRT_SECURE_NO_DEPRECATE -D_CRT_NONSTDC_NO_DEPRECATE -DPERL_TEXTMODE_SCRIPTS -DPERL_IMPLICIT_CONTEXT -DPERL_IMPLICIT_SYS -DUSE_PERLI O', optimize='-O1 -MD -Zi -DNDEBUG -GS- -GL -GL', cppflags='-DWIN32' ccversion='12.1.5.344', gccversion='', gccosandvers='' intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234 d_longlong=undef, longlongsize=8, d_longdbl=define, longdblsize=8 ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='__int64', lseeksi ze=8 alignbytes=8, prototype=define Linker and Libraries: ld='xilink', ldflags ='-nologo -nodefaultlib -debug -opt:ref,icf -ltcg -lib path:"c:\p519\lib\CORE" -machine:x86 "/manifestdependency:type='Win32' name='Mi crosoft.Windows.Common-Controls' version='6.0.0.0' processorArchitecture='*' pub licKeyToken='6595b64144ccf1df' language='*'"' libpth=\lib libs=oldnames.lib kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.l ib advapi32.lib shell32.lib ole32.lib oleaut32.lib netapi32.lib uuid.lib ws2_32 .lib mpr.lib winmm.lib version.lib odbc32.lib odbccp32.lib comctl32.lib libircm t.lib libmmd.lib msvcrt.lib perllibs=oldnames.lib kernel32.lib user32.lib gdi32.lib winspool.lib comdlg 32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib netapi32.lib uuid.lib ws 2_32.lib mpr.lib winmm.lib version.lib odbc32.lib odbccp32.lib comctl32.lib lib ircmt.lib libmmd.lib msvcrt.lib libc=msvcrt.lib, so=dll, useshrplib=true, libperl=perl519.lib gnulibc_version='' Dynamic Linking: dlsrc=dl_win32.xs, dlext=dll, d_dlsymun=undef, ccdlflags=' ' cccdlflags=' ', lddlflags='-dll -nologo -nodefaultlib -debug -opt:ref,icf -l tcg -libpath:"c:\p519\lib\CORE" -machine:x86 "/manifestdependency:type='Win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' processorArchitectur e='*' publicKeyToken='6595b64144ccf1df' language='*'"' Characteristics of this binary (from libperl): Compile-time options: HAS_TIMES HAVE_INTERP_INTERN MULTIPLICITY PERLIO_LAYERS PERL_DONT_CREATE_GVSV PERL_HASH_FUNC_ONE_AT_A_TIME_HARD PERL_IMPLICIT_CONTEXT PERL_IMPLICIT_SYS PERL_MALLOC_WRAP PERL_NEW_COPY_ON_WRITE PERL_PRESERVE_IVUV USE_ITHREADS USE_LARGE_FILES USE_LOCALE USE_LOCALE_COLLATE USE_LOCALE_CTYPE USE_LOCALE_NUMERIC USE_PERLIO USE_PERL_ATOF Locally applied patches: uncommitted-changes Built under MSWin32 Compiled at Nov 2 2013 19:37:34 %ENV: PERL_JSON_BACKEND="JSON::XS" PERL_YAML_BACKEND="YAML" @INC: ../lib C:/p519/src/lib . C:\p519\src\t>set SCRIPT_NAME=not_empty_string C:\p519\src\t>..\perl.exe -I../lib harness ../cpan/CGI/t/url.t ../cpan/CGI/t/url.t .. 1/? # Failed test 'url()' # at t/url.t line 17. # got: 'http://proxy:8484not_empty_string' # expected: 'http://proxy:8484' # Failed test 'url() with default port' # at t/url.t line 23. # got: 'http://proxynot_empty_string' # expected: 'http://proxy' # Looks like you failed 2 tests of 5. ../cpan/CGI/t/url.t .. Dubious, test returned 2 (wstat 512, 0x200) Failed 2/5 subtests Test Summary Report ------------------- ../cpan/CGI/t/url.t (Wstat: 512 Tests: 5 Failed: 2) Failed tests: 3-4 Non-zero exit status: 2 Files=1, Tests=5, 0 wallclock secs ( 0.03 usr + 0.00 sys = 0.03 CPU) Result: FAIL C:\p519\src\t>set SCRIPT_NAME= C:\p519\src\t>..\perl.exe -I../lib harness ../cpan/CGI/t/url.t ../cpan/CGI/t/url.t .. ok All tests successful. Files=1, Tests=5, 0 wallclock secs ( 0.02 usr + 0.01 sys = 0.03 CPU) Result: PASS C:\p519\src\t> ---------------------------------------------------------
Download (untitled) / with headers
text/plain 241b
This issue has been copied to: https://github.com/leejo/CGI.pm/issues/127 please take all future correspondence there. This ticket will remain open but please do not reply here. This ticket will be closed when the github issue is dealt with.
Download (untitled) / with headers
text/plain 383b
commit 65fa86d1e59b45fc620d01fe345454f90ba781c9 Author: Lee Johnson <lee@givengain.ch> Date: Wed Jul 16 18:39:09 2014 +0200 resolve #127 [rt.cpan.org #89992] - fix t/url.t on Win32 platforms, which may or may not have the SCRIPT_NAME env variable set to something already when this test runs. so delete the value of SCRIPT_NAME in the script's env to fix the test


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.