This queue is for tickets about the DBI CPAN distribution.

Report information
The Basics
Id:
89847
Status:
new
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
TruesdellDouglasA [...] JohnDeere.com
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)



Subject: Add dependency for RPC::PlClient
Date: Tue, 29 Oct 2013 15:50:51 +0000
To: "bug-DBI@rt.cpan.org" <bug-DBI@rt.cpan.org>
From: Truesdell Douglas A <TruesdellDouglasA@JohnDeere.com>

Hi,

 

This is a small thing that showed up when I built a fresh Perl instance that includes DBD::Proxy. I used cpanm to install. My Perl version is 5.18.1 on linux-i386. A customer script threw the error below until I installed RPC::PlClient.

 

My read: DBD/Proxy.pm uses RPC::PlClient, but does not list it as a dependency. META.jason does not require RPC::PlClient, but it “recommends”  RPC::PlServer.

 

I did NOT use the cpanm –with-recommends when I installed.

 

install_driver(Proxy) failed: Can't locate RPC/PlClient.pm in @INC (you may need to install the RPC::PlClient module) (@INC contains: /usr/local/etc/inventory /usr/local/perl/ /www/perl/lib/site_perl/5.18.1/i686-linux-thread-multi /www/perl/lib/site_perl/5.18.1 /www/perl/lib/5.18.1/i686-linux-thread-multi /www/perl/lib/5.18.1 .) at /www/perl/lib/site_perl/5.18.1/i686-linux-thread-multi/DBD/Proxy.pm line 29.

BEGIN failed--compilation aborted at /www/perl/lib/site_perl/5.18.1/i686-linux-thread-multi/DBD/Proxy.pm line 29.

Compilation failed in require at (eval 3) line 3.

Perhaps a module that DBD::Proxy requires hasn't been fully installed

 

 

Doug Truesdell
  IPN Web Services
  Deere & Company
  720 328 5478

 



This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.