Skip Menu |
 

This queue is for tickets about the Perl-Critic-Deprecated CPAN distribution.

Report information
The Basics
Id: 89840
Status: resolved
Priority: 0/
Queue: Perl-Critic-Deprecated

People
Owner: Nobody in particular
Requestors: ppisar [...] redhat.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.118
Fixed in: (no value)



Subject: README does not list all included policies
Download (untitled) / with headers
text/plain 497b
1.118 version added Perl::Critic::Policy::Miscellanea::RequireRcsKeywords policy, but its not listed in the README file: DESCRIPTION The included policies are: Perl::Critic::Policy::NamingConventions::ProhibitMixedCaseSubs Write "$my_variable = 42" instead of "$MyVariable = 42". [Default severity 1] Perl::Critic::Policy::NamingConventions::ProhibitMixedCaseVars Write "sub my_function{}" instead of "sub MyFunction{}". [Default severity 1] -- Petr
This has been fixed and released as Perl-Critic-Deprecated-1.119. Thanks for pointing it out.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.