Skip Menu |
 

This queue is for tickets about the PathTools CPAN distribution.

Report information
The Basics
Id: 89664
Status: open
Priority: 0/
Queue: PathTools

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
jkeenan [...] cpan.org
KENTNL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 3.40
Fixed in: (no value)



Subject: Should not install to archlib on >5.12

Given how the @INC order changed in >=5.11, the behaviour of clobbering archlib's files is no longer necessary, as installing to sitelib now automatically shadows.

And an unfortunate consequence of installing to archlib, means that if you're foolish and accidentally install from CPAN, you'll possibly find yourself installing an *OLDER* version of PathTools, and having it clobber your PathTools from Perl, with no way to "undo" that accident short of reinstalling perl from scratch.

Carp does the right thing: https://metacpan.org/source/ZEFRAM/Carp-1.32/Makefile.PL#L18

    INSTALLDIRS => "$]" < 5.011 ? "perl" : "site",

 

So this is merely a request that PathTools follows that example and installs to sitelib where relevant.

 

On Mon Oct 21 17:46:20 2013, KENTNL wrote: Show quoted text
> Given how the @INC order changed in >=5.11, the behaviour of > clobbering > archlib's files is no longer necessary, as installing to sitelib now > automatically shadows. > > And an unfortunate consequence of installing to archlib, means that if > you're > foolish and accidentally install from CPAN, you'll possibly find > yourself > installing an *OLDER* version of PathTools, and having it clobber your > PathTools from Perl, with no way to "undo" that accident short of > reinstalling > perl from scratch. > > Carp does the right thing: > https://metacpan.org/source/ZEFRAM/Carp-1.32/Makefile.PL#L18 > > INSTALLDIRS => "$]" < 5.011 ? "perl" : "site", > > So this is merely a request that PathTools follows that example and > installs to > sitelib where relevant.
This is a subset of the Makefile problems being discussed in rt.perl.org's ticket #116479. I have prepared a patch located here: https://rt.perl.org/Ticket/Attachment/1269633/667195/116479-cwd-insufficient.patch ... but it is causing ancillary test failures.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.