Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 89180
Status: stalled
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: (no value)
Fixed in: (no value)



Subject: add rules for all non-dual-life modules that are specified with a minimum version
Download (untitled) / with headers
text/plain 577b
'use strict 1.08' should turn into a dependency on perl 5.19.2, since strict is non-dual-lifed and that's the version of perl that first shipped with that version. This can get tricky when, say, 5.18.2 then later ships with that version, so maybe we shouldn't inject this prereq until a stable perl ships with that version. This isn't quite doable now, but will be when Module::CoreList has the ability to tell us which modules are dual-lifed. (I'm currently in the middle of writing that feature.) Anyone who reads this later: please feel free to poke me to do this work.
chorny: why is this marked 'stalled'? what is the blockage?
Download (untitled) / with headers
text/plain 254b
On 2013-12-19 11:26:05, ETHER wrote: Show quoted text
> chorny: why is this marked 'stalled'? what is the blockage?
lol never mind. I haven't finished the Module::CoreList work yet -- it's still blocked on some files moving around in blead between dist/, ext/ and lib/.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.