Skip Menu |
 

This queue is for tickets about the Object-InsideOut CPAN distribution.

Report information
The Basics
Id: 89112
Status: resolved
Priority: 0/
Queue: Object-InsideOut

People
Owner: Nobody in particular
Requestors: swen [...] ethz.ch
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: 3.98



Subject: Version mismatch
Date: Tue, 1 Oct 2013 16:18:13 +0000
To: "bug-Object-InsideOut [...] rt.cpan.org" <bug-Object-InsideOut [...] rt.cpan.org>
From: "Vermeul Swen (SWS)" <swen [...] ethz.ch>
Download (untitled) / with headers
text/plain 816b
When I use Object::InsideOut (Version 3.97, Perl v5.14.1) in combination with some of my own modules, I get the following error: OIO::Internal error: Failure compiling file 'Object/InsideOut/Universal.pm' Error: OIO error: Trapped uncaught error Error: Version mismatch Package: Object::InsideOut I haven't found out what is causing the problem yet, but fixed the problem by altering the line # Ensure correct versioning ($Object::InsideOut::VERSION == 3.97) or die("Version mismatch\n"); to # Ensure correct versioning ($Object::InsideOut::VERSION eq 3.97) or die("Version mismatch\n"); in the modules Object/InsideOut/Universal.pm Object/InsideOut/Cumulative.pm Object/InsideOut/Autoload.pm etc. Maybe you have an idea what is going wrong? In any case: great module! Best regards, Swen
Subject: Re: [rt.cpan.org #89112] Version mismatch
Date: Tue, 1 Oct 2013 12:59:10 -0400
To: bug-Object-InsideOut [...] rt.cpan.org
From: "Jerry D. Hedden" <jdhedden [...] cpan.org>
Download (untitled) / with headers
text/plain 1.3k
Thanks. I fix this up for the next release. On Tue, Oct 1, 2013 at 12:18 PM, Vermeul Swen via RT <bug-Object-InsideOut@rt.cpan.org> wrote: Show quoted text
> Tue Oct 01 12:18:31 2013: Request 89112 was acted upon. > Transaction: Ticket created by swen@ethz.ch > Queue: Object-InsideOut > Subject: Version mismatch > Broken in: (no value) > Severity: (no value) > Owner: Nobody > Requestors: swen@ethz.ch > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=89112 > > > > When I use Object::InsideOut (Version 3.97, Perl v5.14.1) in combination > with some of my own modules, I get the following error: > > OIO::Internal error: Failure compiling file 'Object/InsideOut/Universal.pm' > Error: OIO error: Trapped uncaught error > Error: Version mismatch > Package: Object::InsideOut > > > I haven't found out what is causing the problem yet, but > fixed the problem by altering the line > > # Ensure correct versioning > ($Object::InsideOut::VERSION == 3.97) > or die("Version mismatch\n"); > > to > > # Ensure correct versioning > ($Object::InsideOut::VERSION eq 3.97) > or die("Version mismatch\n"); > > > in the modules > > Object/InsideOut/Universal.pm > Object/InsideOut/Cumulative.pm > Object/InsideOut/Autoload.pm > > etc. > > > Maybe you have an idea what is going wrong? > > > In any case: great module! > > > Best regards, > > > Swen > >
Fixed in v3.98


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.